14.0.0 Release
Resolves: rhbz#2061041
This commit is contained in:
parent
04ee07633d
commit
381b080c4f
2
.gitignore
vendored
2
.gitignore
vendored
@ -81,3 +81,5 @@
|
||||
/compiler-rt-13.0.0.src.tar.xz.sig
|
||||
/compiler-rt-13.0.1.src.tar.xz
|
||||
/compiler-rt-13.0.1.src.tar.xz.sig
|
||||
/compiler-rt-14.0.0.src.tar.xz
|
||||
/compiler-rt-14.0.0.src.tar.xz.sig
|
||||
|
@ -1,44 +0,0 @@
|
||||
From f4d4ada2e920136870468f43e0f3c1efa265f2f7 Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Thu, 25 Feb 2021 14:12:57 +0100
|
||||
Subject: [PATCH] [PATCH][compiler-rt] Workaround libstdc++ limitation wrt.
|
||||
thread copy
|
||||
|
||||
---
|
||||
compiler-rt/lib/fuzzer/FuzzerDefs.h | 6 ++++++
|
||||
compiler-rt/lib/fuzzer/FuzzerDriver.cpp | 2 +-
|
||||
2 files changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/compiler-rt/lib/fuzzer/FuzzerDefs.h b/compiler-rt/lib/fuzzer/FuzzerDefs.h
|
||||
index 1a2752a..abfbb8d 100644
|
||||
--- a/compiler-rt/lib/fuzzer/FuzzerDefs.h
|
||||
+++ b/compiler-rt/lib/fuzzer/FuzzerDefs.h
|
||||
@@ -50,6 +50,12 @@ template<typename T>
|
||||
|
||||
template<class Other>
|
||||
struct rebind { typedef fuzzer_allocator<Other> other; };
|
||||
+
|
||||
+ template< class U, class... Args >
|
||||
+ void construct( U* p, Args&&... args ) {
|
||||
+ std::allocator<T>::construct(p, std::forward<Args>(args)...);
|
||||
+ }
|
||||
+
|
||||
};
|
||||
|
||||
template<typename T>
|
||||
diff --git a/compiler-rt/lib/fuzzer/FuzzerDriver.cpp b/compiler-rt/lib/fuzzer/FuzzerDriver.cpp
|
||||
index 447cafc..2fce139 100644
|
||||
--- a/compiler-rt/lib/fuzzer/FuzzerDriver.cpp
|
||||
+++ b/compiler-rt/lib/fuzzer/FuzzerDriver.cpp
|
||||
@@ -294,7 +294,7 @@ static int RunInMultipleProcesses(const Vector<std::string> &Args,
|
||||
std::thread Pulse(PulseThread);
|
||||
Pulse.detach();
|
||||
for (unsigned i = 0; i < NumWorkers; i++)
|
||||
- V.push_back(std::thread(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors));
|
||||
+ V.emplace_back(WorkerThread, std::ref(Cmd), &Counter, NumJobs, &HasErrors);
|
||||
for (auto &T : V)
|
||||
T.join();
|
||||
return HasErrors ? 1 : 0;
|
||||
--
|
||||
1.8.3.1
|
||||
|
37
add-llvm-cmake-package.patch
Normal file
37
add-llvm-cmake-package.patch
Normal file
@ -0,0 +1,37 @@
|
||||
commit b18bde7a9bd6ed80f5721c47c805f0158b4fe9f8
|
||||
Author: Timm Bäder <tbaeder@redhat.com>
|
||||
Date: Wed Mar 9 07:17:21 2022 +0100
|
||||
|
||||
[compiler-rt] Add LLVM cmake package in standalone builds
|
||||
|
||||
So the other files from the toplevel cmake/Modules directory have a
|
||||
chance of being found.
|
||||
|
||||
diff --git a/compiler-rt/CMakeLists.txt b/compiler-rt/CMakeLists.txt
|
||||
index 3a41aa43e406..6516e10fa3c5 100644
|
||||
--- a/compiler-rt/CMakeLists.txt
|
||||
+++ b/compiler-rt/CMakeLists.txt
|
||||
@@ -28,6 +28,12 @@ else()
|
||||
set(CMAKE_CFG_RESOLVED_INTDIR "")
|
||||
endif()
|
||||
|
||||
+if(COMPILER_RT_STANDALONE_BUILD)
|
||||
+ # Needed to find the other modules from the toplevel cmake/Modules dir
|
||||
+ find_package(LLVM REQUIRED HINTS "${LLVM_CMAKE_DIR}")
|
||||
+ list(APPEND CMAKE_MODULE_PATH "${LLVM_DIR}")
|
||||
+endif()
|
||||
+
|
||||
include(SetPlatformToolchainTools)
|
||||
include(base-config-ix)
|
||||
include(CompilerRTUtils)
|
||||
diff --git a/compiler-rt/test/CMakeLists.txt b/compiler-rt/test/CMakeLists.txt
|
||||
index 5c2b634e1180..098fb0481517 100644
|
||||
--- a/compiler-rt/test/CMakeLists.txt
|
||||
+++ b/compiler-rt/test/CMakeLists.txt
|
||||
@@ -1,6 +1,3 @@
|
||||
-# Needed for lit support in standalone builds.
|
||||
-include(AddLLVM)
|
||||
-
|
||||
option(COMPILER_RT_TEST_STANDALONE_BUILD_LIBS
|
||||
"When set to ON and testing in a standalone build, test the runtime \
|
||||
libraries built by this standalone build rather than the runtime libraries \
|
@ -1,6 +1,5 @@
|
||||
#global rc_ver 3
|
||||
|
||||
%global compiler_rt_version 13.0.1
|
||||
%global compiler_rt_version 14.0.0
|
||||
#global rc_ver 2
|
||||
%global crt_srcdir compiler-rt-%{compiler_rt_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
# see https://sourceware.org/bugzilla/show_bug.cgi?id=25271
|
||||
@ -20,14 +19,14 @@ Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compil
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz.sig
|
||||
Source2: tstellar-gpg-key.asc
|
||||
|
||||
Patch0: 0001-PATCH-compiler-rt-Workaround-libstdc-limitation-wrt..patch
|
||||
Patch0: add-llvm-cmake-package.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: python3
|
||||
# We need python3-devel for pathfix.py.
|
||||
# We need python3-devel for %%py3_shebang_fix
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: llvm-devel = %{version}
|
||||
|
||||
@ -46,10 +45,10 @@ instrumentation, and Blocks C language extension.
|
||||
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%autosetup -n %{crt_srcdir} -p2
|
||||
|
||||
pathfix.py -i %{__python3} -pn lib/hwasan/scripts/hwasan_symbolize
|
||||
%py3_shebang_fix lib/hwasan/scripts/hwasan_symbolize
|
||||
|
||||
%build
|
||||
%cmake -GNinja \
|
||||
%cmake -GNinja \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config-%{__isa_bits} \
|
||||
-DCMAKE_SKIP_RPATH:BOOL=ON \
|
||||
@ -104,13 +103,16 @@ popd
|
||||
%files
|
||||
%license LICENSE.TXT
|
||||
%{_includedir}/*
|
||||
%{_libdir}/clang/%{version}/lib/*
|
||||
%{_libdir}/clang/%{version}/share/*
|
||||
%{_libdir}/clang/%{compiler_rt_version}/lib/*
|
||||
%{_libdir}/clang/%{compiler_rt_version}/share/*
|
||||
%ifarch x86_64 aarch64
|
||||
%{_bindir}/hwasan_symbolize
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Apr 25 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
|
||||
- 14.0.0 Release
|
||||
|
||||
* Thu Feb 03 2022 Tom Stellard <tstellar@redhat.com> - 13.0.1-1
|
||||
- 13.0.1 Release
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (compiler-rt-13.0.1.src.tar.xz) = 2cdc3d5cfe5fcf7eba497912ccaadcf33dbd2dd029840fbd54c861b24927e5f4dd494b1ecee1c6c8abbd21e1adf08c217448f408d75346147bac15000fe9ec29
|
||||
SHA512 (compiler-rt-13.0.1.src.tar.xz.sig) = c143c2122ab52f5295f8c32063c7f3822ac2c49fa12121d60fa89f6c99d54709d47a0c6bf41794858de92213f8304bee5a4cf82706b00ac31a2097cca9549efe
|
||||
SHA512 (compiler-rt-14.0.0.src.tar.xz) = 9df73ef3b81f2b70902726e0dc5529c0cc1e976ce75fbfb1c3d7930882d82fc0896934a32d1c9511b08962cac5b409c14f54dc53833fbf0724256b22165c4439
|
||||
SHA512 (compiler-rt-14.0.0.src.tar.xz.sig) = 3998c7a7477a95ae36591b8658677a44f5d4c88a57e93df57fc3f4670c38a71fb0e385b7f9b44ef7e97d7ce77551b4ea790c6f63174e79a2ffc9dd678dcf886f
|
||||
|
Loading…
Reference in New Issue
Block a user