import codemodel-2.6-24.el8

This commit is contained in:
CentOS Sources 2020-12-17 16:38:35 +00:00 committed by Andrew Lukoshko
commit d82d865c5d
4 changed files with 268 additions and 0 deletions

1
.codemodel.metadata Normal file
View File

@ -0,0 +1 @@
726783fd7f9aca7e39cb05721a215f01e5a27050 SOURCES/codemodel-2.6.tar.gz

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/codemodel-2.6.tar.gz

View File

@ -0,0 +1,130 @@
commit 1c15b90aa77cbc242bcec7ea3b38eb46e4c037cb
Author: Juan Hernandez <juan.hernandez@redhat.com>
Date: Sat Mar 31 16:25:02 2012 +0200
Remove the dependency on istack-commons
diff --git a/codemodel-annotation-compiler/pom.xml b/codemodel-annotation-compiler/pom.xml
index 100e084..e1459bc 100644
--- a/codemodel-annotation-compiler/pom.xml
+++ b/codemodel-annotation-compiler/pom.xml
@@ -60,17 +60,6 @@
<version>2.6</version>
</dependency>
<dependency>
- <groupId>com.sun.istack</groupId>
- <artifactId>istack-commons-tools</artifactId>
- <version>2.5</version>
- <exclusions>
- <exclusion>
- <groupId>org.apache.ant</groupId>
- <artifactId>ant</artifactId>
- </exclusion>
- </exclusions>
- </dependency>
- <dependency>
<groupId>org.apache.ant</groupId>
<artifactId>ant</artifactId>
<version>1.7.0</version>
diff --git a/codemodel-annotation-compiler/src/main/java/com/sun/codemodel/ac/ACTask.java b/codemodel-annotation-compiler/src/main/java/com/sun/codemodel/ac/ACTask.java
index d5b0a14..c6d799d 100644
--- a/codemodel-annotation-compiler/src/main/java/com/sun/codemodel/ac/ACTask.java
+++ b/codemodel-annotation-compiler/src/main/java/com/sun/codemodel/ac/ACTask.java
@@ -64,7 +64,6 @@ import com.sun.codemodel.JDefinedClass;
import com.sun.codemodel.JMod;
import com.sun.codemodel.JPackage;
import com.sun.codemodel.JType;
-import com.sun.istack.tools.MaskingClassLoader;
import java.io.Closeable;
import java.net.MalformedURLException;
import java.net.URL;
diff --git a/codemodel-annotation-compiler/src/main/java/com/sun/codemodel/ac/MaskingClassLoader.java b/codemodel-annotation-compiler/src/main/java/com/sun/codemodel/ac/MaskingClassLoader.java
new file mode 100644
index 0000000..d303c11
--- /dev/null
+++ b/codemodel-annotation-compiler/src/main/java/com/sun/codemodel/ac/MaskingClassLoader.java
@@ -0,0 +1,84 @@
+/*
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS HEADER.
+ *
+ * Copyright (c) 1997-2010 Oracle and/or its affiliates. All rights reserved.
+ *
+ * The contents of this file are subject to the terms of either the GNU
+ * General Public License Version 2 only ("GPL") or the Common Development
+ * and Distribution License("CDDL") (collectively, the "License"). You
+ * may not use this file except in compliance with the License. You can
+ * obtain a copy of the License at
+ * https://glassfish.dev.java.net/public/CDDL+GPL_1_1.html
+ * or packager/legal/LICENSE.txt. See the License for the specific
+ * language governing permissions and limitations under the License.
+ *
+ * When distributing the software, include this License Header Notice in each
+ * file and include the License file at packager/legal/LICENSE.txt.
+ *
+ * GPL Classpath Exception:
+ * Oracle designates this particular file as subject to the "Classpath"
+ * exception as provided by Oracle in the GPL Version 2 section of the License
+ * file that accompanied this code.
+ *
+ * Modifications:
+ * If applicable, add the following below the License Header, with the fields
+ * enclosed by brackets [] replaced by your own identifying information:
+ * "Portions Copyright [year] [name of copyright owner]"
+ *
+ * Contributor(s):
+ * If you wish your version of this file to be governed by only the CDDL or
+ * only the GPL Version 2, indicate your decision by adding "[Contributor]
+ * elects to include this software in this distribution under the [CDDL or GPL
+ * Version 2] license." If you don't indicate a single choice of license, a
+ * recipient has the option to distribute your version of this file under
+ * either the CDDL, the GPL Version 2 or to extend the choice of license to
+ * its licensees as provided above. However, if you add GPL Version 2 code
+ * and therefore, elected the GPL Version 2 license, then the option applies
+ * only if the new code is made subject to such option by the copyright
+ * holder.
+ */
+
+package com.sun.codemodel.ac;
+
+import java.util.Collection;
+
+/**
+ * {@link ClassLoader} that masks a specified set of classes
+ * from its parent class loader.
+ *
+ * <p>
+ * This code is used to create an isolated environment.
+ *
+ * @author Kohsuke Kawaguchi
+ */
+public class MaskingClassLoader extends ClassLoader {
+
+ private final String[] masks;
+
+ public MaskingClassLoader(String... masks) {
+ this.masks = masks;
+ }
+
+ public MaskingClassLoader(Collection<String> masks) {
+ this(masks.toArray(new String[masks.size()]));
+ }
+
+ public MaskingClassLoader(ClassLoader parent, String... masks) {
+ super(parent);
+ this.masks = masks;
+ }
+
+ public MaskingClassLoader(ClassLoader parent, Collection<String> masks) {
+ this(parent, masks.toArray(new String[masks.size()]));
+ }
+
+ @Override
+ protected synchronized Class<?> loadClass(String name, boolean resolve) throws ClassNotFoundException {
+ for (String mask : masks) {
+ if(name.startsWith(mask))
+ throw new ClassNotFoundException();
+ }
+
+ return super.loadClass(name, resolve);
+ }
+}

136
SPECS/codemodel.spec Normal file
View File

@ -0,0 +1,136 @@
Name: codemodel
Version: 2.6
Release: 24%{?dist}
Summary: Java library for code generators
License: CDDL-1.1 or GPLv2 with exceptions
URL: http://codemodel.java.net
# svn export https://svn.java.net/svn/codemodel~svn/tags/codemodel-project-2.6/ codemodel-2.6
# tar -zcvf codemodel-2.6.tar.gz codemodel-2.6
Source0: %{name}-%{version}.tar.gz
# Remove the dependency on istack-commons (otherwise it will be a
# recursive dependency with the upcoming changes to that package):
Patch0: %{name}-remove-istack-commons-dependency.patch
BuildArch: noarch
BuildRequires: maven-local
BuildRequires: mvn(junit:junit)
BuildRequires: mvn(net.java:jvnet-parent:pom:)
BuildRequires: mvn(org.apache.ant:ant)
%description
CodeModel is a Java library for code generators; it provides a way to
generate Java programs in a way much nicer than PrintStream.println().
This project is a spin-off from the JAXB RI for its schema compiler
to generate Java source files.
%package javadoc
Summary: Javadoc for %{name}
%description javadoc
This package contains the API documentation for %{name}.
%prep
# Unpack and patch the original source:
%setup -q
%patch0 -p1
# Remove bundled jar files:
find . -name '*.jar' -print -delete
%mvn_file :%{name} %{name}
%mvn_file :%{name}-annotation-compiler %{name}-annotation-compiler
%build
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
%install
%mvn_install
%files -f .mfiles
%license LICENSE.html
%files javadoc -f .mfiles-javadoc
%license LICENSE.html
%changelog
* Fri May 25 2018 Michael Simacek <msimacek@redhat.com> - 2.6-24
- Regenerate BRs
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Nov 09 2017 Michael Simacek <msimacek@redhat.com> - 2.6-22
- Change license to CDDL-1.1 or GPLv2 with exceptions
* Wed Nov 08 2017 Michael Simacek <msimacek@redhat.com> - 2.6-21
- Change license to CDDL-1.1 and GPLv2
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-20
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.6-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Fri Feb 13 2015 gil cattaneo <puntogil@libero.it> 2.6-16
- introduce license macro
* Tue Jun 24 2014 Michael Simacek <msimacek@redhat.com> - 2.6-15
- Chnage jvnet-parent BR to jvnet-parent:pom
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Thu May 22 2014 Michael Simacek <msimacek@redhat.com> - 2.6-13
- Change maven-surefire-provider-junit4 dependency to
maven-surefire-provider-junit
* Thu Mar 20 2014 Michael Simacek <msimacek@redhat.com> - 2.6-12
- Remove BR java-devel
* Thu Mar 13 2014 Michael Simacek <msimacek@redhat.com> - 2.6-11
- Drop manual requires
* Mon Aug 05 2013 gil cattaneo <puntogil@libero.it> 2.6-10
- rebuilt FTBFS in rawhide
- swith to Xmvn
- adapt to new guideline
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 2.6-7
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
- Replace maven BuildRequires with maven-local
* Sat Jul 21 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.6-6
- Add maven-enforcer-plugin as build time dependeny
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Sat Mar 31 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.6-4
- Restore the dependency on jvnet-parent
- Remove the dependency on istack-commons
* Tue Feb 14 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.6-3
- Added build requirement for maven-surefire-provider-junit4
* Tue Feb 14 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.6-2
- Cleanup of the spec file
* Mon Jan 16 2012 Marek Goldmann <mgoldman@redhat.com> 2.6-1
- Initial packaging