Add patch to fix DEL key in ccmake (bug 869769)
This commit is contained in:
parent
1d798ab1d9
commit
dfcce6627e
14
cmake-ccmake-del-in-first-column.patch
Normal file
14
cmake-ccmake-del-in-first-column.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff --git a/Source/CursesDialog/cmCursesStringWidget.cxx b/Source/CursesDialog/cmCursesStringWidget.cxx
|
||||
index 5c7414f..bd1ff71 100644
|
||||
--- a/Source/CursesDialog/cmCursesStringWidget.cxx
|
||||
+++ b/Source/CursesDialog/cmCursesStringWidget.cxx
|
||||
@@ -175,7 +175,7 @@ bool cmCursesStringWidget::HandleInput(int& key, cmCursesMainForm* fm,
|
||||
}
|
||||
else if ( key == ctrl('d') ||key == KEY_DC )
|
||||
{
|
||||
- if ( form->curcol > 0 )
|
||||
+ if ( form->curcol >= 0 )
|
||||
{
|
||||
form_driver(form, REQ_DEL_CHAR);
|
||||
}
|
||||
|
10
cmake.spec
10
cmake.spec
@ -8,7 +8,7 @@
|
||||
|
||||
Name: cmake
|
||||
Version: 2.8.10
|
||||
Release: 0.1.rc3%{?dist}
|
||||
Release: 0.2.rc3%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -30,6 +30,10 @@ Patch2: cmake-findruby.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=828467
|
||||
# http://public.kitware.com/Bug/view.php?id=13378
|
||||
Patch3: cmake-FindPostgreSQL.patch
|
||||
# Patch to fix ccmake DEL issue
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=869769
|
||||
# http://public.kitware.com/Bug/view.php?id=13604
|
||||
Patch4: cmake-ccmake-del-in-first-column.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: gcc-gfortran
|
||||
@ -81,6 +85,7 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
%patch0 -p1 -b .dcmtk
|
||||
%patch2 -p1 -b .findruby
|
||||
%patch3 -p1 -b .findpostgresql
|
||||
%patch4 -p1 -b .ccmake-del
|
||||
|
||||
|
||||
%build
|
||||
@ -177,6 +182,9 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Oct 24 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.10-0.2.rc3
|
||||
- Add patch to fix DEL key in ccmake (bug 869769)
|
||||
|
||||
* Wed Oct 24 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.10-0.1.rc3
|
||||
- Update to 2.8.10 RC 3
|
||||
- Rebase FindRuby and FindPostgreSQL patches
|
||||
|
Loading…
Reference in New Issue
Block a user