Update to 2.8.10 RC 3
Rebase FindRuby and FindPostgreSQL patches
This commit is contained in:
parent
35d1ae4b3f
commit
1d798ab1d9
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@ cmake-2.8.2.tar.gz
|
||||
/cmake-2.8.9-rc2.tar.gz
|
||||
/cmake-2.8.9-rc3.tar.gz
|
||||
/cmake-2.8.9.tar.gz
|
||||
/cmake-2.8.10-rc3.tar.gz
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- cmake-2.8.8/Modules/FindPostgreSQL.cmake 2012-04-18 20:10:54.000000000 +0200
|
||||
+++ cmake-2.8.8/Modules/FindPostgreSQL.cmake 2012-07-04 23:05:30.532090522 +0200
|
||||
@@ -97,76 +97,101 @@ set( PostgreSQL_ROOT_DIRECTORIES
|
||||
diff -up cmake-2.8.10-rc3/Modules/FindPostgreSQL.cmake.findpostgresql cmake-2.8.10-rc3/Modules/FindPostgreSQL.cmake
|
||||
--- cmake-2.8.10-rc3/Modules/FindPostgreSQL.cmake.findpostgresql 2012-10-24 11:12:01.000000000 -0600
|
||||
+++ cmake-2.8.10-rc3/Modules/FindPostgreSQL.cmake 2012-10-24 19:49:54.189433358 -0600
|
||||
@@ -92,77 +92,99 @@ set( PostgreSQL_ROOT_DIRECTORIES
|
||||
#
|
||||
# Look for an installation.
|
||||
#
|
||||
@ -28,12 +29,22 @@
|
||||
- # Look in other places.
|
||||
- ${PostgreSQL_ROOT_DIRECTORIES}
|
||||
- PATH_SUFFIXES
|
||||
- postgresql
|
||||
- pgsql/server
|
||||
- postgresql/server
|
||||
- include/server
|
||||
- # Help the user find it if we cannot.
|
||||
- DOC "The ${PostgreSQL_INCLUDE_DIR_MESSAGE}"
|
||||
-)
|
||||
-
|
||||
-# The PostgreSQL library.
|
||||
-set (PostgreSQL_LIBRARY_TO_FIND pq)
|
||||
-# Setting some more prefixes for the library
|
||||
-set (PostgreSQL_LIB_PREFIX "")
|
||||
-if ( WIN32 )
|
||||
- set (PostgreSQL_LIB_PREFIX ${PostgreSQL_LIB_PREFIX} "lib")
|
||||
- set ( PostgreSQL_LIBRARY_TO_FIND ${PostgreSQL_LIB_PREFIX}${PostgreSQL_LIBRARY_TO_FIND})
|
||||
-endif()
|
||||
+macro (fail_if)
|
||||
+ if (${ARGV})
|
||||
+ message (WARNING "Couldn't determine PostgreSQL configuration.")
|
||||
@ -96,15 +107,6 @@
|
||||
+ fail_if (NOT PostgreSQL_LIBRARY_FOUND)
|
||||
+ set (PostgreSQL_LIBRARIES ${PostgreSQL_LIBRARY_TO_FIND})
|
||||
|
||||
-# The PostgreSQL library.
|
||||
-set (PostgreSQL_LIBRARY_TO_FIND pq)
|
||||
-# Setting some more prefixes for the library
|
||||
-set (PostgreSQL_LIB_PREFIX "")
|
||||
-if ( WIN32 )
|
||||
- set (PostgreSQL_LIB_PREFIX ${PostgreSQL_LIB_PREFIX} "lib")
|
||||
- set ( PostgreSQL_LIBRARY_TO_FIND ${PostgreSQL_LIB_PREFIX}${PostgreSQL_LIBRARY_TO_FIND})
|
||||
-endif()
|
||||
-
|
||||
-find_library( PostgreSQL_LIBRARY
|
||||
- NAMES ${PostgreSQL_LIBRARY_TO_FIND}
|
||||
- PATHS
|
||||
@ -122,10 +124,10 @@
|
||||
- PostgreSQL_VERSION_STRING "${pgsql_version_str}")
|
||||
- unset(pgsql_version_str)
|
||||
-endif()
|
||||
+endforeach ()
|
||||
+endforeach()
|
||||
|
||||
# Did we find anything?
|
||||
-include(FindPackageHandleStandardArgs)
|
||||
-include(${CMAKE_CURRENT_LIST_DIR}/FindPackageHandleStandardArgs.cmake)
|
||||
-find_package_handle_standard_args(PostgreSQL
|
||||
- REQUIRED_VARS PostgreSQL_LIBRARY PostgreSQL_INCLUDE_DIR PostgreSQL_TYPE_INCLUDE_DIR
|
||||
- VERSION_VAR PostgreSQL_VERSION_STRING)
|
||||
@ -156,8 +158,6 @@
|
||||
+ message (STATUS "PostgreSQL include dirs: ${PostgreSQL_INCLUDE_DIRS}")
|
||||
+ message (STATUS "PostgreSQL library dirs: ${PostgreSQL_LIBRARY_DIRS}")
|
||||
+ message (STATUS "PostgreSQL libraries: ${PostgreSQL_LIBRARIES}")
|
||||
endif(PostgreSQL_FOUND)
|
||||
endif()
|
||||
|
||||
-mark_as_advanced(PostgreSQL_INCLUDE_DIR PostgreSQL_TYPE_INCLUDE_DIR PostgreSQL_LIBRARY )
|
||||
+mark_as_advanced (PostgreSQL_CONFIG_DIR PostgreSQL_LIB_DIR
|
||||
+ PostgreSQL_INCLUDE_DIR PostgreSQL_TYPE_INCLUDE_DIR)
|
||||
|
@ -1,20 +1,20 @@
|
||||
diff -up cmake-2.8.8/Modules/FindRuby.cmake.findruby cmake-2.8.8/Modules/FindRuby.cmake
|
||||
--- cmake-2.8.8/Modules/FindRuby.cmake.findruby 2012-04-18 12:10:54.000000000 -0600
|
||||
+++ cmake-2.8.8/Modules/FindRuby.cmake 2012-05-21 10:36:19.206076083 -0600
|
||||
@@ -92,14 +92,8 @@ IF(RUBY_EXECUTABLE AND NOT RUBY_VERSIO
|
||||
diff -up cmake-2.8.10-rc1/Modules/FindRuby.cmake.findruby cmake-2.8.10-rc1/Modules/FindRuby.cmake
|
||||
--- cmake-2.8.10-rc1/Modules/FindRuby.cmake.findruby 2012-10-02 10:12:18.000000000 -0600
|
||||
+++ cmake-2.8.10-rc1/Modules/FindRuby.cmake 2012-10-02 15:50:30.463292214 -0600
|
||||
@@ -92,14 +92,8 @@ if(RUBY_EXECUTABLE AND NOT RUBY_VERSIO
|
||||
_RUBY_CONFIG_VAR("sitearchdir" RUBY_SITEARCH_DIR)
|
||||
_RUBY_CONFIG_VAR("sitelibdir" RUBY_SITELIB_DIR)
|
||||
|
||||
- # vendor_ruby available ?
|
||||
- EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r vendor-specific -e "print 'true'"
|
||||
- execute_process(COMMAND ${RUBY_EXECUTABLE} -r vendor-specific -e "print 'true'"
|
||||
- OUTPUT_VARIABLE RUBY_HAS_VENDOR_RUBY ERROR_QUIET)
|
||||
-
|
||||
- IF(RUBY_HAS_VENDOR_RUBY)
|
||||
- if(RUBY_HAS_VENDOR_RUBY)
|
||||
- _RUBY_CONFIG_VAR("vendorlibdir" RUBY_VENDORLIB_DIR)
|
||||
- _RUBY_CONFIG_VAR("vendorarchdir" RUBY_VENDORARCH_DIR)
|
||||
- ENDIF(RUBY_HAS_VENDOR_RUBY)
|
||||
- endif()
|
||||
+ _RUBY_CONFIG_VAR("vendorlibdir" RUBY_VENDORLIB_DIR)
|
||||
+ _RUBY_CONFIG_VAR("vendorarchdir" RUBY_VENDORARCH_DIR)
|
||||
|
||||
# save the results in the cache so we don't have to run ruby the next time again
|
||||
SET(RUBY_VERSION_MAJOR ${RUBY_VERSION_MAJOR} CACHE PATH "The Ruby major version" FORCE)
|
||||
set(RUBY_VERSION_MAJOR ${RUBY_VERSION_MAJOR} CACHE PATH "The Ruby major version" FORCE)
|
||||
|
10
cmake.spec
10
cmake.spec
@ -4,11 +4,11 @@
|
||||
# Set to bcond_with or use --without gui to disable qt4 gui build
|
||||
%bcond_without gui
|
||||
# Set to RC version if building RC, else %{nil}
|
||||
%define rcver %{nil}
|
||||
%define rcver -rc3
|
||||
|
||||
Name: cmake
|
||||
Version: 2.8.9
|
||||
Release: 1%{?dist}
|
||||
Version: 2.8.10
|
||||
Release: 0.1.rc3%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -177,6 +177,10 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 24 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.10-0.1.rc3
|
||||
- Update to 2.8.10 RC 3
|
||||
- Rebase FindRuby and FindPostgreSQL patches
|
||||
|
||||
* Thu Aug 9 2012 Orion Poplawski <orion@cora.nwra.com> - 2.8.9-1
|
||||
- Update to 2.8.9 final
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user