Rebase to version 10.2.0
- Disable erasure_codelib neon build - Sync up the spec file
This commit is contained in:
parent
767c6bb311
commit
bde7d230a8
@ -1,4 +1,4 @@
|
|||||||
From e439feb47e0bd603b6e2d84b6ae280f2a2d4d134 Mon Sep 17 00:00:00 2001
|
From 45f04eb8ac97d953ed5d631f6ec227a217a27bec Mon Sep 17 00:00:00 2001
|
||||||
From: Boris Ranto <branto@redhat.com>
|
From: Boris Ranto <branto@redhat.com>
|
||||||
Date: Wed, 11 Nov 2015 17:08:06 +0100
|
Date: Wed, 11 Nov 2015 17:08:06 +0100
|
||||||
Subject: [PATCH] Disable erasure_codelib neon build
|
Subject: [PATCH] Disable erasure_codelib neon build
|
||||||
@ -9,7 +9,7 @@ Subject: [PATCH] Disable erasure_codelib neon build
|
|||||||
2 files changed, 6 insertions(+), 6 deletions(-)
|
2 files changed, 6 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/erasure-code/jerasure/Makefile.am b/src/erasure-code/jerasure/Makefile.am
|
diff --git a/src/erasure-code/jerasure/Makefile.am b/src/erasure-code/jerasure/Makefile.am
|
||||||
index 9ca4fbb..147d57e 100644
|
index adcb95d..5e47943 100644
|
||||||
--- a/src/erasure-code/jerasure/Makefile.am
|
--- a/src/erasure-code/jerasure/Makefile.am
|
||||||
+++ b/src/erasure-code/jerasure/Makefile.am
|
+++ b/src/erasure-code/jerasure/Makefile.am
|
||||||
@@ -75,9 +75,9 @@ if LINUX
|
@@ -75,9 +75,9 @@ if LINUX
|
||||||
@ -26,7 +26,7 @@ index 9ca4fbb..147d57e 100644
|
|||||||
libec_jerasure_sse3_la_SOURCES = ${jerasure_sources}
|
libec_jerasure_sse3_la_SOURCES = ${jerasure_sources}
|
||||||
libec_jerasure_sse3_la_CFLAGS = ${AM_CFLAGS} \
|
libec_jerasure_sse3_la_CFLAGS = ${AM_CFLAGS} \
|
||||||
diff --git a/src/erasure-code/shec/Makefile.am b/src/erasure-code/shec/Makefile.am
|
diff --git a/src/erasure-code/shec/Makefile.am b/src/erasure-code/shec/Makefile.am
|
||||||
index 1449a41..f5d5997 100644
|
index 6b658d5..93051f4 100644
|
||||||
--- a/src/erasure-code/shec/Makefile.am
|
--- a/src/erasure-code/shec/Makefile.am
|
||||||
+++ b/src/erasure-code/shec/Makefile.am
|
+++ b/src/erasure-code/shec/Makefile.am
|
||||||
@@ -81,9 +81,9 @@ if LINUX
|
@@ -81,9 +81,9 @@ if LINUX
|
||||||
@ -43,5 +43,5 @@ index 1449a41..f5d5997 100644
|
|||||||
libec_shec_sse3_la_SOURCES = ${shec_sources}
|
libec_shec_sse3_la_SOURCES = ${shec_sources}
|
||||||
libec_shec_sse3_la_CFLAGS = ${AM_CFLAGS} \
|
libec_shec_sse3_la_CFLAGS = ${AM_CFLAGS} \
|
||||||
--
|
--
|
||||||
2.1.0
|
2.5.5
|
||||||
|
|
||||||
|
@ -1,93 +0,0 @@
|
|||||||
From 1c2831a2c1277c69f9649200d74a75c04a4b0296 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Mon, 21 Mar 2016 14:24:35 +0000
|
|
||||||
Subject: [PATCH] common/Cycles: Do not initialize Cycles globally.
|
|
||||||
|
|
||||||
Move initialization to the few tests that actually use it.
|
|
||||||
|
|
||||||
Fixes: http://tracker.ceph.com/issues/15225
|
|
||||||
Signed-off-by: Richard W.M. Jones <rjones@redhat.com>
|
|
||||||
---
|
|
||||||
src/common/Cycles.cc | 11 ++++++-----
|
|
||||||
src/test/msgr/perf_msgr_client.cc | 1 +
|
|
||||||
src/test/msgr/perf_msgr_server.cc | 1 -
|
|
||||||
src/test/objectstore/ObjectStoreTransactionBenchmark.cc | 1 +
|
|
||||||
src/test/perf_local.cc | 1 +
|
|
||||||
5 files changed, 9 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/common/Cycles.cc b/src/common/Cycles.cc
|
|
||||||
index b0b687e..656f08b 100644
|
|
||||||
--- a/src/common/Cycles.cc
|
|
||||||
+++ b/src/common/Cycles.cc
|
|
||||||
@@ -38,14 +38,15 @@
|
|
||||||
#include "Cycles.h"
|
|
||||||
|
|
||||||
double Cycles::cycles_per_sec = 0;
|
|
||||||
-static Initialize _(Cycles::init);
|
|
||||||
|
|
||||||
/**
|
|
||||||
* Perform once-only overall initialization for the Cycles class, such
|
|
||||||
- * as calibrating the clock frequency. This method is invoked automatically
|
|
||||||
- * during initialization, but it may be invoked explicitly by other modules
|
|
||||||
- * to ensure that initialization occurs before those modules initialize
|
|
||||||
- * themselves.
|
|
||||||
+ * as calibrating the clock frequency. This method must be called
|
|
||||||
+ * before using the Cycles module.
|
|
||||||
+ *
|
|
||||||
+ * It is not initialized by default because the timing loops cause
|
|
||||||
+ * general process startup times to balloon
|
|
||||||
+ * (http://tracker.ceph.com/issues/15225).
|
|
||||||
*/
|
|
||||||
void Cycles::init()
|
|
||||||
{
|
|
||||||
diff --git a/src/test/msgr/perf_msgr_client.cc b/src/test/msgr/perf_msgr_client.cc
|
|
||||||
index fa21b49..1cb3db2 100644
|
|
||||||
--- a/src/test/msgr/perf_msgr_client.cc
|
|
||||||
+++ b/src/test/msgr/perf_msgr_client.cc
|
|
||||||
@@ -196,6 +196,7 @@ int main(int argc, char **argv)
|
|
||||||
cerr << " message data bytes " << len << std::endl;
|
|
||||||
MessengerClient client(g_ceph_context->_conf->ms_type, args[0], think_time);
|
|
||||||
client.ready(concurrent, numjobs, ios, len);
|
|
||||||
+ Cycles::init();
|
|
||||||
uint64_t start = Cycles::rdtsc();
|
|
||||||
client.start();
|
|
||||||
uint64_t stop = Cycles::rdtsc();
|
|
||||||
diff --git a/src/test/msgr/perf_msgr_server.cc b/src/test/msgr/perf_msgr_server.cc
|
|
||||||
index 3eae9a5..dde679c 100644
|
|
||||||
--- a/src/test/msgr/perf_msgr_server.cc
|
|
||||||
+++ b/src/test/msgr/perf_msgr_server.cc
|
|
||||||
@@ -25,7 +25,6 @@ using namespace std;
|
|
||||||
#include "include/atomic.h"
|
|
||||||
#include "common/ceph_argparse.h"
|
|
||||||
#include "common/debug.h"
|
|
||||||
-#include "common/Cycles.h"
|
|
||||||
#include "global/global_init.h"
|
|
||||||
#include "msg/Messenger.h"
|
|
||||||
#include "messages/MOSDOp.h"
|
|
||||||
diff --git a/src/test/objectstore/ObjectStoreTransactionBenchmark.cc b/src/test/objectstore/ObjectStoreTransactionBenchmark.cc
|
|
||||||
index 7c0dc09..46fd25d 100644
|
|
||||||
--- a/src/test/objectstore/ObjectStoreTransactionBenchmark.cc
|
|
||||||
+++ b/src/test/objectstore/ObjectStoreTransactionBenchmark.cc
|
|
||||||
@@ -249,6 +249,7 @@ int main(int argc, char **argv)
|
|
||||||
global_init(NULL, args, CEPH_ENTITY_TYPE_CLIENT, CODE_ENVIRONMENT_UTILITY, 0);
|
|
||||||
common_init_finish(g_ceph_context);
|
|
||||||
g_ceph_context->_conf->apply_changes(NULL);
|
|
||||||
+ Cycles::init();
|
|
||||||
|
|
||||||
cerr << "args: " << args << std::endl;
|
|
||||||
if (args.size() < 1) {
|
|
||||||
diff --git a/src/test/perf_local.cc b/src/test/perf_local.cc
|
|
||||||
index 49440c2..7c33dc5 100644
|
|
||||||
--- a/src/test/perf_local.cc
|
|
||||||
+++ b/src/test/perf_local.cc
|
|
||||||
@@ -1020,6 +1020,7 @@ int main(int argc, char *argv[])
|
|
||||||
|
|
||||||
global_init(NULL, args, CEPH_ENTITY_TYPE_CLIENT, CODE_ENVIRONMENT_UTILITY, 0);
|
|
||||||
common_init_finish(g_ceph_context);
|
|
||||||
+ Cycles::init();
|
|
||||||
|
|
||||||
bind_thread_to_cpu(3);
|
|
||||||
if (argc == 1) {
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -1,18 +0,0 @@
|
|||||||
diff -up ceph-0.46/src/init-ceph.in.orig ceph-0.46/src/init-ceph.in
|
|
||||||
--- ceph-0.46/src/init-ceph.in.orig 2012-04-24 16:06:39.000000000 -0400
|
|
||||||
+++ ceph-0.46/src/init-ceph.in 2012-05-09 16:41:36.500004052 -0400
|
|
||||||
@@ -1,11 +1,11 @@
|
|
||||||
#!/bin/sh
|
|
||||||
# Start/stop ceph daemons
|
|
||||||
-# chkconfig: 2345 60 80
|
|
||||||
+# chkconfig: - 60 80
|
|
||||||
|
|
||||||
### BEGIN INIT INFO
|
|
||||||
# Provides: ceph
|
|
||||||
-# Default-Start: 2 3 4 5
|
|
||||||
-# Default-Stop: 0 1 6
|
|
||||||
+# Default-Start:
|
|
||||||
+# Default-Stop:
|
|
||||||
# Required-Start: $remote_fs $named $network $time
|
|
||||||
# Required-Stop: $remote_fs $named $network $time
|
|
||||||
# Short-Description: Start Ceph distributed file system daemons at boot time
|
|
Loading…
Reference in New Issue
Block a user