- new upstream release
- drop brltty-3.9-java-svn.patch, brltty-3.9-tcl85path.patch, and brltty-3.9-pyxfix.patch, they are upstream - fix BuildRoot - fix many sub-packages' Requires on brlapi
This commit is contained in:
parent
6cc4c5def3
commit
f326de93f8
@ -1 +1 @@
|
|||||||
brltty-3.9.tar.gz
|
brltty-3.10.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- brltty-3.9/configure.ac.gnusource 2007-10-17 17:19:31.000000000 +0200
|
|
||||||
+++ brltty-3.9/configure.ac 2008-02-28 14:30:57.000000000 +0100
|
|
||||||
@@ -678,7 +678,7 @@
|
|
||||||
case "${host_os}"
|
|
||||||
in
|
|
||||||
linux*|gnu*|kfreebsd*)
|
|
||||||
- brltty_cv_prog_cc_sysflags="-D_POSIX_C_SOURCE=2 -D_BSD_SOURCE -D_XOPEN_SOURCE=500"
|
|
||||||
+ brltty_cv_prog_cc_sysflags="-D_POSIX_C_SOURCE=2 -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_GNU_SOURCE"
|
|
||||||
;;
|
|
||||||
solaris*)
|
|
||||||
brltty_cv_prog_cc_sysflags="-D_XOPEN_SOURCE=500 -D__EXTENSIONS__"
|
|
File diff suppressed because it is too large
Load Diff
@ -1,18 +0,0 @@
|
|||||||
2008-09-12 Stepan Kasal <skasal@redhat.com>
|
|
||||||
|
|
||||||
* Programs/Makefile.in (braille-drivers): Depend on `api';
|
|
||||||
without this, make -j8 failed, because some of the drivers
|
|
||||||
call target `brlapi'. Recursive make is harmful.
|
|
||||||
|
|
||||||
diff -up brltty-3.9/Programs/Makefile.in.parallel brltty-3.9/Programs/Makefile.in
|
|
||||||
--- brltty-3.9/Programs/Makefile.in.parallel 2007-10-17 17:19:24.000000000 +0200
|
|
||||||
+++ brltty-3.9/Programs/Makefile.in 2008-09-12 17:44:54.000000000 +0200
|
|
||||||
@@ -381,7 +381,7 @@ apitest.$O:
|
|
||||||
|
|
||||||
###############################################################################
|
|
||||||
|
|
||||||
-braille-drivers: txt2hlp
|
|
||||||
+braille-drivers: txt2hlp api
|
|
||||||
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
|
|
||||||
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-help) || exit 1; \
|
|
||||||
done
|
|
@ -1,45 +0,0 @@
|
|||||||
2008-09-13 Stepan Kasal <skasal@redhat.com>
|
|
||||||
|
|
||||||
Backport fix to satisfy current pyrex.
|
|
||||||
|
|
||||||
* Bindings/Python/brlapi.pyx (ignoreKeys, acceptKeys): Do not
|
|
||||||
use keyword "type" as a name of a parameter.
|
|
||||||
|
|
||||||
--- ./Bindings/Python/brlapi.pyx.orig 2007-10-17 17:19:30.000000000 +0200
|
|
||||||
+++ ./Bindings/Python/brlapi.pyx 2008-09-12 18:08:47.000000000 +0200
|
|
||||||
@@ -484,7 +484,7 @@
|
|
||||||
else:
|
|
||||||
return { "type":ekc.type, "command":ekc.command, "argument":ekc.argument, "flags":ekc.flags }
|
|
||||||
|
|
||||||
- def ignoreKeys(self, type, set):
|
|
||||||
+ def ignoreKeys(self, key_type, set):
|
|
||||||
"""Ignore some key presses from the braille keyboard.
|
|
||||||
See brlapi_ignoreKeys(3).
|
|
||||||
|
|
||||||
@@ -495,7 +495,7 @@
|
|
||||||
cdef c_brlapi.brlapi_rangeType_t c_type
|
|
||||||
cdef c_brlapi.brlapi_keyCode_t *c_set
|
|
||||||
cdef unsigned int c_n
|
|
||||||
- c_type = type
|
|
||||||
+ c_type = key_type
|
|
||||||
c_n = len(set)
|
|
||||||
c_set = <c_brlapi.brlapi_keyCode_t*>c_brlapi.malloc(c_n * sizeof(c_set[0]))
|
|
||||||
for i from 0 <= i < c_n:
|
|
||||||
@@ -509,7 +509,7 @@
|
|
||||||
else:
|
|
||||||
return retval
|
|
||||||
|
|
||||||
- def acceptKeys(self, type, set):
|
|
||||||
+ def acceptKeys(self, key_type, set):
|
|
||||||
"""Accept some key presses from the braille keyboard.
|
|
||||||
See brlapi_ignoreKeys(3).
|
|
||||||
|
|
||||||
@@ -520,7 +520,7 @@
|
|
||||||
cdef c_brlapi.brlapi_rangeType_t c_type
|
|
||||||
cdef c_brlapi.brlapi_keyCode_t *c_set
|
|
||||||
cdef unsigned int c_n
|
|
||||||
- c_type = type
|
|
||||||
+ c_type = key_type
|
|
||||||
c_n = len(set)
|
|
||||||
c_set = <c_brlapi.brlapi_keyCode_t*>c_brlapi.malloc(c_n * sizeof(c_set[0]))
|
|
||||||
for i from 0 <= i < c_n:
|
|
@ -1,11 +0,0 @@
|
|||||||
--- brltty-3.9/Bindings/Tcl/pkgutil.tcl85 2007-10-17 17:19:30.000000000 +0200
|
|
||||||
+++ brltty-3.9/Bindings/Tcl/pkgutil 2008-01-04 16:07:25.000000000 +0100
|
|
||||||
@@ -31,7 +31,7 @@
|
|
||||||
}
|
|
||||||
set directory [eval file join / [lrange $components $rootCount end]]
|
|
||||||
|
|
||||||
- if {[lsearch -exact {lib lib64} [file tail $directory]] >= 0} {
|
|
||||||
+ if {[regexp /lib(64)?(/|$) $directory] >= 0} {
|
|
||||||
global optionValues packageName packageVersion
|
|
||||||
return [file join "$optionValues(root)$directory" "$packageName-$packageVersion"]
|
|
||||||
}
|
|
17
brltty-gnusource.patch
Normal file
17
brltty-gnusource.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
2008-09-17 Stepan Kasal <skasal@redhat.com>
|
||||||
|
|
||||||
|
* configure.ac: Add -D_GNU_SOURCE to get struct ucred from
|
||||||
|
socket.h.
|
||||||
|
|
||||||
|
diff -up brltty-3.10/configure.ac.gnusource brltty-3.10/configure.ac
|
||||||
|
--- brltty-3.10/configure.ac.gnusource 2008-07-17 00:19:54.000000000 +0200
|
||||||
|
+++ brltty-3.10/configure.ac 2008-09-17 12:44:28.000000000 +0200
|
||||||
|
@@ -779,7 +779,7 @@ AC_CACHE_CHECK([for system-dependent com
|
||||||
|
case "${host_os}"
|
||||||
|
in
|
||||||
|
linux*|gnu*|kfreebsd*)
|
||||||
|
- brltty_cv_prog_cc_sysflags="-D_POSIX_C_SOURCE=2 -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_XOPEN_SOURCE_EXTENDED"
|
||||||
|
+ brltty_cv_prog_cc_sysflags="-D_POSIX_C_SOURCE=2 -D_BSD_SOURCE -D_XOPEN_SOURCE=500 -D_XOPEN_SOURCE_EXTENDED -D_GNU_SOURCE"
|
||||||
|
;;
|
||||||
|
solaris*)
|
||||||
|
brltty_cv_prog_cc_sysflags="-D_XOPEN_SOURCE=500 -D__EXTENSIONS__"
|
20
brltty-parallel.patch
Normal file
20
brltty-parallel.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
2008-09-17 Stepan Kasal <skasal@redhat.com>
|
||||||
|
|
||||||
|
* Programs/Makefile.in (braille-drivers): Add
|
||||||
|
prerequisity `all' to prevent race of this make with nested
|
||||||
|
"make brlapi" when parallel make is used. Recursive make is
|
||||||
|
harmful.
|
||||||
|
|
||||||
|
diff -up brltty-3.10/Makefile.in.parallel brltty-3.10/Makefile.in
|
||||||
|
diff -up brltty-3.10/Programs/Makefile.in.parallel brltty-3.10/Programs/Makefile.in
|
||||||
|
--- brltty-3.10/Programs/Makefile.in.parallel 2008-07-17 00:19:08.000000000 +0200
|
||||||
|
+++ brltty-3.10/Programs/Makefile.in 2008-09-17 11:24:35.000000000 +0200
|
||||||
|
@@ -399,7 +399,7 @@ apitest.$O:
|
||||||
|
|
||||||
|
###############################################################################
|
||||||
|
|
||||||
|
-braille-drivers: txt2hlp
|
||||||
|
+braille-drivers: txt2hlp api
|
||||||
|
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
|
||||||
|
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-all) || exit 1; \
|
||||||
|
done
|
36
brltty.spec
36
brltty.spec
@ -1,5 +1,5 @@
|
|||||||
%define pkg_version 3.9
|
%define pkg_version 3.10
|
||||||
%define api_version 0.5.1
|
%define api_version 0.5.2
|
||||||
|
|
||||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
|
%{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
|
||||||
@ -9,20 +9,16 @@
|
|||||||
|
|
||||||
Name: brltty
|
Name: brltty
|
||||||
Version: %{pkg_version}
|
Version: %{pkg_version}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://mielke.cc/brltty/
|
URL: http://mielke.cc/brltty/
|
||||||
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
|
||||||
Patch0: brltty-3.9-tcl85path.patch
|
Patch2: brltty-gnusource.patch
|
||||||
Patch1: brltty-3.9-java-svn.patch
|
|
||||||
Patch2: brltty-3.9-gnusource.patch
|
|
||||||
Patch3: brltty-3.9-autoconf.patch
|
Patch3: brltty-3.9-autoconf.patch
|
||||||
Patch4: brltty-3.9-pyxfix.patch
|
Patch5: brltty-parallel.patch
|
||||||
Patch5: brltty-3.9-parallel.patch
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-InstallRoot
|
|
||||||
Summary: Braille display driver for Linux/Unix
|
Summary: Braille display driver for Linux/Unix
|
||||||
Requires(post): coreutils
|
|
||||||
BuildRequires: byacc, glibc-kernheaders
|
BuildRequires: byacc, glibc-kernheaders
|
||||||
# BuildRequires: ocaml
|
# BuildRequires: ocaml
|
||||||
|
|
||||||
@ -68,7 +64,7 @@ a refreshable braille display.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}
|
Requires: brlapi = %{api_version}-%{release}
|
||||||
Summary: Headers, static archive, and documentation for BrlAPI
|
Summary: Headers, static archive, and documentation for BrlAPI
|
||||||
|
|
||||||
%description -n brlapi-devel
|
%description -n brlapi-devel
|
||||||
@ -87,7 +83,7 @@ which directly accesses a refreshable braille display.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}
|
Requires: brlapi = %{api_version}-%{release}
|
||||||
BuildRequires: tcl-devel tcl
|
BuildRequires: tcl-devel tcl
|
||||||
Summary: Tcl binding for BrlAPI
|
Summary: Tcl binding for BrlAPI
|
||||||
%description -n tcl-brlapi
|
%description -n tcl-brlapi
|
||||||
@ -97,7 +93,7 @@ This package provides the Tcl binding for BrlAPI.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}
|
Requires: brlapi = %{api_version}-%{release}
|
||||||
BuildRequires: Pyrex
|
BuildRequires: Pyrex
|
||||||
Summary: Python binding for BrlAPI
|
Summary: Python binding for BrlAPI
|
||||||
%description -n python-brlapi
|
%description -n python-brlapi
|
||||||
@ -107,7 +103,7 @@ This package provides the Python binding for BrlAPI.
|
|||||||
Version: %{api_version}
|
Version: %{api_version}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Requires: brlapi = %{api_version}
|
Requires: brlapi = %{api_version}-%{release}
|
||||||
BuildRequires: java-devel
|
BuildRequires: java-devel
|
||||||
#BuildRequires: java-1.7.0-icedtea-devel
|
#BuildRequires: java-1.7.0-icedtea-devel
|
||||||
Summary: Java binding for BrlAPI
|
Summary: Java binding for BrlAPI
|
||||||
@ -118,15 +114,12 @@ This package provides the Java binding for BrlAPI.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .tcl85path
|
|
||||||
%patch1 -p1 -b .java-svn
|
|
||||||
%patch2 -p1 -b .gnusource
|
%patch2 -p1 -b .gnusource
|
||||||
%patch3 -p1 -b .autoconf
|
%patch3 -p1 -b .autoconf
|
||||||
%patch4 -p1 -b .pyxfix
|
|
||||||
%patch5 -p1 -b .parallel
|
%patch5 -p1 -b .parallel
|
||||||
./autogen
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
./autogen
|
||||||
%configure --with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
|
%configure --with-install-root="${RPM_BUILD_ROOT}" --with-braille-driver=-tt
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
@ -223,6 +216,13 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Sep 13 2008 Stepan Kasal <skasal@redhat.com> - 3.10-1
|
||||||
|
- new upstream release
|
||||||
|
- drop brltty-3.9-java-svn.patch, brltty-3.9-tcl85path.patch,
|
||||||
|
and brltty-3.9-pyxfix.patch, they are upstream
|
||||||
|
- fix BuildRoot
|
||||||
|
- fix many sub-packages' Requires on brlapi
|
||||||
|
|
||||||
* Wed Sep 10 2008 Stepan Kasal <skasal@redhat.com> - 3.9-3
|
* Wed Sep 10 2008 Stepan Kasal <skasal@redhat.com> - 3.9-3
|
||||||
- add brltty-3.9-autoconf.patch to fix to build with Autoconf 2.62
|
- add brltty-3.9-autoconf.patch to fix to build with Autoconf 2.62
|
||||||
- add brltty-3.9-parallel.patch to fix race condition with parallel make
|
- add brltty-3.9-parallel.patch to fix race condition with parallel make
|
||||||
|
Loading…
Reference in New Issue
Block a user