6cc4c5def3
- add brltty-3.9-parallel.patch to fix race condition with parallel make - add brltty-3.9-pyxfix.patch to fix build with current pyrex - Summary lines shall not end with a dot
19 lines
778 B
Diff
19 lines
778 B
Diff
2008-09-12 Stepan Kasal <skasal@redhat.com>
|
|
|
|
* Programs/Makefile.in (braille-drivers): Depend on `api';
|
|
without this, make -j8 failed, because some of the drivers
|
|
call target `brlapi'. Recursive make is harmful.
|
|
|
|
diff -up brltty-3.9/Programs/Makefile.in.parallel brltty-3.9/Programs/Makefile.in
|
|
--- brltty-3.9/Programs/Makefile.in.parallel 2007-10-17 17:19:24.000000000 +0200
|
|
+++ brltty-3.9/Programs/Makefile.in 2008-09-12 17:44:54.000000000 +0200
|
|
@@ -381,7 +381,7 @@ apitest.$O:
|
|
|
|
###############################################################################
|
|
|
|
-braille-drivers: txt2hlp
|
|
+braille-drivers: txt2hlp api
|
|
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
|
|
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-help) || exit 1; \
|
|
done
|