- add brltty-3.9-autoconf.patch to fix to build with Autoconf 2.62

- add brltty-3.9-parallel.patch to fix race condition with parallel make
- add brltty-3.9-pyxfix.patch to fix build with current pyrex
- Summary lines shall not end with a dot
This commit is contained in:
Štěpán Kasal 2008-09-13 14:10:14 +00:00
parent 37c9aa8820
commit 6cc4c5def3
4 changed files with 115 additions and 9 deletions

31
brltty-3.9-autoconf.patch Normal file
View File

@ -0,0 +1,31 @@
2008-09-12 Stepan Kasal <skasal@redhat.com>
* aclocal.m4 (BRLTTY_HELP_STRING, BRLTTY_TEXT_TABLE,
BRLTTY_ATTRIBUTES_TABLE): Expand parameters to AC_HELP_STRING
and m4_text_wrap, to be compatible with Autoconf 2.62+.
--- brltty-3.9.orig/aclocal.m4.orig 2007-10-17 17:19:31.000000000 +0200
+++ brltty-3.9.orig/aclocal.m4 2008-09-12 18:05:21.000000000 +0200
@@ -144,7 +144,7 @@
AC_DEFUN([BRLTTY_HELP_STRING], [dnl
AC_HELP_STRING([$1], patsubst([$2], [
-.*$]), [brltty_help_prefix])dnl
+.*$]), m4_defn([brltty_help_prefix]))dnl
patsubst(patsubst([$2], [\`[^
]*]), [
], [\&brltty_help_prefix])[]dnl
@@ -384,11 +384,11 @@
AC_DEFUN([BRLTTY_TEXT_TABLE], [dnl
define([brltty_tables_text], ifdef([brltty_tables_text], [brltty_tables_text])[
-m4_text_wrap([$2], [ ], [- m4_format([%-8s ], [$1])], brltty_help_width)])])
+m4_text_wrap([$2], [ ], [- ]m4_format([%-8s ], [$1]), brltty_help_width)])])
AC_DEFUN([BRLTTY_ATTRIBUTES_TABLE], [dnl
define([brltty_tables_attributes], ifdef([brltty_tables_attributes], [brltty_tables_attributes])[
-m4_text_wrap([$2], [ ], [- m4_format([%-10s ], [$1])], brltty_help_width)])])
+m4_text_wrap([$2], [ ], [- ]m4_format([%-10s ], [$1]), brltty_help_width)])])
AC_DEFUN([BRLTTY_SUMMARY_BEGIN], [dnl
brltty_summary_lines="Options Summary:"

18
brltty-3.9-parallel.patch Normal file
View File

@ -0,0 +1,18 @@
2008-09-12 Stepan Kasal <skasal@redhat.com>
* Programs/Makefile.in (braille-drivers): Depend on `api';
without this, make -j8 failed, because some of the drivers
call target `brlapi'. Recursive make is harmful.
diff -up brltty-3.9/Programs/Makefile.in.parallel brltty-3.9/Programs/Makefile.in
--- brltty-3.9/Programs/Makefile.in.parallel 2007-10-17 17:19:24.000000000 +0200
+++ brltty-3.9/Programs/Makefile.in 2008-09-12 17:44:54.000000000 +0200
@@ -381,7 +381,7 @@ apitest.$O:
###############################################################################
-braille-drivers: txt2hlp
+braille-drivers: txt2hlp api
for driver in $(BRAILLE_EXTERNAL_DRIVER_NAMES); \
do (cd $(BLD_TOP)$(BRL_DIR)/$$driver && $(MAKE) braille-driver braille-help) || exit 1; \
done

45
brltty-3.9-pyxfix.patch Normal file
View File

@ -0,0 +1,45 @@
2008-09-13 Stepan Kasal <skasal@redhat.com>
Backport fix to satisfy current pyrex.
* Bindings/Python/brlapi.pyx (ignoreKeys, acceptKeys): Do not
use keyword "type" as a name of a parameter.
--- ./Bindings/Python/brlapi.pyx.orig 2007-10-17 17:19:30.000000000 +0200
+++ ./Bindings/Python/brlapi.pyx 2008-09-12 18:08:47.000000000 +0200
@@ -484,7 +484,7 @@
else:
return { "type":ekc.type, "command":ekc.command, "argument":ekc.argument, "flags":ekc.flags }
- def ignoreKeys(self, type, set):
+ def ignoreKeys(self, key_type, set):
"""Ignore some key presses from the braille keyboard.
See brlapi_ignoreKeys(3).
@@ -495,7 +495,7 @@
cdef c_brlapi.brlapi_rangeType_t c_type
cdef c_brlapi.brlapi_keyCode_t *c_set
cdef unsigned int c_n
- c_type = type
+ c_type = key_type
c_n = len(set)
c_set = <c_brlapi.brlapi_keyCode_t*>c_brlapi.malloc(c_n * sizeof(c_set[0]))
for i from 0 <= i < c_n:
@@ -509,7 +509,7 @@
else:
return retval
- def acceptKeys(self, type, set):
+ def acceptKeys(self, key_type, set):
"""Accept some key presses from the braille keyboard.
See brlapi_ignoreKeys(3).
@@ -520,7 +520,7 @@
cdef c_brlapi.brlapi_rangeType_t c_type
cdef c_brlapi.brlapi_keyCode_t *c_set
cdef unsigned int c_n
- c_type = type
+ c_type = key_type
c_n = len(set)
c_set = <c_brlapi.brlapi_keyCode_t*>c_brlapi.malloc(c_n * sizeof(c_set[0]))
for i from 0 <= i < c_n:

View File

@ -9,7 +9,7 @@
Name: brltty
Version: %{pkg_version}
Release: 2.2%{?dist}
Release: 3%{?dist}
License: GPLv2+
Group: System Environment/Daemons
URL: http://mielke.cc/brltty/
@ -17,8 +17,11 @@ Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.gz
Patch0: brltty-3.9-tcl85path.patch
Patch1: brltty-3.9-java-svn.patch
Patch2: brltty-3.9-gnusource.patch
Patch3: brltty-3.9-autoconf.patch
Patch4: brltty-3.9-pyxfix.patch
Patch5: brltty-3.9-parallel.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-InstallRoot
Summary: Braille display driver for Linux/Unix.
Summary: Braille display driver for Linux/Unix
Requires(post): coreutils
BuildRequires: byacc, glibc-kernheaders
# BuildRequires: ocaml
@ -33,7 +36,7 @@ Some speech capability has also been incorporated.
%package xw
Requires: %{name}
Summary: XWindow driver for BRLTTY.
Summary: XWindow driver for BRLTTY
Group: System Environment/Daemons
License: GPLv2+
BuildRequires: libSM-devel libICE-devel libX11-devel libXaw-devel libXext-devel libXt-devel libXtst-devel
@ -42,7 +45,7 @@ This package provides the XWindow driver for BRLTTY.
%package at-spi
Requires: %{name}
Summary: AtSpi driver for BRLTTY.
Summary: AtSpi driver for BRLTTY
Group: System Environment/Daemons
License: GPLv2+
BuildRequires: at-spi-devel
@ -53,7 +56,7 @@ This package provides the AtSpi driver for BRLTTY.
Version: %{api_version}
Group: Applications/System
License: LGPLv2+
Summary: Appliation Programming Interface for BRLTTY.
Summary: Appliation Programming Interface for BRLTTY
%description -n brlapi
This package provides the run-time support for the Application
Programming Interface to BRLTTY.
@ -66,8 +69,8 @@ Version: %{api_version}
Group: Development/System
License: LGPLv2+
Requires: brlapi = %{api_version}
Summary: Headers, static archive, and documentation for BrlAPI
Summary: Headers, static archive, and documentation for BrlAPI.
%description -n brlapi-devel
This package provides the header files, static archive, shared object
linker reference, and reference documentation for BrlAPI (the
@ -86,7 +89,7 @@ Group: Development/System
License: LGPLv2+
Requires: brlapi = %{api_version}
BuildRequires: tcl-devel tcl
Summary: Tcl binding for BrlAPI.
Summary: Tcl binding for BrlAPI
%description -n tcl-brlapi
This package provides the Tcl binding for BrlAPI.
@ -96,7 +99,7 @@ Group: Development/System
License: LGPLv2+
Requires: brlapi = %{api_version}
BuildRequires: Pyrex
Summary: Python binding for BrlAPI.
Summary: Python binding for BrlAPI
%description -n python-brlapi
This package provides the Python binding for BrlAPI.
@ -107,7 +110,7 @@ License: LGPLv2+
Requires: brlapi = %{api_version}
BuildRequires: java-devel
#BuildRequires: java-1.7.0-icedtea-devel
Summary: Java binding for BrlAPI.
Summary: Java binding for BrlAPI
%description -n brlapi-java
This package provides the Java binding for BrlAPI.
@ -118,6 +121,9 @@ This package provides the Java binding for BrlAPI.
%patch0 -p1 -b .tcl85path
%patch1 -p1 -b .java-svn
%patch2 -p1 -b .gnusource
%patch3 -p1 -b .autoconf
%patch4 -p1 -b .pyxfix
%patch5 -p1 -b .parallel
./autogen
%build
@ -217,6 +223,12 @@ exit 0
%changelog
* Wed Sep 10 2008 Stepan Kasal <skasal@redhat.com> - 3.9-3
- add brltty-3.9-autoconf.patch to fix to build with Autoconf 2.62
- add brltty-3.9-parallel.patch to fix race condition with parallel make
- add brltty-3.9-pyxfix.patch to fix build with current pyrex
- Summary lines shall not end with a dot
* Thu Feb 28 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-2.2
- glibc build fixes
- applied java reorganisations from svn