import booth-1.0-283.1.9d4029a.git.el9

This commit is contained in:
CentOS Sources 2023-05-09 05:16:51 +00:00 committed by Stepan Oksanichenko
parent 95c510afa9
commit 89f55ca13b
6 changed files with 20 additions and 77 deletions

View File

@ -1 +1 @@
5444fbd98864fee07bc8b7c97a3c579b6ad72190 SOURCES/booth-1.0-251-bfb2f92.tar.gz 1fe5851af81995b4187b6c24ffbb9e8edead7060 SOURCES/booth-1.0-283-9d4029a.tar.gz

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/booth-1.0-251-bfb2f92.tar.gz SOURCES/booth-1.0-283-9d4029a.tar.gz

View File

@ -1,30 +0,0 @@
From 35bf0b7b048d715f671eb68974fb6b4af6528c67 Mon Sep 17 00:00:00 2001
From: Jan Friesse <jfriesse@redhat.com>
Date: Mon, 4 Jul 2022 09:39:47 +0200
Subject: [PATCH] Revert "Refactor: main: substitute is_auth_req macro"
This reverts commit da79b8ba28ad4837a0fee13e5f8fb6f89fe0e24c.
authfile != authkey
Signed-off-by: Jan Friesse <jfriesse@redhat.com>
---
src/main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/main.c b/src/main.c
index b50a883..b4a174f 100644
--- a/src/main.c
+++ b/src/main.c
@@ -364,7 +364,7 @@ static int setup_config(int type)
if (rv < 0)
goto out;
- if (is_auth_req()) {
+ if (booth_conf->authfile[0] != '\0') {
rv = read_authkey();
if (rv < 0)
goto out;
--
2.37.1

View File

@ -1,30 +0,0 @@
From dd090510d7fba88c41adc1b70804c1c79b036736 Mon Sep 17 00:00:00 2001
From: Jan Friesse <jfriesse@redhat.com>
Date: Tue, 27 Sep 2022 18:50:31 +0200
Subject: [PATCH] unit file: Remove Alias directive
Recent change in systemd made imposible to enable booth@.service any
longer - more details in BZ
https://bugzilla.redhat.com/show_bug.cgi?id=2128998. Solution is to
delete Alias directive.
Signed-off-by: Jan Friesse <jfriesse@redhat.com>
---
conf/booth@.service.in | 1 -
1 file changed, 1 deletion(-)
diff --git a/conf/booth@.service.in b/conf/booth@.service.in
index e516194..e4b8fbc 100644
--- a/conf/booth@.service.in
+++ b/conf/booth@.service.in
@@ -8,7 +8,6 @@ ConditionFileNotEmpty=/etc/booth/%i.conf
Conflicts=pacemaker.service
[Install]
-Alias=boothd
WantedBy=multi-user.target
[Service]
--
2.31.1

View File

@ -1,6 +1,6 @@
From 466246c2fa8ea1bcc06593fbf7b900d0665606b1 Mon Sep 17 00:00:00 2001 From 87c8545816cca03d19c2f3ef54031940f7e19d50 Mon Sep 17 00:00:00 2001
From: Jan Friesse <jfriesse@redhat.com> From: Jan Friesse <jfriesse@redhat.com>
Date: Tue, 26 Jul 2022 18:39:38 +0200 Date: Fri, 18 Nov 2022 11:57:46 +0100
Subject: [PATCH] config: Add enable-authfile option Subject: [PATCH] config: Add enable-authfile option
This option enables (or disables) usage of authfile. Can be 'yes' or 'no'. This option enables (or disables) usage of authfile. Can be 'yes' or 'no'.
@ -31,28 +31,28 @@ Signed-off-by: Jan Friesse <jfriesse@redhat.com>
4 files changed, 26 insertions(+), 1 deletion(-) 4 files changed, 26 insertions(+), 1 deletion(-)
diff --git a/docs/boothd.8.txt b/docs/boothd.8.txt diff --git a/docs/boothd.8.txt b/docs/boothd.8.txt
index f58f27e..12f66f9 100644 index 0f3d2c1..c7a8413 100644
--- a/docs/boothd.8.txt --- a/docs/boothd.8.txt
+++ b/docs/boothd.8.txt +++ b/docs/boothd.8.txt
@@ -230,6 +230,13 @@ will always bind and listen to both UDP and TCP ports. @@ -230,6 +230,13 @@ will always bind and listen to both UDP and TCP ports.
parameter to a higher value. The time skew test is performed parameter to a higher value. The time skew test is performed
only in concert with authentication. only in concert with authentication.
+*'enable-authfile'*:: +'enable-authfile'::
+ Enables (or disables) usage of authfile. Can be 'yes' or 'no'. + Enables (or disables) usage of authfile. Can be 'yes' or 'no'.
+ Default is 'no'. + Default is 'no'.
+ This is non-upstream option used to allow use of authfile without + This is non-upstream option used to allow use of authfile without
+ breaking compatibility for clusters consisting of mixed + breaking compatibility for clusters consisting of mixed
+ versions of booth. + versions of booth.
+ +
*'site'*:: 'debug'::
Defines a site Raft member with the given IP. Sites can Specifies the debug output level. Alternative to
acquire tickets. The sites' IP should be managed by the cluster. command line argument. Effective only for 'daemon'
diff --git a/src/config.c b/src/config.c diff --git a/src/config.c b/src/config.c
index 8e41553..b9df3e3 100644 index f0ca4aa..e1f25f0 100644
--- a/src/config.c --- a/src/config.c
+++ b/src/config.c +++ b/src/config.c
@@ -729,6 +729,23 @@ no_value: @@ -732,6 +732,23 @@ no_value:
booth_conf->maxtimeskew = atoi(val); booth_conf->maxtimeskew = atoi(val);
continue; continue;
} }
@ -102,5 +102,5 @@ index b4a174f..0fdb295 100644
if (rv < 0) if (rv < 0)
goto out; goto out;
-- --
2.37.1 2.27.0

View File

@ -28,10 +28,10 @@
# This will be used to fill booth_ver, booth_numcomm and booth_sha1. # This will be used to fill booth_ver, booth_numcomm and booth_sha1.
# It is important to keep abbrev to get full length sha1! When updating source use # It is important to keep abbrev to get full length sha1! When updating source use
# `spectool -g booth.spec` to download source. # `spectool -g booth.spec` to download source.
%global git_describe_str v1.0-251-gbfb2f924c07db823f5c934d1aafbc5181bb25148 %global git_describe_str v1.0-283-g9d4029aa14323a7f3b496215d25e40bd14f33632
# Set this to 1 when rebasing (changing git_describe_str) and increase otherwise # Set this to 1 when rebasing (changing git_describe_str) and increase otherwise
%global release 5 %global release 1
# Run shell script to parse git_describe str into version, numcomm and sha1 hash # Run shell script to parse git_describe str into version, numcomm and sha1 hash
%global booth_ver %(s=%{git_describe_str}; vver=${s%%%%-*}; echo ${vver:1}) %global booth_ver %(s=%{git_describe_str}; vver=${s%%%%-*}; echo ${vver:1})
@ -62,9 +62,7 @@ Summary: Ticket Manager for Multi-site Clusters
License: GPLv2+ License: GPLv2+
Url: https://github.com/%{github_owner}/%{name} Url: https://github.com/%{github_owner}/%{name}
Source0: https://github.com/%{github_owner}/%{name}/archive/%{booth_short_sha1}/%{booth_archive_name}.tar.gz Source0: https://github.com/%{github_owner}/%{name}/archive/%{booth_short_sha1}/%{booth_archive_name}.tar.gz
Patch0: bz2111669-1-Revert-Refactor-main-substitute-is_auth_req-macro.patch Patch0: rhel-specific-0001-config-Add-enable-authfile-option.patch
Patch1: bz2111669-2-config-Add-enable-authfile-option.patch
Patch2: bz2133833-1-unit-file-Remove-Alias-directive.patch
# direct build process dependencies # direct build process dependencies
BuildRequires: autoconf BuildRequires: autoconf
@ -313,6 +311,11 @@ VERBOSE=1 make check
%{_usr}/lib/ocf/resource.d/booth/sharedrsc %{_usr}/lib/ocf/resource.d/booth/sharedrsc
%changelog %changelog
* Mon Nov 21 2022 Jan Friesse <jfriesse@redhat.com> - 1.0-283.1.9d4029a.git
- Resolves: rhbz#2135866
- Update to current snapshot (commit 9d4029a) (rhbz#2135866)
* Tue Oct 25 2022 Jan Friesse <jfriesse@redhat.com> - 1.0-251.5.bfb2f92.git * Tue Oct 25 2022 Jan Friesse <jfriesse@redhat.com> - 1.0-251.5.bfb2f92.git
- Resolves: rhbz#2133833 - Resolves: rhbz#2133833