Additional build fix for proper long-double detection

This commit is contained in:
Petr Machata 2012-01-25 15:02:25 +01:00
parent 0f5140e4c1
commit 1a7f14244d
2 changed files with 23 additions and 1 deletions

View File

@ -0,0 +1,20 @@
diff -urpN boost_1_48_0/libs/math/config/CMakeLists.txt boost_1_48_0.pm/libs/math/config/CMakeLists.txt
--- boost_1_48_0/libs/math/config/CMakeLists.txt 1969-12-31 19:00:00.000000000 -0500
+++ boost_1_48_0.pm/libs/math/config/CMakeLists.txt 2012-01-25 06:13:29.000000000 -0500
@@ -0,0 +1,3 @@
+project(has_long_double_support CXX)
+add_executable(has_long_double_support has_long_double_support.cpp)
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/../../../)
diff -urpN boost_1_48_0/libs/math/src/tr1/CMakeLists.txt boost_1_48_0.pm/libs/math/src/tr1/CMakeLists.txt
--- boost_1_48_0/libs/math/src/tr1/CMakeLists.txt 2012-01-25 07:32:50.000000000 -0500
+++ boost_1_48_0.pm/libs/math/src/tr1/CMakeLists.txt 2012-01-25 07:29:01.000000000 -0500
@@ -51,7 +51,8 @@ boost_add_library(math_c99f
try_compile(HAS_LONG_DOUBLE_SUPPORT
${CMAKE_CURRENT_SOURCE_DIR}/../../config/
- ${CMAKE_CURRENT_SOURCE_DIR}/../../config/has_long_double_support.cpp)
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../config/
+ has_long_double_support)
IF (HAS_LONG_DOUBLE_SUPPORT)
boost_add_library(math_tr1l

View File

@ -129,7 +129,8 @@ Patch8: boost-1.48.0-gcc47-pthreads.patch
Patch9: boost-1.48.0-attribute.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=783660
Patch10: boost-1.48.0-long-double.patch
Patch10: boost-1.48.0-long-double-1.patch
Patch11: boost-1.48.0-long-double.patch
%bcond_with tests
%bcond_with docs_generated
@ -499,6 +500,7 @@ sed 's/_FEDORA_SONAME/%{sonamever}/' %{PATCH1} | %{__patch} -p0 --fuzz=0
%patch8 -p0
%patch9 -p1
%patch10 -p1
%patch11 -p1
%build
# Support for building tests.