The second half of long double support

This commit is contained in:
Petr Machata 2012-01-25 02:17:46 +01:00
parent a7311be698
commit 0f5140e4c1
2 changed files with 27 additions and 1 deletions

View File

@ -0,0 +1,14 @@
diff -up boost_1_48_0/boost/math/tools/config.hpp\~ boost_1_48_0/boost/math/tools/config.hpp
--- boost_1_48_0/boost/math/tools/config.hpp~ 2011-10-16 20:57:30.000000000 +0200
+++ boost_1_48_0/boost/math/tools/config.hpp 2012-01-25 01:50:44.446832172 +0100
@@ -24,7 +24,7 @@
#include <boost/math/special_functions/detail/round_fwd.hpp>
#if (defined(__CYGWIN__) || defined(__FreeBSD__) || defined(__NetBSD__) \
- || (defined(__hppa) && !defined(__OpenBSD__)) || defined(__NO_LONG_DOUBLE_MATH)) && !defined(BOOST_MATH_NO_LONG_DOUBLE_MATH_FUNCTIONS)
+ || (defined(__hppa) && !defined(__OpenBSD__))) && !defined(BOOST_MATH_NO_LONG_DOUBLE_MATH_FUNCTIONS)
# define BOOST_MATH_NO_LONG_DOUBLE_MATH_FUNCTIONS
#endif
#if BOOST_WORKAROUND(__BORLANDC__, BOOST_TESTED_AT(0x582))
Diff finished. Wed Jan 25 01:50:49 2012

View File

@ -28,7 +28,7 @@ Name: boost
Summary: The free peer-reviewed portable C++ source libraries
Version: 1.48.0
%define version_enc 1_48_0
Release: 8%{?dist}
Release: 9%{?dist}
License: Boost and MIT and Python
# The CMake build framework (set of CMakeLists.txt and module.cmake files) is
@ -128,6 +128,9 @@ Patch8: boost-1.48.0-gcc47-pthreads.patch
# https://svn.boost.org/trac/boost/ticket/6416
Patch9: boost-1.48.0-attribute.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=783660
Patch10: boost-1.48.0-long-double.patch
%bcond_with tests
%bcond_with docs_generated
@ -495,6 +498,7 @@ sed 's/_FEDORA_SONAME/%{sonamever}/' %{PATCH1} | %{__patch} -p0 --fuzz=0
%patch7 -p2
%patch8 -p0
%patch9 -p1
%patch10 -p1
%build
# Support for building tests.
@ -998,6 +1002,14 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/bjam.1*
%changelog
* Wed Jan 25 2012 Petr Machata <pmachata@redhat.com> - 1.48.0-9
- Only build the long double math libraries on arches that support
long double.
- ARM was considered unsupporting, because libc defines
__NO_LONG_DOUBLE_MATH. Ignore this setting, ARM has perfectly
working long double that just happens to be only as long as double.
- Resolves: #783660
* Mon Jan 16 2012 Petr Machata <pmachata@redhat.com> - 1.48.0-8
- Add underscores around several uses of __attribute__((X)) to prevent
interactions with user-defined macro X