Fix sixaxis patch to apply

This commit is contained in:
Bastien Nocera 2010-10-27 19:16:55 +01:00
parent e8cf4822fb
commit fb14d2c2a8

View File

@ -1,7 +1,7 @@
From 25e16a281dc158660c03fa475ffdc4b575642f5b Mon Sep 17 00:00:00 2001
From 4165e66ef8517cf48e90be7ccb3ba4f4fcd57153 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 1 Sep 2009 17:32:48 +0100
Subject: [PATCH 1/3] Add sixaxis cable-pairing plugin
Subject: [PATCH] Add sixaxis cable-pairing plugin
Implement the old "sixpair" using libudev and libusb-1.0.
@ -17,7 +17,7 @@ address, and added to the database of the current default adapter.
create mode 100644 plugins/cable.c
diff --git a/Makefile.am b/Makefile.am
index 8f9f5d3..e855713 100644
index 6e8fc7d..8636530 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -195,6 +195,11 @@ builtin_sources += health/hdp_main.c health/hdp_types.h \
@ -36,8 +36,8 @@ index 8f9f5d3..e855713 100644
src/dbus-common.c src/dbus-common.h \
src/dbus-hci.h src/dbus-hci.c
src_bluetoothd_LDADD = lib/libbluetooth.la @GLIB_LIBS@ @DBUS_LIBS@ \
- @CAPNG_LIBS@ -ldl
+ @CAPNG_LIBS@ @CABLE_LIBS@ -ldl
- @CAPNG_LIBS@ -ldl -lrt
+ @CAPNG_LIBS@ @CABLE_LIBS@ -ldl -lrt
src_bluetoothd_LDFLAGS = -Wl,--export-dynamic \
-Wl,--version-script=$(srcdir)/src/bluetooth.ver
@ -104,7 +104,7 @@ index 287f07d..aab0c15 100644
+ AM_CONDITIONAL(CABLE, test "${cable_enable}" = "yes" && test "${cable_found}" = "yes")
])
diff --git a/configure.ac b/configure.ac
index 6ffeb20..d375ac9 100644
index 13a154c..59b0693 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,7 @@ AC_PATH_GLIB