Add missing patch
This commit is contained in:
parent
6f4f6b1926
commit
e8cf4822fb
34
0002-build-Fix-parallel-build.patch
Normal file
34
0002-build-Fix-parallel-build.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From ad21a880935863d3592cae708147ef54c796222d Mon Sep 17 00:00:00 2001
|
||||
From: Bastien Nocera <hadess@hadess.net>
|
||||
Date: Wed, 27 Oct 2010 18:54:49 +0100
|
||||
Subject: [PATCH 2/3] build: Fix parallel build
|
||||
|
||||
Fix parallel build where parser.h won't have been generated when
|
||||
we're trying to compile kword itself.
|
||||
|
||||
YACC tools/parser.c
|
||||
LEX tools/lexer.c
|
||||
conflicts: 3 shift/reduce
|
||||
CC tools/kword.o
|
||||
tools/kword.c:36:20: fatal error: parser.h: No such file or directory
|
||||
compilation terminated.
|
||||
---
|
||||
Makefile.tools | 2 ++
|
||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/Makefile.tools b/Makefile.tools
|
||||
index 405a42b..797b53d 100644
|
||||
--- a/Makefile.tools
|
||||
+++ b/Makefile.tools
|
||||
@@ -12,6 +12,8 @@ sbin_PROGRAMS += tools/hciattach tools/hciconfig
|
||||
noinst_PROGRAMS += tools/avinfo tools/ppporc \
|
||||
tools/hcieventmask tools/hcisecfilter
|
||||
|
||||
+tools/kword.c: tools/parser.h
|
||||
+
|
||||
tools_rfcomm_SOURCES = tools/main.c tools/parser.y tools/lexer.l \
|
||||
tools/kword.h tools/kword.c
|
||||
EXTRA_tools_rfcomm_SOURCES = tools/parser.h tools/parser.c \
|
||||
--
|
||||
1.7.3.1
|
||||
|
Loading…
Reference in New Issue
Block a user