Rebase to 2.6.1
This commit is contained in:
parent
719f50443c
commit
7cbe3912ed
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ bison-2.4.2.tar.bz2
|
|||||||
bison-2.4.3.tar.bz2
|
bison-2.4.3.tar.bz2
|
||||||
bison-*/
|
bison-*/
|
||||||
/bison-2.5.tar.bz2
|
/bison-2.5.tar.bz2
|
||||||
|
/bison-2.6.1.tar.xz
|
||||||
|
@ -1,51 +0,0 @@
|
|||||||
diff -up bison-2.4.2/tests/skeletons.at\~ bison-2.4.2/tests/skeletons.at
|
|
||||||
--- bison-2.4.2/tests/skeletons.at~ 2010-02-23 01:04:09.000000000 +0100
|
|
||||||
+++ bison-2.4.2/tests/skeletons.at 2010-04-08 20:28:49.000000000 +0200
|
|
||||||
@@ -288,45 +288,3 @@ foo.y:1.5-6: fatal error: M4 should exit
|
|
||||||
]])
|
|
||||||
|
|
||||||
AT_CLEANUP
|
|
||||||
-
|
|
||||||
-
|
|
||||||
-## ------------------------------------------------ ##
|
|
||||||
-## Fatal errors but M4 continues producing output. ##
|
|
||||||
-## ------------------------------------------------ ##
|
|
||||||
-
|
|
||||||
-# At one time, if Bison encountered a fatal error during M4 processing,
|
|
||||||
-# Bison failed to drain M4's output pipe. The result was a SIGPIPE.
|
|
||||||
-# On some platforms, the default disposition for SIGPIPE is terminate,
|
|
||||||
-# which was fine. On others, it's ignore, which caused M4 to report
|
|
||||||
-# the broken pipe to the user, but we don't want to bother the user with
|
|
||||||
-# that.
|
|
||||||
-
|
|
||||||
-# There is a race condition somewhere. That is, before the associated
|
|
||||||
-# fix, running this test group many times in a row would occasionally
|
|
||||||
-# produce a pass among all the failures.
|
|
||||||
-
|
|
||||||
-AT_SETUP([[Fatal errors but M4 continues producing output]])
|
|
||||||
-
|
|
||||||
-AT_DATA([[gen-skel.pl]],
|
|
||||||
-[[use warnings;
|
|
||||||
-use strict;
|
|
||||||
-my $M4 = "m4";
|
|
||||||
-my $DNL = "d"."nl";
|
|
||||||
-print "${M4}_divert_push(0)$DNL\n";
|
|
||||||
-print '@output(@,@)', "\n";
|
|
||||||
-(print "garbage"x10, "\n") for (1..1000);
|
|
||||||
-print "${M4}_divert_pop(0)\n";
|
|
||||||
-]])
|
|
||||||
-AT_CHECK([[perl gen-skel.pl > skel.c || exit 77]])
|
|
||||||
-
|
|
||||||
-AT_DATA([[input.y]],
|
|
||||||
-[[%skeleton "./skel.c"
|
|
||||||
-%%
|
|
||||||
-start: ;
|
|
||||||
-]])
|
|
||||||
-
|
|
||||||
-AT_BISON_CHECK([[input.y]], [[1]], [[]],
|
|
||||||
-[[input.y: fatal error: too many arguments for @output directive in skeleton
|
|
||||||
-]])
|
|
||||||
-
|
|
||||||
-AT_CLEANUP
|
|
||||||
|
|
||||||
Diff finished. Thu Apr 8 20:28:56 2010
|
|
17
bison.spec
17
bison.spec
@ -1,13 +1,12 @@
|
|||||||
Summary: A GNU general-purpose parser generator
|
Summary: A GNU general-purpose parser generator
|
||||||
Name: bison
|
Name: bison
|
||||||
Version: 2.5
|
Version: 2.6.1
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Source: ftp://ftp.gnu.org/pub/gnu/bison/bison-%{version}.tar.bz2
|
Source: ftp://ftp.gnu.org/pub/gnu/bison/bison-%{version}.tar.xz
|
||||||
|
|
||||||
# testsuite patch and a dependency
|
# testsuite dependency
|
||||||
Patch0: bison-2.4.2-drop-test-67.patch
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
|
|
||||||
URL: http://www.gnu.org/software/bison/
|
URL: http://www.gnu.org/software/bison/
|
||||||
@ -73,7 +72,6 @@ Bison manual section for more information.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -113,7 +111,7 @@ fi
|
|||||||
# when the target parser file is generated.
|
# when the target parser file is generated.
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc AUTHORS ChangeLog NEWS OChangeLog README THANKS TODO COPYING
|
%doc AUTHORS ChangeLog NEWS README THANKS TODO COPYING
|
||||||
%{_mandir}/*/bison*
|
%{_mandir}/*/bison*
|
||||||
%{_datadir}/bison
|
%{_datadir}/bison
|
||||||
%{_infodir}/bison.info*
|
%{_infodir}/bison.info*
|
||||||
@ -132,6 +130,11 @@ fi
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 31 2012 Petr Machata <pmachata@redhat.com> - 2.6.1-1
|
||||||
|
- Rebase to 2.6.1
|
||||||
|
- Drop bison-2.4.2-drop-test-67.patch
|
||||||
|
- Resolves: #829028
|
||||||
|
|
||||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-5
|
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user