Drop unused options --raw, -n, -e, --include and -I
This commit is contained in:
parent
2d03d03717
commit
7b4c369f4f
53
bison-2.7-unused-opts.patch
Normal file
53
bison-2.7-unused-opts.patch
Normal file
@ -0,0 +1,53 @@
|
||||
diff -up bison-2.7/src/getargs.c\~ bison-2.7/src/getargs.c
|
||||
--- bison-2.7/src/getargs.c~ 2012-12-05 14:51:18.000000000 +0100
|
||||
+++ bison-2.7/src/getargs.c 2013-05-17 17:45:53.188616509 +0200
|
||||
@@ -80,7 +80,6 @@ int skeleton_prio = default_prio;
|
||||
const char *skeleton = NULL;
|
||||
int language_prio = default_prio;
|
||||
struct bison_language const *language = &valid_languages[0];
|
||||
-const char *include = NULL;
|
||||
|
||||
|
||||
/** Decode an option's set of keys.
|
||||
@@ -500,12 +499,10 @@ static char const short_options[] =
|
||||
"b:"
|
||||
"d"
|
||||
"f::"
|
||||
- "e"
|
||||
"g::"
|
||||
"h"
|
||||
"k"
|
||||
"l"
|
||||
- "n"
|
||||
"o:"
|
||||
"p:"
|
||||
"r:"
|
||||
@@ -535,7 +532,6 @@ static struct option const long_options[
|
||||
|
||||
/* Parser. */
|
||||
{ "name-prefix", required_argument, 0, 'p' },
|
||||
- { "include", required_argument, 0, 'I' },
|
||||
|
||||
/* Output. */
|
||||
{ "file-prefix", required_argument, 0, 'b' },
|
||||
@@ -564,7 +560,6 @@ static struct option const long_options[
|
||||
{ "force-define", required_argument, 0, 'F' },
|
||||
{ "locations", no_argument, 0, LOCATIONS_OPTION },
|
||||
{ "no-lines", no_argument, 0, 'l' },
|
||||
- { "raw", no_argument, 0, 0 },
|
||||
{ "skeleton", required_argument, 0, 'S' },
|
||||
{ "language", required_argument, 0, 'L' },
|
||||
{ "token-table", no_argument, 0, 'k' },
|
||||
@@ -623,10 +618,6 @@ getargs (int argc, char *argv[])
|
||||
}
|
||||
break;
|
||||
|
||||
- case 'I':
|
||||
- include = AS_FILE_NAME (optarg);
|
||||
- break;
|
||||
-
|
||||
case 'L':
|
||||
language_argmatch (optarg, command_line_prio,
|
||||
command_line_location ());
|
||||
|
||||
Diff finished. Fri May 17 17:45:58 2013
|
13
bison.spec
13
bison.spec
@ -1,17 +1,22 @@
|
||||
Summary: A GNU general-purpose parser generator
|
||||
Name: bison
|
||||
Version: 2.7
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Development/Tools
|
||||
Source: ftp://ftp.gnu.org/pub/gnu/bison/bison-%{version}.tar.xz
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=948856
|
||||
# Submitted for upstream inclusion on 2013-05-17.
|
||||
Patch0: bison-2.7-unused-opts.patch
|
||||
|
||||
# testsuite dependency
|
||||
BuildRequires: autoconf
|
||||
|
||||
URL: http://www.gnu.org/software/bison/
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
BuildRequires: m4 >= 1.4 java-1.7.0-openjdk-devel
|
||||
BuildRequires: m4 >= 1.4
|
||||
#java-1.7.0-openjdk-devel
|
||||
Requires: m4 >= 1.4
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
@ -72,6 +77,7 @@ Bison manual section for more information.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -130,6 +136,9 @@ fi
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%changelog
|
||||
* Fri May 17 2013 Petr Machata <pmachata@redhat.com> - 2.7-2
|
||||
- Drop unused options --raw, -n, -e, --include and -I
|
||||
|
||||
* Thu Mar 21 2013 Petr Machata <pmachata@redhat.com> - 2.7-1
|
||||
- Rebase to 2.7
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user