Properly test also gsstsig upstream test
Disabled by mistake by downstream patch. Related: RHEL-50591
This commit is contained in:
parent
16baeaf03b
commit
c099c3f187
@ -1,4 +1,4 @@
|
|||||||
From e645046202006750f87531e21e3ff7c26fba3466 Mon Sep 17 00:00:00 2001
|
From e9e7069ede766fa5c881517bdae74e2fc6682398 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
|
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
|
||||||
Date: Wed, 30 Jan 2019 14:37:17 +0100
|
Date: Wed, 30 Jan 2019 14:37:17 +0100
|
||||||
Subject: [PATCH] Create feature-test in source directory
|
Subject: [PATCH] Create feature-test in source directory
|
||||||
@ -6,16 +6,27 @@ Subject: [PATCH] Create feature-test in source directory
|
|||||||
Feature-test tool is used in system tests to test compiled in changes.
|
Feature-test tool is used in system tests to test compiled in changes.
|
||||||
Because we build more variants of named with different configuration,
|
Because we build more variants of named with different configuration,
|
||||||
compile feature-test for each of them this way.
|
compile feature-test for each of them this way.
|
||||||
|
|
||||||
|
Make gsstsig test supported
|
||||||
---
|
---
|
||||||
bin/named/Makefile.in | 12 +++++++++++-
|
bin/named/Makefile.in | 14 ++++++++++++--
|
||||||
bin/tests/system/conf.sh.in | 2 +-
|
bin/tests/system/conf.sh.in | 2 +-
|
||||||
2 files changed, 12 insertions(+), 2 deletions(-)
|
2 files changed, 13 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/bin/named/Makefile.in b/bin/named/Makefile.in
|
diff --git a/bin/named/Makefile.in b/bin/named/Makefile.in
|
||||||
index 37053a7..ed9add2 100644
|
index debb906adc..dd894fe934 100644
|
||||||
--- a/bin/named/Makefile.in
|
--- a/bin/named/Makefile.in
|
||||||
+++ b/bin/named/Makefile.in
|
+++ b/bin/named/Makefile.in
|
||||||
@@ -91,7 +91,7 @@ NOSYMLIBS = ${NSLIBS} ${DNSLIBS} ${BIND9LIBS} \
|
@@ -56,7 +56,7 @@ CINCLUDES = -I${srcdir}/include -I${srcdir}/unix/include -I. \
|
||||||
|
${LIBXML2_CFLAGS} \
|
||||||
|
${MAXMINDDB_CFLAGS}
|
||||||
|
|
||||||
|
-CDEFINES = @CONTRIB_DLZ@
|
||||||
|
+CDEFINES = @USE_GSSAPI@ @CONTRIB_DLZ@
|
||||||
|
|
||||||
|
CWARNINGS =
|
||||||
|
|
||||||
|
@@ -93,7 +93,7 @@ NOSYMLIBS = ${NSLIBS} ${DNSLIBS} ${BIND9LIBS} \
|
||||||
|
|
||||||
SUBDIRS = unix
|
SUBDIRS = unix
|
||||||
|
|
||||||
@ -24,7 +35,7 @@ index 37053a7..ed9add2 100644
|
|||||||
|
|
||||||
GEOIP2LINKOBJS = geoip.@O@
|
GEOIP2LINKOBJS = geoip.@O@
|
||||||
|
|
||||||
@@ -154,6 +154,16 @@ named@EXEEXT@: ${OBJS} ${DEPLIBS}
|
@@ -156,6 +156,16 @@ named@EXEEXT@: ${OBJS} ${DEPLIBS}
|
||||||
export BASEOBJS="${OBJS} ${UOBJS}"; \
|
export BASEOBJS="${OBJS} ${UOBJS}"; \
|
||||||
${FINALBUILDCMD}
|
${FINALBUILDCMD}
|
||||||
|
|
||||||
@ -42,10 +53,10 @@ index 37053a7..ed9add2 100644
|
|||||||
rm -f ${TARGETS} ${OBJS}
|
rm -f ${TARGETS} ${OBJS}
|
||||||
|
|
||||||
diff --git a/bin/tests/system/conf.sh.in b/bin/tests/system/conf.sh.in
|
diff --git a/bin/tests/system/conf.sh.in b/bin/tests/system/conf.sh.in
|
||||||
index 7934930..e84fde2 100644
|
index 9a61622143..f69c5be334 100644
|
||||||
--- a/bin/tests/system/conf.sh.in
|
--- a/bin/tests/system/conf.sh.in
|
||||||
+++ b/bin/tests/system/conf.sh.in
|
+++ b/bin/tests/system/conf.sh.in
|
||||||
@@ -37,7 +37,7 @@ DELV=$TOP/bin/delv/delv
|
@@ -38,7 +38,7 @@ DELV=$TOP/bin/delv/delv
|
||||||
DIG=$TOP/bin/dig/dig
|
DIG=$TOP/bin/dig/dig
|
||||||
DNSTAPREAD=$TOP/bin/tools/dnstap-read
|
DNSTAPREAD=$TOP/bin/tools/dnstap-read
|
||||||
DSFROMKEY=$TOP/bin/dnssec/dnssec-dsfromkey
|
DSFROMKEY=$TOP/bin/dnssec/dnssec-dsfromkey
|
||||||
@ -55,5 +66,5 @@ index 7934930..e84fde2 100644
|
|||||||
HOST=$TOP/bin/dig/host
|
HOST=$TOP/bin/dig/host
|
||||||
IMPORTKEY=$TOP/bin/dnssec/dnssec-importkey
|
IMPORTKEY=$TOP/bin/dnssec/dnssec-importkey
|
||||||
--
|
--
|
||||||
2.26.2
|
2.45.2
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user