98 lines
4.4 KiB
Diff
98 lines
4.4 KiB
Diff
diff -Naur bacula-13.0.0.old/autoconf/configure.in bacula-13.0.0/autoconf/configure.in
|
|
--- bacula-13.0.0.old/autoconf/configure.in 2022-07-08 14:52:53.890141040 +0200
|
|
+++ bacula-13.0.0/autoconf/configure.in 2022-07-08 14:53:05.527348638 +0200
|
|
@@ -4040,7 +4040,7 @@
|
|
cd src/qt-console
|
|
chmod 755 install_conf_file build-depkgs-qt-console
|
|
cd tray-monitor
|
|
-chmod 755 install_conf_file
|
|
+chmod 755 install_conf_file build-depkgs-qt-console
|
|
cd ${BUILD_DIR}
|
|
|
|
cd scripts
|
|
diff -Naur bacula-13.0.0.old/examples/nagios/check_bacula/Makefile.in bacula-13.0.0/examples/nagios/check_bacula/Makefile.in
|
|
--- bacula-13.0.0.old/examples/nagios/check_bacula/Makefile.in 2022-07-08 14:50:02.318058909 +0200
|
|
+++ bacula-13.0.0/examples/nagios/check_bacula/Makefile.in 2022-07-08 14:53:05.527348638 +0200
|
|
@@ -72,7 +72,8 @@
|
|
(cd $(srcdir); $(RMF) Makefile)
|
|
|
|
install: all
|
|
- $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) check_bacula $(DESTDIR)$(sbindir)/check_bacula
|
|
+ $(MKDIR) $(DESTDIR)$(libdir)/nagios/plugins
|
|
+ $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) .libs/check_bacula $(DESTDIR)$(libdir)/nagios/plugins/check_bacula
|
|
|
|
uninstall:
|
|
(cd $(DESTDIR)$(sbindir); $(RMF) check_bacula)
|
|
diff -Naur bacula-13.0.0.old/src/cats/make_sqlite3_tables.in bacula-13.0.0/src/cats/make_sqlite3_tables.in
|
|
--- bacula-13.0.0.old/src/cats/make_sqlite3_tables.in 2022-07-08 14:50:02.173056303 +0200
|
|
+++ bacula-13.0.0/src/cats/make_sqlite3_tables.in 2022-07-08 14:53:05.562349262 +0200
|
|
@@ -560,4 +560,5 @@
|
|
echo ""
|
|
|
|
chmod 640 ${db_name}.db
|
|
+chown bacula:bacula ${db_name}.db
|
|
exit 0
|
|
diff -Naur bacula-13.0.0.old/src/dird/bacula-dir.conf.in bacula-13.0.0/src/dird/bacula-dir.conf.in
|
|
--- bacula-13.0.0.old/src/dird/bacula-dir.conf.in 2022-07-08 14:50:02.205056878 +0200
|
|
+++ bacula-13.0.0/src/dird/bacula-dir.conf.in 2022-07-08 14:53:05.563349280 +0200
|
|
@@ -18,7 +18,7 @@
|
|
Director { # define myself
|
|
Name = @basename@-dir
|
|
DIRport = @dir_port@ # where we listen for UA connections
|
|
- QueryFile = "@scriptdir@/query.sql"
|
|
+ QueryFile = "@sysconfdir@/query.sql"
|
|
WorkingDirectory = "@working_dir@"
|
|
PidDirectory = "@piddir@"
|
|
Maximum Concurrent Jobs = 20
|
|
diff -Naur bacula-13.0.0.old/src/dird/Makefile.in bacula-13.0.0/src/dird/Makefile.in
|
|
--- bacula-13.0.0.old/src/dird/Makefile.in 2022-07-08 14:50:02.205056878 +0200
|
|
+++ bacula-13.0.0/src/dird/Makefile.in 2022-07-08 14:53:05.564349298 +0200
|
|
@@ -126,11 +126,11 @@
|
|
@if test "x${dir_group}" != "x"; then \
|
|
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
|
fi
|
|
- @if test -f ${DESTDIR}${scriptdir}/query.sql; then \
|
|
+ @if test -f ${DESTDIR}${sysconfdir}/query.sql; then \
|
|
echo " ==> Saving existing query.sql to query.sql.old"; \
|
|
- $(MV) -f ${DESTDIR}${scriptdir}/query.sql ${DESTDIR}${scriptdir}/query.sql.old; \
|
|
+ $(MV) -f ${DESTDIR}${sysconfdir}/query.sql ${DESTDIR}${sysconfdir}/query.sql.old; \
|
|
fi
|
|
- ${INSTALL_DATA} query.sql ${DESTDIR}${scriptdir}/query.sql
|
|
+ ${INSTALL_DATA} query.sql ${DESTDIR}${sysconfdir}/query.sql
|
|
@if test -f static-bacula-dir; then \
|
|
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) static-bacula-dir $(DESTDIR)$(sbindir)/static-bacula-dir; \
|
|
fi
|
|
@@ -139,7 +139,7 @@
|
|
uninstall:
|
|
(cd $(DESTDIR)$(sbindir); $(RMF) bacula-dir bdirjson)
|
|
(cd $(DESTDIR)$(sysconfdir); $(RMF) bacula-dir.conf bacula-dir.conf.new)
|
|
- (cd $(DESTDIR)$(scriptdir); $(RMF) query.sql)
|
|
+ (cd $(DESTDIR)$(sysconfdir); $(RMF) query.sql)
|
|
|
|
|
|
|
|
diff -Naur bacula-13.0.0.old/src/qt-console/bat.pro.in bacula-13.0.0/src/qt-console/bat.pro.in
|
|
--- bacula-13.0.0.old/src/qt-console/bat.pro.in 2022-07-08 14:52:53.891141058 +0200
|
|
+++ bacula-13.0.0/src/qt-console/bat.pro.in 2022-07-08 14:53:05.564349298 +0200
|
|
@@ -12,7 +12,7 @@
|
|
|
|
datarootdir = @datarootdir@
|
|
bins.path = /$(DESTDIR)@sbindir@
|
|
-bins.files = bat
|
|
+bins.files = .libs/bat
|
|
confs.path = /$(DESTDIR)@sysconfdir@
|
|
confs.commands = ./install_conf_file
|
|
help.path = /$(DESTDIR)@htmldir@
|
|
diff -Naur bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in
|
|
--- bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:52:53.892141076 +0200
|
|
+++ bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:53:05.565349316 +0200
|
|
@@ -26,7 +26,7 @@
|
|
|
|
|
|
bins.path = /$(DESTDIR)@sbindir@
|
|
-bins.files = bacula-tray-monitor
|
|
+bins.files = .libs/bacula-tray-monitor
|
|
confs.path = /$(DESTDIR)@sysconfdir@
|
|
confs.commands = ./install_conf_file
|
|
|