Update to version 13.0.0
This commit is contained in:
parent
6fda920c47
commit
504bbe743d
1
.gitignore
vendored
1
.gitignore
vendored
@ -58,3 +58,4 @@ bacula-docs-5.0.3.tar.bz2
|
||||
/bacula-11.0.3.tar.gz
|
||||
/bacula-11.0.5.tar.gz
|
||||
/bacula-11.0.6.tar.gz
|
||||
/bacula-13.0.0.tar.gz
|
||||
|
@ -1,43 +0,0 @@
|
||||
diff -Naur bacula-11.0.0.old/src/plugins/fd/Makefile.in bacula-11.0.0/src/plugins/fd/Makefile.in
|
||||
--- bacula-11.0.0.old/src/plugins/fd/Makefile.in 2021-01-15 14:28:41.375718846 +0100
|
||||
+++ bacula-11.0.0/src/plugins/fd/Makefile.in 2021-01-15 14:37:51.212066769 +0100
|
||||
@@ -22,7 +22,7 @@
|
||||
.c.lo:
|
||||
$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I${SRCDIR} -I${FDDIR} -DTEST_PROGRAM -c $<
|
||||
|
||||
-all: bpipe-fd.la test-plugin-fd.la test-deltaseq-fd.la pluglib.lo
|
||||
+all: bpipe-fd.la cdp-fd.la test-plugin-fd.la test-deltaseq-fd.la pluglib.lo
|
||||
|
||||
example-plugin-fd.lo: example-plugin-fd.c ${FDDIR}/fd_plugins.h
|
||||
$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I../.. -I${FDDIR} -c example-plugin-fd.c
|
||||
@@ -36,8 +36,6 @@
|
||||
bpipe-fd.la: Makefile bpipe-fd$(DEFAULT_OBJECT_TYPE)
|
||||
$(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -shared bpipe-fd.lo -o $@ -rpath $(plugindir) -module -export-dynamic -avoid-version
|
||||
|
||||
-cdp: cdp-fd.la
|
||||
-
|
||||
cdp-fd.lo: cdp-fd.c journal.h folder-record.h file-record.h settings-record.h ${FDDIR}/fd_plugins.h
|
||||
$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -Wno-unused-function -I../.. -I${FDDIR} -c cdp-fd.c
|
||||
|
||||
@@ -47,12 +45,6 @@
|
||||
cdp-fd.la: Makefile cdp-fd$(DEFAULT_OBJECT_TYPE) journal.lo
|
||||
$(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -shared cdp-fd.lo journal.lo -o $@ -rpath $(plugindir) -module -export-dynamic -avoid-version
|
||||
|
||||
-install-cdp: cdp-fd.la
|
||||
- $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) cdp-fd.la $(DESTDIR)$(plugindir)
|
||||
- $(RMF) $(DESTDIR)$(plugindir)/cdp-fd.la
|
||||
-
|
||||
-
|
||||
-
|
||||
test-deltaseq-fd.lo: test-deltaseq-fd.c ${FDDIR}/fd_plugins.h fd_common.h
|
||||
$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I../.. -I${FDDIR} -c test-deltaseq-fd.c
|
||||
|
||||
@@ -69,6 +61,8 @@
|
||||
$(MKDIR) $(DESTDIR)$(plugindir)
|
||||
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) bpipe-fd.la $(DESTDIR)$(plugindir)
|
||||
$(RMF) $(DESTDIR)$(plugindir)/bpipe-fd.la
|
||||
+ $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) cdp-fd.la $(DESTDIR)$(plugindir)
|
||||
+ $(RMF) $(DESTDIR)$(plugindir)/cdp-fd.la
|
||||
|
||||
install-test-plugin: all
|
||||
$(MKDIR) $(DESTDIR)$(plugindir)
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-11.0.6.old/autoconf/bacula-macros/db.m4 bacula-11.0.6/autoconf/bacula-macros/db.m4
|
||||
--- bacula-11.0.6.old/autoconf/bacula-macros/db.m4 2022-03-26 15:44:08.577953123 +0100
|
||||
+++ bacula-11.0.6/autoconf/bacula-macros/db.m4 2022-03-26 15:49:32.246622405 +0100
|
||||
diff -Naur bacula-13.0.0.old/autoconf/bacula-macros/db.m4 bacula-13.0.0/autoconf/bacula-macros/db.m4
|
||||
--- bacula-13.0.0.old/autoconf/bacula-macros/db.m4 2022-07-08 14:50:02.293058459 +0200
|
||||
+++ bacula-13.0.0/autoconf/bacula-macros/db.m4 2022-07-08 14:52:40.525902566 +0200
|
||||
@@ -102,7 +102,7 @@
|
||||
fi
|
||||
DBI_INCLUDE=-I$DBI_INCDIR
|
||||
@ -55,9 +55,9 @@ diff -Naur bacula-11.0.6.old/autoconf/bacula-macros/db.m4 bacula-11.0.6/autoconf
|
||||
else
|
||||
POSTGRESQL_LIBS="-L$POSTGRESQL_LIBDIR -lpq"
|
||||
fi
|
||||
diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/configure.in
|
||||
--- bacula-11.0.6.old/autoconf/configure.in 2022-03-26 15:44:08.578953140 +0100
|
||||
+++ bacula-11.0.6/autoconf/configure.in 2022-03-26 15:49:32.297623298 +0100
|
||||
diff -Naur bacula-13.0.0.old/autoconf/configure.in bacula-13.0.0/autoconf/configure.in
|
||||
--- bacula-13.0.0.old/autoconf/configure.in 2022-07-08 14:50:02.292058441 +0200
|
||||
+++ bacula-13.0.0/autoconf/configure.in 2022-07-08 14:52:40.528902620 +0200
|
||||
@@ -16,7 +16,7 @@
|
||||
cd ${BUILD_DIR}
|
||||
AC_SUBST(BUILD_DIR)
|
||||
@ -67,7 +67,7 @@ diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/config
|
||||
AC_CONFIG_HEADERS(src/config.h:autoconf/config.h.in)
|
||||
|
||||
dnl minimal Win32 stuff for "make clean"
|
||||
@@ -3335,11 +3335,6 @@
|
||||
@@ -3508,11 +3508,6 @@
|
||||
AC_DEFINE(FDLIBS)
|
||||
|
||||
CFLAGS=${CFLAGS--O}
|
||||
@ -79,9 +79,9 @@ diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/config
|
||||
LDFLAGS=${LDFLAGS--O}
|
||||
CPPFLAGS="$CPPFLAGS"
|
||||
CFLAGS="$CFLAGS"
|
||||
diff -Naur bacula-11.0.6.old/autoconf/Make.common.in bacula-11.0.6/autoconf/Make.common.in
|
||||
--- bacula-11.0.6.old/autoconf/Make.common.in 2022-03-26 15:44:08.578953140 +0100
|
||||
+++ bacula-11.0.6/autoconf/Make.common.in 2022-03-26 15:49:32.297623298 +0100
|
||||
diff -Naur bacula-13.0.0.old/autoconf/Make.common.in bacula-13.0.0/autoconf/Make.common.in
|
||||
--- bacula-13.0.0.old/autoconf/Make.common.in 2022-07-08 14:50:02.290058405 +0200
|
||||
+++ bacula-13.0.0/autoconf/Make.common.in 2022-07-08 14:52:40.529902638 +0200
|
||||
@@ -75,12 +75,12 @@
|
||||
DEFAULT_ARCHIVE_TYPE = @DEFAULT_ARCHIVE_TYPE@
|
||||
DEFAULT_SHARED_OBJECT_TYPE = @DEFAULT_SHARED_OBJECT_TYPE@
|
||||
@ -101,9 +101,9 @@ diff -Naur bacula-11.0.6.old/autoconf/Make.common.in bacula-11.0.6/autoconf/Make
|
||||
|
||||
# Flags & libs
|
||||
CFLAGS = @CFLAGS@ @OPENSSL_INC@
|
||||
diff -Naur bacula-11.0.6.old/src/qt-console/bat.pro.in bacula-11.0.6/src/qt-console/bat.pro.in
|
||||
--- bacula-11.0.6.old/src/qt-console/bat.pro.in 2022-03-26 15:44:29.088312370 +0100
|
||||
+++ bacula-11.0.6/src/qt-console/bat.pro.in 2022-03-26 15:49:32.297623298 +0100
|
||||
diff -Naur bacula-13.0.0.old/src/qt-console/bat.pro.in bacula-13.0.0/src/qt-console/bat.pro.in
|
||||
--- bacula-13.0.0.old/src/qt-console/bat.pro.in 2022-07-08 14:50:57.498050723 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/bat.pro.in 2022-07-08 14:52:40.529902638 +0200
|
||||
@@ -23,8 +23,8 @@
|
||||
DEPENDPATH += .
|
||||
INCLUDEPATH += .. . ./console ./restore ./select
|
||||
@ -115,9 +115,9 @@ diff -Naur bacula-11.0.6.old/src/qt-console/bat.pro.in bacula-11.0.6/src/qt-cons
|
||||
QMAKE_LINK = $${LIBTOOL_LINK} $(CXX)
|
||||
QMAKE_INSTALL_PROGRAM = $${LIBTOOL_INSTALL} install -m @SBINPERM@ -p
|
||||
QMAKE_CLEAN += .libs/* bat
|
||||
diff -Naur bacula-11.0.6.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-11.0.6/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||
--- bacula-11.0.6.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-03-26 15:44:08.523952177 +0100
|
||||
+++ bacula-11.0.6/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-03-26 15:49:32.298623316 +0100
|
||||
diff -Naur bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||
--- bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:50:02.187056554 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:52:40.530902656 +0200
|
||||
@@ -36,8 +36,8 @@
|
||||
DEPENDPATH += .
|
||||
INCLUDEPATH += ../.. .
|
||||
|
@ -1,15 +1,15 @@
|
||||
diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/configure.in
|
||||
--- bacula-11.0.6.old/autoconf/configure.in 2022-03-26 15:51:18.976491851 +0100
|
||||
+++ bacula-11.0.6/autoconf/configure.in 2022-03-26 15:53:22.522655847 +0100
|
||||
@@ -3301,20 +3301,11 @@
|
||||
diff -Naur bacula-13.0.0.old/autoconf/configure.in bacula-13.0.0/autoconf/configure.in
|
||||
--- bacula-13.0.0.old/autoconf/configure.in 2022-07-08 14:53:19.765602625 +0200
|
||||
+++ bacula-13.0.0/autoconf/configure.in 2022-07-08 14:54:32.972908546 +0200
|
||||
@@ -3404,20 +3404,9 @@
|
||||
]
|
||||
)
|
||||
if test x$support_docker = xyes -o x$support_docker = xauto; then
|
||||
- AC_CHECK_PROG(docker_bin, docker, yes, no, "/usr/bin/")
|
||||
- if test x$docker_bin = xyes; then
|
||||
- support_docker=yes
|
||||
- FD_PLUGIN_DIR="$FD_PLUGIN_DIR src/plugins/fd/docker"
|
||||
- PLUGCONFILES="${PLUGCONFILES} src/plugins/fd/docker/Makefile"
|
||||
- FD_PLUGIN_DIR="${FD_PLUGIN_DIR} src/plugins/fd/docker"
|
||||
- FD_PLUGIN_INSTALL="${FD_PLUGIN_INSTALL} install-docker"
|
||||
- else
|
||||
- if test x$support_docker = xyes; then
|
||||
- echo " "
|
||||
@ -20,10 +20,8 @@ diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/config
|
||||
- support_docker=no
|
||||
- fi
|
||||
+ support_docker=yes
|
||||
+ FD_PLUGIN_DIR="$FD_PLUGIN_DIR src/plugins/fd/docker"
|
||||
+ PLUGCONFILES="${PLUGCONFILES} src/plugins/fd/docker/Makefile"
|
||||
+else
|
||||
+ support_docker=no
|
||||
+ FD_PLUGIN_DIR="${FD_PLUGIN_DIR} src/plugins/fd/docker"
|
||||
+ FD_PLUGIN_INSTALL="${FD_PLUGIN_INSTALL} install-docker"
|
||||
fi
|
||||
|
||||
AC_SUBST(FD_PLUGIN_DIR)
|
||||
dnl kubernetes Plugin
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/configure.in
|
||||
--- bacula-11.0.6.old/autoconf/configure.in 2022-03-26 15:50:09.232270232 +0100
|
||||
+++ bacula-11.0.6/autoconf/configure.in 2022-03-26 15:50:24.774542471 +0100
|
||||
@@ -3859,7 +3859,7 @@
|
||||
diff -Naur bacula-13.0.0.old/autoconf/configure.in bacula-13.0.0/autoconf/configure.in
|
||||
--- bacula-13.0.0.old/autoconf/configure.in 2022-07-08 14:52:53.890141040 +0200
|
||||
+++ bacula-13.0.0/autoconf/configure.in 2022-07-08 14:53:05.527348638 +0200
|
||||
@@ -4040,7 +4040,7 @@
|
||||
cd src/qt-console
|
||||
chmod 755 install_conf_file build-depkgs-qt-console
|
||||
cd tray-monitor
|
||||
@ -10,9 +10,9 @@ diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/config
|
||||
cd ${BUILD_DIR}
|
||||
|
||||
cd scripts
|
||||
diff -Naur bacula-11.0.6.old/examples/nagios/check_bacula/Makefile.in bacula-11.0.6/examples/nagios/check_bacula/Makefile.in
|
||||
--- bacula-11.0.6.old/examples/nagios/check_bacula/Makefile.in 2022-03-26 15:44:08.615953788 +0100
|
||||
+++ bacula-11.0.6/examples/nagios/check_bacula/Makefile.in 2022-03-26 15:50:24.775542488 +0100
|
||||
diff -Naur bacula-13.0.0.old/examples/nagios/check_bacula/Makefile.in bacula-13.0.0/examples/nagios/check_bacula/Makefile.in
|
||||
--- bacula-13.0.0.old/examples/nagios/check_bacula/Makefile.in 2022-07-08 14:50:02.318058909 +0200
|
||||
+++ bacula-13.0.0/examples/nagios/check_bacula/Makefile.in 2022-07-08 14:53:05.527348638 +0200
|
||||
@@ -72,7 +72,8 @@
|
||||
(cd $(srcdir); $(RMF) Makefile)
|
||||
|
||||
@ -23,18 +23,18 @@ diff -Naur bacula-11.0.6.old/examples/nagios/check_bacula/Makefile.in bacula-11.
|
||||
|
||||
uninstall:
|
||||
(cd $(DESTDIR)$(sbindir); $(RMF) check_bacula)
|
||||
diff -Naur bacula-11.0.6.old/src/cats/make_sqlite3_tables.in bacula-11.0.6/src/cats/make_sqlite3_tables.in
|
||||
--- bacula-11.0.6.old/src/cats/make_sqlite3_tables.in 2022-03-26 15:44:08.497951721 +0100
|
||||
+++ bacula-11.0.6/src/cats/make_sqlite3_tables.in 2022-03-26 15:50:30.181637182 +0100
|
||||
@@ -555,4 +555,5 @@
|
||||
diff -Naur bacula-13.0.0.old/src/cats/make_sqlite3_tables.in bacula-13.0.0/src/cats/make_sqlite3_tables.in
|
||||
--- bacula-13.0.0.old/src/cats/make_sqlite3_tables.in 2022-07-08 14:50:02.173056303 +0200
|
||||
+++ bacula-13.0.0/src/cats/make_sqlite3_tables.in 2022-07-08 14:53:05.562349262 +0200
|
||||
@@ -560,4 +560,5 @@
|
||||
echo ""
|
||||
|
||||
chmod 640 ${db_name}.db
|
||||
+chown bacula:bacula ${db_name}.db
|
||||
exit 0
|
||||
diff -Naur bacula-11.0.6.old/src/dird/bacula-dir.conf.in bacula-11.0.6/src/dird/bacula-dir.conf.in
|
||||
--- bacula-11.0.6.old/src/dird/bacula-dir.conf.in 2022-03-26 15:44:08.560952825 +0100
|
||||
+++ bacula-11.0.6/src/dird/bacula-dir.conf.in 2022-03-26 15:50:27.421588838 +0100
|
||||
diff -Naur bacula-13.0.0.old/src/dird/bacula-dir.conf.in bacula-13.0.0/src/dird/bacula-dir.conf.in
|
||||
--- bacula-13.0.0.old/src/dird/bacula-dir.conf.in 2022-07-08 14:50:02.205056878 +0200
|
||||
+++ bacula-13.0.0/src/dird/bacula-dir.conf.in 2022-07-08 14:53:05.563349280 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
Director { # define myself
|
||||
Name = @basename@-dir
|
||||
@ -44,10 +44,10 @@ diff -Naur bacula-11.0.6.old/src/dird/bacula-dir.conf.in bacula-11.0.6/src/dird/
|
||||
WorkingDirectory = "@working_dir@"
|
||||
PidDirectory = "@piddir@"
|
||||
Maximum Concurrent Jobs = 20
|
||||
diff -Naur bacula-11.0.6.old/src/dird/Makefile.in bacula-11.0.6/src/dird/Makefile.in
|
||||
--- bacula-11.0.6.old/src/dird/Makefile.in 2022-03-26 15:44:08.560952825 +0100
|
||||
+++ bacula-11.0.6/src/dird/Makefile.in 2022-03-26 15:50:27.452589381 +0100
|
||||
@@ -125,11 +125,11 @@
|
||||
diff -Naur bacula-13.0.0.old/src/dird/Makefile.in bacula-13.0.0/src/dird/Makefile.in
|
||||
--- bacula-13.0.0.old/src/dird/Makefile.in 2022-07-08 14:50:02.205056878 +0200
|
||||
+++ bacula-13.0.0/src/dird/Makefile.in 2022-07-08 14:53:05.564349298 +0200
|
||||
@@ -126,11 +126,11 @@
|
||||
@if test "x${dir_group}" != "x"; then \
|
||||
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
||||
fi
|
||||
@ -62,7 +62,7 @@ diff -Naur bacula-11.0.6.old/src/dird/Makefile.in bacula-11.0.6/src/dird/Makefil
|
||||
@if test -f static-bacula-dir; then \
|
||||
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) static-bacula-dir $(DESTDIR)$(sbindir)/static-bacula-dir; \
|
||||
fi
|
||||
@@ -138,7 +138,7 @@
|
||||
@@ -139,7 +139,7 @@
|
||||
uninstall:
|
||||
(cd $(DESTDIR)$(sbindir); $(RMF) bacula-dir bdirjson)
|
||||
(cd $(DESTDIR)$(sysconfdir); $(RMF) bacula-dir.conf bacula-dir.conf.new)
|
||||
@ -71,9 +71,9 @@ diff -Naur bacula-11.0.6.old/src/dird/Makefile.in bacula-11.0.6/src/dird/Makefil
|
||||
|
||||
|
||||
|
||||
diff -Naur bacula-11.0.6.old/src/qt-console/bat.pro.in bacula-11.0.6/src/qt-console/bat.pro.in
|
||||
--- bacula-11.0.6.old/src/qt-console/bat.pro.in 2022-03-26 15:50:09.233270249 +0100
|
||||
+++ bacula-11.0.6/src/qt-console/bat.pro.in 2022-03-26 15:50:24.807543049 +0100
|
||||
diff -Naur bacula-13.0.0.old/src/qt-console/bat.pro.in bacula-13.0.0/src/qt-console/bat.pro.in
|
||||
--- bacula-13.0.0.old/src/qt-console/bat.pro.in 2022-07-08 14:52:53.891141058 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/bat.pro.in 2022-07-08 14:53:05.564349298 +0200
|
||||
@@ -12,7 +12,7 @@
|
||||
|
||||
datarootdir = @datarootdir@
|
||||
@ -83,9 +83,9 @@ diff -Naur bacula-11.0.6.old/src/qt-console/bat.pro.in bacula-11.0.6/src/qt-cons
|
||||
confs.path = /$(DESTDIR)@sysconfdir@
|
||||
confs.commands = ./install_conf_file
|
||||
help.path = /$(DESTDIR)@htmldir@
|
||||
diff -Naur bacula-11.0.6.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-11.0.6/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||
--- bacula-11.0.6.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-03-26 15:50:09.234270267 +0100
|
||||
+++ bacula-11.0.6/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-03-26 15:50:24.807543049 +0100
|
||||
diff -Naur bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||
--- bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:52:53.892141076 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:53:05.565349316 +0200
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-11.0.2.old/src/lib/lib.h bacula-11.0.2/src/lib/lib.h
|
||||
--- bacula-11.0.2.old/src/lib/lib.h 2021-04-16 13:03:57.372394803 +0200
|
||||
+++ bacula-11.0.2/src/lib/lib.h 2021-04-16 13:04:05.322527064 +0200
|
||||
diff -Naur bacula-13.0.0.old/src/lib/lib.h bacula-13.0.0/src/lib/lib.h
|
||||
--- bacula-13.0.0.old/src/lib/lib.h 2022-07-08 14:50:02.281058244 +0200
|
||||
+++ bacula-13.0.0/src/lib/lib.h 2022-07-08 14:52:00.918190647 +0200
|
||||
@@ -57,7 +57,6 @@
|
||||
#include "fnmatch.h"
|
||||
#endif
|
||||
@ -9,9 +9,9 @@ diff -Naur bacula-11.0.2.old/src/lib/lib.h bacula-11.0.2/src/lib/lib.h
|
||||
#include "tree.h"
|
||||
#include "watchdog.h"
|
||||
#include "btimers.h"
|
||||
diff -Naur bacula-11.0.2.old/src/lib/Makefile.in bacula-11.0.2/src/lib/Makefile.in
|
||||
--- bacula-11.0.2.old/src/lib/Makefile.in 2021-04-16 13:03:57.372394803 +0200
|
||||
+++ bacula-11.0.2/src/lib/Makefile.in 2021-04-16 13:04:05.356527630 +0200
|
||||
diff -Naur bacula-13.0.0.old/src/lib/Makefile.in bacula-13.0.0/src/lib/Makefile.in
|
||||
--- bacula-13.0.0.old/src/lib/Makefile.in 2022-07-08 14:50:02.285058315 +0200
|
||||
+++ bacula-13.0.0/src/lib/Makefile.in 2022-07-08 14:52:00.954191295 +0200
|
||||
@@ -40,7 +40,7 @@
|
||||
flist.h fnmatch.h guid_to_name.h htable.h lex.h \
|
||||
lib.h lz4.h md5.h mem_pool.h message.h \
|
||||
@ -30,7 +30,7 @@ diff -Naur bacula-11.0.2.old/src/lib/Makefile.in bacula-11.0.2/src/lib/Makefile.
|
||||
signal.c smartall.c rblist.c tls.c tree.c \
|
||||
util.c var.c watchdog.c workq.c btimers.c \
|
||||
worker.c flist.c bcollector.c collect.c \
|
||||
@@ -286,22 +286,6 @@
|
||||
@@ -299,22 +299,6 @@
|
||||
$(RMF) md5.o
|
||||
$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) md5.c
|
||||
|
||||
@ -52,8 +52,8 @@ diff -Naur bacula-11.0.2.old/src/lib/Makefile.in bacula-11.0.2/src/lib/Makefile.
|
||||
-
|
||||
bsnprintf_test: Makefile libbac.la bsnprintf.c unittests.o
|
||||
$(RMF) bsnprintf.o
|
||||
$(CXX) -DTEST_PROGRAM $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) -Wno-format-truncation bsnprintf.c
|
||||
@@ -397,7 +381,7 @@
|
||||
$(CXX) -DTEST_PROGRAM $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) -Wno-format-truncation bsnprintf.c
|
||||
@@ -411,7 +395,7 @@
|
||||
|
||||
clean: libtool-clean
|
||||
@$(RMF) core a.out *.o *.bak *.tex *.pdf *~ *.intpro *.extpro 1 2 3
|
||||
@ -62,9 +62,9 @@ diff -Naur bacula-11.0.2.old/src/lib/Makefile.in bacula-11.0.2/src/lib/Makefile.
|
||||
|
||||
realclean: clean
|
||||
@$(RMF) tags
|
||||
diff -Naur bacula-11.0.2.old/src/lib/sha1.c bacula-11.0.2/src/lib/sha1.c
|
||||
--- bacula-11.0.2.old/src/lib/sha1.c 2021-04-16 13:03:57.372394803 +0200
|
||||
+++ bacula-11.0.2/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
||||
diff -Naur bacula-13.0.0.old/src/lib/sha1.c bacula-13.0.0/src/lib/sha1.c
|
||||
--- bacula-13.0.0.old/src/lib/sha1.c 2022-07-08 14:50:02.287058351 +0200
|
||||
+++ bacula-13.0.0/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,517 +0,0 @@
|
||||
-/*
|
||||
- * sha1.c
|
||||
@ -583,9 +583,9 @@ diff -Naur bacula-11.0.2.old/src/lib/sha1.c bacula-11.0.2/src/lib/sha1.c
|
||||
- fclose(fd);
|
||||
-}
|
||||
-#endif /* SHA1_SUM */
|
||||
diff -Naur bacula-11.0.2.old/src/lib/sha1.h bacula-11.0.2/src/lib/sha1.h
|
||||
--- bacula-11.0.2.old/src/lib/sha1.h 2021-04-16 13:03:57.373394819 +0200
|
||||
+++ bacula-11.0.2/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
||||
diff -Naur bacula-13.0.0.old/src/lib/sha1.h bacula-13.0.0/src/lib/sha1.h
|
||||
--- bacula-13.0.0.old/src/lib/sha1.h 2022-07-08 14:50:02.248057651 +0200
|
||||
+++ bacula-13.0.0/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,107 +0,0 @@
|
||||
-/*
|
||||
- * sha1.h
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-11.0.0.old/src/lib/message.c bacula-11.0.0/src/lib/message.c
|
||||
--- bacula-11.0.0.old/src/lib/message.c 2021-01-12 12:36:32.630470094 +0100
|
||||
+++ bacula-11.0.0/src/lib/message.c 2021-01-12 12:39:42.477945569 +0100
|
||||
diff -Naur bacula-13.0.0.old/src/lib/message.c bacula-13.0.0/src/lib/message.c
|
||||
--- bacula-13.0.0.old/src/lib/message.c 2022-07-08 14:50:02.247057633 +0200
|
||||
+++ bacula-13.0.0/src/lib/message.c 2022-07-08 14:51:05.527195040 +0200
|
||||
@@ -28,6 +28,7 @@
|
||||
*
|
||||
*/
|
||||
@ -9,7 +9,7 @@ diff -Naur bacula-11.0.0.old/src/lib/message.c bacula-11.0.0/src/lib/message.c
|
||||
#include "bacula.h"
|
||||
#include "jcr.h"
|
||||
|
||||
@@ -1476,7 +1477,8 @@
|
||||
@@ -1480,7 +1481,8 @@
|
||||
|
||||
if (type == M_ABORT) {
|
||||
char *p = 0;
|
||||
|
22
bacula.spec
22
bacula.spec
@ -2,8 +2,8 @@
|
||||
%global username bacula
|
||||
|
||||
Name: bacula
|
||||
Version: 11.0.6
|
||||
Release: 2%{?dist}
|
||||
Version: 13.0.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
License: AGPLv3 with exceptions
|
||||
@ -33,14 +33,13 @@ Patch6: %{name}-desktop.patch
|
||||
Patch7: %{name}-compile-options.patch
|
||||
Patch8: %{name}-install.patch
|
||||
Patch9: %{name}-docker-plugin.patch
|
||||
Patch10: %{name}-build-cdp-plugin.patch
|
||||
Patch11: %{name}-traceback-man.patch
|
||||
Patch10: %{name}-traceback-man.patch
|
||||
# Original patch removed by mistake, upstream is not willing to add it again:
|
||||
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
||||
# Without this, there is no library providing the correct shared object name
|
||||
# required by the daemons.
|
||||
# http://bugs.bacula.org/view.php?id=2084
|
||||
Patch12: %{name}-autoconf.patch
|
||||
Patch11: %{name}-autoconf.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: perl-generators
|
||||
@ -58,6 +57,7 @@ BuildRequires: libcap-devel
|
||||
BuildRequires: lzo-devel
|
||||
BuildRequires: make
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: openldap-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: readline-devel
|
||||
@ -309,8 +309,11 @@ export PATH="$PATH:%{_qt5_bindir}"
|
||||
--enable-batch-insert \
|
||||
--enable-build-dird \
|
||||
--enable-build-stored \
|
||||
--enable-cdp-plugin \
|
||||
--enable-docker-plugin \
|
||||
--enable-includes \
|
||||
--enable-largefile \
|
||||
--enable-ldap-bpam \
|
||||
--enable-readline \
|
||||
--enable-smartalloc \
|
||||
--sysconfdir=%{_sysconfdir}/bacula \
|
||||
@ -319,6 +322,7 @@ export PATH="$PATH:%{_qt5_bindir}"
|
||||
--with-dir-password=@@DIR_PASSWORD@@ \
|
||||
--with-fd-password=@@FD_PASSWORD@@ \
|
||||
--with-hostname=localhost \
|
||||
--with-ldap \
|
||||
--with-logdir=%{_localstatedir}/log/bacula \
|
||||
--with-mon-dir-password=@@MON_DIR_PASSWORD@@ \
|
||||
--with-mon-fd-password=@@MON_FD_PASSWORD@@ \
|
||||
@ -352,7 +356,6 @@ pushd src/qt-console/tray-monitor
|
||||
%make_build
|
||||
popd
|
||||
|
||||
# Convert image to png for tray monitor icon
|
||||
%install
|
||||
%make_install
|
||||
%make_install -C src/tools/cdp-client
|
||||
@ -497,6 +500,7 @@ exit 0
|
||||
%files common
|
||||
%doc README.Redhat quickstart_*
|
||||
%config(noreplace) %{_sysconfdir}/logrotate.d/bacula
|
||||
%dir %{_libdir}/%{name}
|
||||
%dir %{_localstatedir}/log/bacula %attr(750, bacula, bacula)
|
||||
%dir %{_localstatedir}/spool/bacula %attr(750, bacula, bacula)
|
||||
%dir %{_libexecdir}/%{name}
|
||||
@ -513,6 +517,7 @@ exit 0
|
||||
%config(noreplace) %{_sysconfdir}/bacula/bacula-dir.conf %attr(640,root,bacula)
|
||||
%config(noreplace) %{_sysconfdir}/bacula/query.sql %attr(640,root,bacula)
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/bacula-dir
|
||||
%{_libdir}/%{name}/ldap-dir.so
|
||||
%{_libexecdir}/%{name}/baculabackupreport
|
||||
%{_libexecdir}/%{name}/create_bacula_database
|
||||
%{_libexecdir}/%{name}/delete_catalog_backup
|
||||
@ -551,6 +556,7 @@ exit 0
|
||||
%{_sbindir}/bsmtp
|
||||
%{_sbindir}/bwild
|
||||
%{_sbindir}/dbcheck
|
||||
%{_sbindir}/ldaptest
|
||||
%{_unitdir}/bacula-dir.service
|
||||
|
||||
%files logwatch
|
||||
@ -628,6 +634,10 @@ exit 0
|
||||
%{_libdir}/nagios/plugins/check_bacula
|
||||
|
||||
%changelog
|
||||
* Fri Jul 08 2022 Simone Caronni <negativo17@gmail.com> - 13.0.0-1
|
||||
- Update to version 13.0.0.
|
||||
- Enable LDAP integration.
|
||||
|
||||
* Sat Mar 26 2022 Simone Caronni <negativo17@gmail.com> - 11.0.6-2
|
||||
- Update/reorganize patches.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bacula-11.0.6.tar.gz) = 44abc9e3598f3d3beea3e85cca0867e4b9b77c4e7a17cb1902a5e952b049fb2b15f8f6319436fce1dd92ad52d26f04d7225dd052372ecc30aa55fb668a639149
|
||||
SHA512 (bacula-13.0.0.tar.gz) = 4049771f0a0a6c9302d73bd9870c0508d339e919077ac7cfabd4df83a24bb734dcaa8b1c655fb2ad44b04ce616cd566c2ff6dbb7567ae5904efb255ad2b7c0be
|
||||
|
Loading…
Reference in New Issue
Block a user