Bat fix.
This commit is contained in:
parent
111191fc99
commit
eb59c7cc32
@ -1,18 +1,6 @@
|
||||
diff -up bacula-3.0.2/bacula-3.0.2/src/lib/crypto.c.openssl bacula-3.0.2/bacula-3.0.2/src/lib/crypto.c
|
||||
--- bacula-3.0.2/bacula-3.0.2/src/lib/crypto.c.openssl 2008-11-06 20:10:08.000000000 +0100
|
||||
+++ bacula-3.0.2/bacula-3.0.2/src/lib/crypto.c 2009-08-22 12:48:20.000000000 +0200
|
||||
@@ -316,7 +316,11 @@
|
||||
*/
|
||||
static ASN1_OCTET_STRING *openssl_cert_keyid(X509 *cert) {
|
||||
X509_EXTENSION *ext;
|
||||
+#if (OPENSSL_VERSION_NUMBER < 0x10000000L)
|
||||
+ X509V3_EXT_METHOD *method;
|
||||
+#else
|
||||
const X509V3_EXT_METHOD *method;
|
||||
+#endif
|
||||
ASN1_OCTET_STRING *keyid;
|
||||
int i;
|
||||
#if (OPENSSL_VERSION_NUMBER >= 0x0090800FL)
|
||||
@@ -973,6 +977,10 @@ void crypto_sign_free(SIGNATURE *sig)
|
||||
free (sig);
|
||||
}
|
||||
|
15
bacula.spec
15
bacula.spec
@ -8,7 +8,7 @@
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
Name: bacula
|
||||
Version: 5.0.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# See LICENSE for details
|
||||
License: GPLv2 with exceptions
|
||||
Group: System Environment/Daemons
|
||||
@ -470,6 +470,15 @@ pushd bacula-sqlite
|
||||
echo 'depending on your release version you are building on.'
|
||||
exit 1
|
||||
%endif
|
||||
|
||||
#Regen bat qt project file and build
|
||||
pushd src
|
||||
pushd qt-console
|
||||
/usr/bin/qmake-qt4
|
||||
make
|
||||
popd
|
||||
popd
|
||||
|
||||
popd
|
||||
|
||||
# Build MySQL director
|
||||
@ -1012,6 +1021,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 19 2010 Jon Ciesla <limb@jcomserv.net - 5.0.2-2
|
||||
- Corrected bat build, BZ 593149.
|
||||
- Corrected ssl patch.
|
||||
|
||||
* Thu Apr 29 2010 Jon Ciesla <limb@jcomserv.net - 5.0.2-1
|
||||
- New upstream, 5.0.2.
|
||||
- Updated openssl patch.
|
||||
|
Loading…
Reference in New Issue
Block a user