5.0.2. Fixes an sd bug per slankes.
This commit is contained in:
parent
0cbe383288
commit
111191fc99
@ -1,2 +1,2 @@
|
||||
bacula-5.0.1.tar.gz
|
||||
bacula-docs-5.0.1.tar.bz2
|
||||
bacula-5.0.2.tar.gz
|
||||
bacula-docs-5.0.2.tar.bz2
|
||||
|
26
bacula-5.0.2-openssl.patch
Normal file
26
bacula-5.0.2-openssl.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff -up bacula-3.0.2/bacula-3.0.2/src/lib/crypto.c.openssl bacula-3.0.2/bacula-3.0.2/src/lib/crypto.c
|
||||
--- bacula-3.0.2/bacula-3.0.2/src/lib/crypto.c.openssl 2008-11-06 20:10:08.000000000 +0100
|
||||
+++ bacula-3.0.2/bacula-3.0.2/src/lib/crypto.c 2009-08-22 12:48:20.000000000 +0200
|
||||
@@ -316,7 +316,11 @@
|
||||
*/
|
||||
static ASN1_OCTET_STRING *openssl_cert_keyid(X509 *cert) {
|
||||
X509_EXTENSION *ext;
|
||||
+#if (OPENSSL_VERSION_NUMBER < 0x10000000L)
|
||||
+ X509V3_EXT_METHOD *method;
|
||||
+#else
|
||||
const X509V3_EXT_METHOD *method;
|
||||
+#endif
|
||||
ASN1_OCTET_STRING *keyid;
|
||||
int i;
|
||||
#if (OPENSSL_VERSION_NUMBER >= 0x0090800FL)
|
||||
@@ -973,6 +977,10 @@ void crypto_sign_free(SIGNATURE *sig)
|
||||
free (sig);
|
||||
}
|
||||
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||
+#define EVP_PKEY_decrypt EVP_PKEY_decrypt_old
|
||||
+#define EVP_PKEY_encrypt EVP_PKEY_encrypt_old
|
||||
+#endif
|
||||
/*
|
||||
* Create a new encryption session.
|
||||
* Returns: A pointer to a CRYPTO_SESSION object on success.
|
12
bacula.spec
12
bacula.spec
@ -7,7 +7,7 @@
|
||||
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
Name: bacula
|
||||
Version: 5.0.1
|
||||
Version: 5.0.2
|
||||
Release: 1%{?dist}
|
||||
# See LICENSE for details
|
||||
License: GPLv2 with exceptions
|
||||
@ -39,8 +39,9 @@ Patch3: bacula-pamd.patch
|
||||
#Patch10: bacula-web-smarty.patch
|
||||
#Patch11: bacula-2.4.3-orphaned-jobs.patch
|
||||
#Patch12: bacula-2.4.3-python26.patch
|
||||
Patch13: bacula-3.0.2-openssl.patch
|
||||
#Patch13: bacula-3.0.2-openssl.patch
|
||||
Patch14: bacula-5.0.1-dsolink.patch
|
||||
Patch15: bacula-5.0.2-openssl.patch
|
||||
URL: http://www.bacula.org
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: openssl-devel, atk-devel, ncurses-devel, pango-devel, perl
|
||||
@ -367,8 +368,9 @@ pushd bacula-%{version}
|
||||
#%patch9 -p0
|
||||
#%patch11 -p0
|
||||
#%patch12 -p0
|
||||
%patch13 -p2 -b .openssl
|
||||
#%patch13 -p2 -b .openssl
|
||||
%patch14 -p2
|
||||
%patch15 -p2 -b .openssl
|
||||
|
||||
# Remove execution permissions from files we're packaging as docs later on
|
||||
find examples -type f | xargs chmod -x
|
||||
@ -1010,6 +1012,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Apr 29 2010 Jon Ciesla <limb@jcomserv.net - 5.0.2-1
|
||||
- New upstream, 5.0.2.
|
||||
- Updated openssl patch.
|
||||
|
||||
* Thu Feb 25 2010 Jon Ciesla <limb@jcomserv.net - 5.0.1-1
|
||||
- New upstream, 5.0.1.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user