Merge branch 'master' into f17

This commit is contained in:
Simone Caronni 2012-05-28 15:14:00 +02:00
commit 33c6b94bbc
4 changed files with 97 additions and 55 deletions

View File

@ -1,39 +0,0 @@
diff -Naur bacula-5.2.2.old/configure bacula-5.2.2/configure
--- bacula-5.2.2.old/configure 2011-11-26 15:08:12.000000000 +0100
+++ bacula-5.2.2/configure 2011-12-11 18:17:30.530625327 +0100
@@ -30019,15 +30019,6 @@
MACOSX=
COMPRESS_MANPAGES=yes
-hostname=`uname -n | cut -d '.' -f 1`
-if test x${hostname} = x ; then
- hostname="localhost"
-fi
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
-if test ! $? = 0; then
- hostname="localhost"
-fi
-
case "$DISTNAME" in
aix)
DISTVER=`uname -r`
diff -Naur bacula-5.2.2.old/autoconf/configure.in bacula-5.2.2/autoconf/configure.in
--- bacula-5.2.2.old/autoconf/configure.in 2011-12-07 18:19:40.559345035 +0100
+++ bacula-5.2.2/autoconf/configure.in 2011-12-12 10:11:02.783978422 +0100
@@ -2853,16 +2853,6 @@
MACOSX=
COMPRESS_MANPAGES=yes
-hostname=`uname -n | cut -d '.' -f 1`
-if test x${hostname} = x ; then
- hostname="localhost"
-fi
-dnl Make sure hostname is resolved
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
-if test ! $? = 0; then
- hostname="localhost"
-fi
-
case "$DISTNAME" in
aix)
DISTVER=`uname -r`

View File

@ -0,0 +1,62 @@
diff -Naur bacula-5.2.6.old/autoconf/configure.in bacula-5.2.6/autoconf/configure.in
--- bacula-5.2.6.old/autoconf/configure.in 2012-05-24 14:08:57.595272317 +0200
+++ bacula-5.2.6/autoconf/configure.in 2012-05-24 14:11:20.313120159 +0200
@@ -1264,6 +1264,11 @@
if test x${hostname} = x ; then
hostname="localhost"
fi
+dnl Make sure hostname is resolved
+ping -c 1 $hostname 2>/dev/null 1>/dev/null
+if test ! $? = 0; then
+ hostname="localhost"
+fi
AC_ARG_WITH(hostname,
AC_HELP_STRING([--with-hostname=RESNAME], [specify host name for daemons]),
[
@@ -2858,16 +2863,6 @@
MACOSX=
COMPRESS_MANPAGES=yes
-hostname=`uname -n | cut -d '.' -f 1`
-if test x${hostname} = x ; then
- hostname="localhost"
-fi
-dnl Make sure hostname is resolved
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
-if test ! $? = 0; then
- hostname="localhost"
-fi
-
case "$DISTNAME" in
aix)
DISTVER=`uname -r`
diff -Naur bacula-5.2.6.old/configure bacula-5.2.6/configure
--- bacula-5.2.6.old/configure 2012-05-24 14:08:57.834277377 +0200
+++ bacula-5.2.6/configure 2012-05-24 14:12:04.561861019 +0200
@@ -23174,6 +23174,10 @@
if test x${hostname} = x ; then
hostname="localhost"
fi
+ping -c 1 $hostname 2>/dev/null 1>/dev/null
+if test ! $? = 0; then
+ hostname="localhost"
+fi
# Check whether --with-hostname was given.
if test "${with_hostname+set}" = set; then :
@@ -30010,15 +30014,6 @@
MACOSX=
COMPRESS_MANPAGES=yes
-hostname=`uname -n | cut -d '.' -f 1`
-if test x${hostname} = x ; then
- hostname="localhost"
-fi
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
-if test ! $? = 0; then
- hostname="localhost"
-fi
-
case "$DISTNAME" in
aix)
DISTVER=`uname -r`

11
bacula-5.2.6-xattr.patch Normal file
View File

@ -0,0 +1,11 @@
diff -Naur bacula-5.2.6.old/src/filed/xattr.c bacula-5.2.6/src/filed/xattr.c
--- bacula-5.2.6.old/src/filed/xattr.c 2012-05-24 14:16:04.413581814 +0200
+++ bacula-5.2.6/src/filed/xattr.c 2012-05-24 14:18:19.439600409 +0200
@@ -448,6 +448,7 @@
* Each xattr valuepair starts with a magic so we can parse it easier.
*/
current_xattr = (xattr_t *)malloc(sizeof(xattr_t));
+ memset(current_xattr, 0, sizeof(xattr_t));
current_xattr->magic = XATTR_MAGIC;
expected_serialize_len += sizeof(current_xattr->magic);

View File

@ -3,7 +3,7 @@
Name: bacula
Version: 5.2.6
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
# See LICENSE for details
License: AGPLv3 with exceptions
@ -28,7 +28,7 @@ Source17: bacula-sd.sysconfig
Source18: bacula-checkconf
# bugs.bacula.org #1805: hostname is ignored during configure, always picks "uname -n"
Patch1: bacula-5.2.2-hostname.patch
Patch1: bacula-5.2.6-hostname.patch
Patch2: bacula-5.0.2-openssl.patch
Patch3: bacula-5.2.2-queryfile.patch
Patch5: bacula-5.2.4-log-path.patch
@ -37,22 +37,27 @@ Patch6: bacula-5.0.3-sqlite-priv.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=824303
Patch7: bacula-5.2.6-python-detect.patch
Patch8: bacula-5.2.2-qt-console-optflags.patch
# bugs.bacula.org #1874: crash with btrfs backup and xattr
Patch9: bacula-5.2.6-xattr.patch
BuildRequires: desktop-file-utils
BuildRequires: perl
BuildRequires: sed
BuildRequires: perl sed desktop-file-utils
BuildRequires: openssl-devel%{?_isa}
BuildRequires: ncurses-devel%{?_isa}
BuildRequires: glibc-devel%{?_isa}
BuildRequires: libacl-devel%{?_isa}
BuildRequires: libstdc++-devel%{?_isa}
BuildRequires: libxml2-devel%{?_isa}
BuildRequires: zlib-devel%{?_isa}
BuildRequires: mysql-devel%{?_isa}
BuildRequires: postgresql-devel%{?_isa}
BuildRequires: sqlite-devel%{?_isa}
BuildRequires: python-devel%{?_isa}
BuildRequires: libacl-devel%{?_isa}
BuildRequires: readline-devel%{?_isa}
BuildRequires: libcap-devel%{?_isa}
BuildRequires: lzo-devel%{?_isa}
BuildRequires: mysql-devel%{?_isa}
BuildRequires: ncurses-devel%{?_isa}
BuildRequires: openssl-devel%{?_isa}
BuildRequires: postgresql-devel%{?_isa}
BuildRequires: python-devel%{?_isa}
BuildRequires: readline-devel%{?_isa}
BuildRequires: sqlite-devel%{?_isa}
BuildRequires: zlib-devel%{?_isa}
%if 0%{?fedora} >= 12 || 0%{?rhel} >= 6
BuildRequires: qt4-devel%{?_isa} >= 4.6.2
@ -64,9 +69,6 @@ BuildRequires: tcp_wrappers-devel%{?_isa}
BuildRequires: tcp_wrappers%{?_isa}
%endif
%if 0%{?fedora} >= 15 || 0%{?rhel} > 6
BuildRequires: systemd-units
%endif
%description
Bacula is a set of programs that allow you to manage the backup,
@ -294,6 +296,7 @@ Provides check_bacula support for Nagios.
%patch6 -p0 -b .priv
%patch7 -p1 -b .python-detect
%patch8 -p1 -b .optflags
%patch9 -p1 -b .xattr
# Remove execution permissions from files we're packaging as docs later on
find updatedb -type f | xargs chmod -x
@ -833,7 +836,12 @@ fi
%changelog
* Wed May 22 2012 Simone Caronni <negativo17@gmail.com> - 5.2.6-4
* Mon May 28 2012 Simone Caronni <negativo17@gmail.com> - 5.2.6-5
- Patch for bug #819158.
- Updated hostname patch with official fix.
- Sorted all BuildRequires and removed useless systemd-units.
* Wed May 23 2012 Simone Caronni <negativo17@gmail.com> - 5.2.6-4
- Added python config workaround for Fedora 16.
* Mon May 21 2012 Simone Caronni <negativo17@gmail.com> - 5.2.6-3