bacula/bacula-5.2.6-hostname.patch
2012-05-28 15:13:46 +02:00

63 lines
1.6 KiB
Diff

diff -Naur bacula-5.2.6.old/autoconf/configure.in bacula-5.2.6/autoconf/configure.in
--- bacula-5.2.6.old/autoconf/configure.in 2012-05-24 14:08:57.595272317 +0200
+++ bacula-5.2.6/autoconf/configure.in 2012-05-24 14:11:20.313120159 +0200
@@ -1264,6 +1264,11 @@
if test x${hostname} = x ; then
hostname="localhost"
fi
+dnl Make sure hostname is resolved
+ping -c 1 $hostname 2>/dev/null 1>/dev/null
+if test ! $? = 0; then
+ hostname="localhost"
+fi
AC_ARG_WITH(hostname,
AC_HELP_STRING([--with-hostname=RESNAME], [specify host name for daemons]),
[
@@ -2858,16 +2863,6 @@
MACOSX=
COMPRESS_MANPAGES=yes
-hostname=`uname -n | cut -d '.' -f 1`
-if test x${hostname} = x ; then
- hostname="localhost"
-fi
-dnl Make sure hostname is resolved
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
-if test ! $? = 0; then
- hostname="localhost"
-fi
-
case "$DISTNAME" in
aix)
DISTVER=`uname -r`
diff -Naur bacula-5.2.6.old/configure bacula-5.2.6/configure
--- bacula-5.2.6.old/configure 2012-05-24 14:08:57.834277377 +0200
+++ bacula-5.2.6/configure 2012-05-24 14:12:04.561861019 +0200
@@ -23174,6 +23174,10 @@
if test x${hostname} = x ; then
hostname="localhost"
fi
+ping -c 1 $hostname 2>/dev/null 1>/dev/null
+if test ! $? = 0; then
+ hostname="localhost"
+fi
# Check whether --with-hostname was given.
if test "${with_hostname+set}" = set; then :
@@ -30010,15 +30014,6 @@
MACOSX=
COMPRESS_MANPAGES=yes
-hostname=`uname -n | cut -d '.' -f 1`
-if test x${hostname} = x ; then
- hostname="localhost"
-fi
-ping -c 1 $hostname 2>/dev/null 1>/dev/null
-if test ! $? = 0; then
- hostname="localhost"
-fi
-
case "$DISTNAME" in
aix)
DISTVER=`uname -r`