53 lines
1.7 KiB
Diff
53 lines
1.7 KiB
Diff
From 8070ec2ac51219c462ac05238eab239461c38454 Mon Sep 17 00:00:00 2001
|
|
From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
|
|
Date: Thu, 7 Jun 2012 16:51:10 +0200
|
|
Subject: [PATCH 4/8] build-sys: fix MKDIR_P for recent automake
|
|
|
|
---
|
|
avahi-autoipd/Makefile.am | 2 +-
|
|
avahi-daemon/Makefile.am | 2 +-
|
|
configure.ac | 1 +
|
|
3 files changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/avahi-autoipd/Makefile.am b/avahi-autoipd/Makefile.am
|
|
index 263e991..56f7a35 100644
|
|
--- a/avahi-autoipd/Makefile.am
|
|
+++ b/avahi-autoipd/Makefile.am
|
|
@@ -76,7 +76,7 @@ dhcliententerdir = $(sysconfdir)/dhcp/dhclient-enter-hooks.d
|
|
dhclientexitdir = $(sysconfdir)/dhcp/dhclient-exit-hooks.d
|
|
|
|
install-exec-hook: dhclient-exit-hook dhclient-enter-hook
|
|
- $(mkdir_p) $(DESTDIR)$(dhcliententerdir) $(DESTDIR)$(dhclientexitdir)
|
|
+ $(MKDIR_P) $(DESTDIR)$(dhcliententerdir) $(DESTDIR)$(dhclientexitdir)
|
|
$(INSTALL) dhclient-enter-hook $(DESTDIR)$(dhcliententerdir)/avahi-autoipd
|
|
$(INSTALL) dhclient-exit-hook $(DESTDIR)$(dhclientexitdir)/avahi-autoipd
|
|
|
|
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
|
|
index b5d2bf4..b6b5a77 100644
|
|
--- a/avahi-daemon/Makefile.am
|
|
+++ b/avahi-daemon/Makefile.am
|
|
@@ -169,7 +169,7 @@ xmllint:
|
|
done
|
|
|
|
install-data-local:
|
|
- test -z "$(localstatedir)/run" || $(mkdir_p) "$(DESTDIR)$(localstatedir)/run"
|
|
+ test -z "$(localstatedir)/run" || $(MKDIR_P) "$(DESTDIR)$(localstatedir)/run"
|
|
|
|
update-systemd:
|
|
curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.c > sd-daemon.c
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 0e190ba..9debce2 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -59,6 +59,7 @@ AC_PROG_CXX
|
|
AM_PROG_CC_C_O
|
|
AC_USE_SYSTEM_EXTENSIONS
|
|
AC_PROG_CPP
|
|
+AC_PROG_MKDIR_P
|
|
AC_PROG_INSTALL
|
|
AC_PROG_LN_S
|
|
AC_PROG_MAKE_SET
|
|
--
|
|
1.9.3
|
|
|