pull in post 0.6.31 upstream fixes, python related packaging polish

This commit is contained in:
Rex Dieter 2015-09-17 10:36:43 -05:00
parent 5536a8639f
commit f5488f8a48
9 changed files with 826 additions and 24 deletions

View File

@ -0,0 +1,26 @@
From 938b5f883fbaa642e3acb7720e37f95f3d72be62 Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Mon, 2 Apr 2012 21:17:19 +0200
Subject: [PATCH 1/8] avahi-daemon: don't add 0pointer.de and zeroconf.org to
default browse list
---
avahi-daemon/avahi-daemon.conf | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/avahi-daemon/avahi-daemon.conf b/avahi-daemon/avahi-daemon.conf
index c992842..1906590 100644
--- a/avahi-daemon/avahi-daemon.conf
+++ b/avahi-daemon/avahi-daemon.conf
@@ -21,7 +21,7 @@
[server]
#host-name=foo
#domain-name=local
-browse-domains=0pointer.de, zeroconf.org
+#browse-domains=0pointer.de, zeroconf.org
use-ipv4=yes
use-ipv6=no
#allow-interfaces=eth0
--
1.9.3

View File

@ -0,0 +1,27 @@
From 530fbb59abafb970ef1dd8f61571b13fb0918b23 Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Mon, 2 Apr 2012 21:17:36 +0200
Subject: [PATCH 2/8] avahi-daemon: don't leak host info by default
---
avahi-daemon/avahi-daemon.conf | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/avahi-daemon/avahi-daemon.conf b/avahi-daemon/avahi-daemon.conf
index 1906590..27e240d 100644
--- a/avahi-daemon/avahi-daemon.conf
+++ b/avahi-daemon/avahi-daemon.conf
@@ -46,8 +46,8 @@ enable-wide-area=yes
#disable-user-service-publishing=no
#add-service-cookie=no
#publish-addresses=yes
-#publish-hinfo=yes
-#publish-workstation=yes
+publish-hinfo=no
+publish-workstation=no
#publish-domain=yes
#publish-dns-servers=192.168.50.1, 192.168.50.2
#publish-resolv-conf-dns-servers=yes
--
1.9.3

View File

@ -0,0 +1,52 @@
From 468519681b09f00851e1d4dd658b939e4e938cf6 Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Mon, 2 Apr 2012 21:20:34 +0200
Subject: [PATCH 3/8] core: don't leak hinfo/workstation even if the
configuration file doesn't exist
---
avahi-core/server.c | 4 ++--
man/avahi-daemon.conf.5.xml.in | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/avahi-core/server.c b/avahi-core/server.c
index 86fd4a5..69a1d02 100644
--- a/avahi-core/server.c
+++ b/avahi-core/server.c
@@ -1582,9 +1582,9 @@ AvahiServerConfig* avahi_server_config_init(AvahiServerConfig *c) {
c->host_name = NULL;
c->domain_name = NULL;
c->check_response_ttl = 0;
- c->publish_hinfo = 1;
+ c->publish_hinfo = 0;
c->publish_addresses = 1;
- c->publish_workstation = 1;
+ c->publish_workstation = 0;
c->publish_domain = 1;
c->use_iff_running = 0;
c->enable_reflector = 0;
diff --git a/man/avahi-daemon.conf.5.xml.in b/man/avahi-daemon.conf.5.xml.in
index 487645b..bea7ed5 100644
--- a/man/avahi-daemon.conf.5.xml.in
+++ b/man/avahi-daemon.conf.5.xml.in
@@ -244,7 +244,7 @@
useful for administrative purposes. This is recommended by the
mDNS specification but not required. For the sake of privacy
you might choose to disable this feature. Defaults to
- "yes."</p>
+ "no".</p>
</option>
<option>
@@ -254,7 +254,7 @@
might be useful for administrative purposes (i.e. browse for
all PCs on the LAN), but is not required or recommended by any
specification. Newer MacOS X releases register a service of
- this type. Defaults to "yes".</p>
+ this type. Defaults to "no".</p>
</option>
<option>
--
1.9.3

View File

@ -0,0 +1,52 @@
From 8070ec2ac51219c462ac05238eab239461c38454 Mon Sep 17 00:00:00 2001
From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Date: Thu, 7 Jun 2012 16:51:10 +0200
Subject: [PATCH 4/8] build-sys: fix MKDIR_P for recent automake
---
avahi-autoipd/Makefile.am | 2 +-
avahi-daemon/Makefile.am | 2 +-
configure.ac | 1 +
3 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/avahi-autoipd/Makefile.am b/avahi-autoipd/Makefile.am
index 263e991..56f7a35 100644
--- a/avahi-autoipd/Makefile.am
+++ b/avahi-autoipd/Makefile.am
@@ -76,7 +76,7 @@ dhcliententerdir = $(sysconfdir)/dhcp/dhclient-enter-hooks.d
dhclientexitdir = $(sysconfdir)/dhcp/dhclient-exit-hooks.d
install-exec-hook: dhclient-exit-hook dhclient-enter-hook
- $(mkdir_p) $(DESTDIR)$(dhcliententerdir) $(DESTDIR)$(dhclientexitdir)
+ $(MKDIR_P) $(DESTDIR)$(dhcliententerdir) $(DESTDIR)$(dhclientexitdir)
$(INSTALL) dhclient-enter-hook $(DESTDIR)$(dhcliententerdir)/avahi-autoipd
$(INSTALL) dhclient-exit-hook $(DESTDIR)$(dhclientexitdir)/avahi-autoipd
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index b5d2bf4..b6b5a77 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -169,7 +169,7 @@ xmllint:
done
install-data-local:
- test -z "$(localstatedir)/run" || $(mkdir_p) "$(DESTDIR)$(localstatedir)/run"
+ test -z "$(localstatedir)/run" || $(MKDIR_P) "$(DESTDIR)$(localstatedir)/run"
update-systemd:
curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.c > sd-daemon.c
diff --git a/configure.ac b/configure.ac
index 0e190ba..9debce2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,7 @@ AC_PROG_CXX
AM_PROG_CC_C_O
AC_USE_SYSTEM_EXTENSIONS
AC_PROG_CPP
+AC_PROG_MKDIR_P
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
--
1.9.3

View File

@ -0,0 +1,29 @@
From a485019966c32af05fb294fb4e20f1d3a82f3fbe Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@flameeyes.eu>
Date: Sun, 17 Jun 2012 07:44:01 -0700
Subject: [PATCH 5/8] build-sys: fix parallel install in avahi-utils
The moment install-exec-local is called, we might still not have
created ${DESTDIR}/${bindir} so we should make sure to create it
first, and then try to chdir into it.
---
avahi-utils/Makefile.am | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/avahi-utils/Makefile.am b/avahi-utils/Makefile.am
index a644b4a..1abc79a 100644
--- a/avahi-utils/Makefile.am
+++ b/avahi-utils/Makefile.am
@@ -54,7 +54,8 @@ avahi_set_host_name_CFLAGS = $(AM_CFLAGS)
avahi_set_host_name_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
install-exec-local:
- cd $(DESTDIR)/$(bindir) && \
+ $(mkdir_p) $(DESTDIR)/$(bindir) && \
+ cd $(DESTDIR)/$(bindir) && \
rm -f avahi-resolve-host-name avahi-resolve-address avahi-browse-domains avahi-publish-address avahi-publish-service && \
$(LN_S) avahi-resolve avahi-resolve-host-name && \
$(LN_S) avahi-resolve avahi-resolve-address && \
--
1.9.3

View File

@ -0,0 +1,25 @@
From 35ea8dc8954eebd63aad7157d02f97388f679122 Mon Sep 17 00:00:00 2001
From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Date: Tue, 19 Jun 2012 15:50:35 +0200
Subject: [PATCH 6/8] build-sys: fix previous commit for recent automake
---
avahi-utils/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/avahi-utils/Makefile.am b/avahi-utils/Makefile.am
index 1abc79a..66c4cc6 100644
--- a/avahi-utils/Makefile.am
+++ b/avahi-utils/Makefile.am
@@ -54,7 +54,7 @@ avahi_set_host_name_CFLAGS = $(AM_CFLAGS)
avahi_set_host_name_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
install-exec-local:
- $(mkdir_p) $(DESTDIR)/$(bindir) && \
+ $(MKDIR_P) $(DESTDIR)/$(bindir) && \
cd $(DESTDIR)/$(bindir) && \
rm -f avahi-resolve-host-name avahi-resolve-address avahi-browse-domains avahi-publish-address avahi-publish-service && \
$(LN_S) avahi-resolve avahi-resolve-host-name && \
--
1.9.3

View File

@ -0,0 +1,477 @@
From ccfcd5c42c68752fbd6de318fe5ce4269f5a7c06 Mon Sep 17 00:00:00 2001
From: Lennart Poettering <lennart@poettering.net>
Date: Fri, 7 Sep 2012 16:17:43 +0200
Subject: [PATCH 7/8] avahi-common: typo fix
---
avahi-common/error.c | 2 +-
avahi-common/error.h | 2 +-
po/bg.po | 2 +-
po/ca.po | 2 +-
po/cs.po | 2 +-
po/da.po | 2 +-
po/de.po | 2 +-
po/el.po | 2 +-
po/en_AU.po | 2 +-
po/en_CA.po | 2 +-
po/en_GB.po | 2 +-
po/en_NZ.po | 859 ++++++++++++++++++++++++++++++++++++++++++++++++++-
po/es.po | 2 +-
po/fi.po | 2 +-
po/fo.po | 2 +-
po/fr.po | 2 +-
po/gl.po | 2 +-
po/he.po | 2 +-
po/hu.po | 2 +-
po/id.po | 2 +-
po/it.po | 2 +-
po/ja.po | 2 +-
po/ms.po | 2 +-
po/nl.po | 2 +-
po/pl.po | 2 +-
po/pt_BR.po | 2 +-
po/ro.po | 2 +-
po/ru.po | 2 +-
po/sl.po | 2 +-
po/sl.si | 2 +-
po/sr.po | 2 +-
po/sr@latin.po | 2 +-
po/sv.po | 2 +-
po/uk.po | 2 +-
po/zh_CN.po | 2 +-
po/zh_TW.po | 2 +-
36 files changed, 893 insertions(+), 36 deletions(-)
mode change 120000 => 100644 po/en_NZ.po
diff --git a/avahi-common/error.c b/avahi-common/error.c
index b0b66ea..63c5033 100644
--- a/avahi-common/error.c
+++ b/avahi-common/error.c
@@ -51,7 +51,7 @@ const char *avahi_strerror(int error) {
N_("Access denied"),
N_("Invalid operation"),
- N_("An unexpected D-Bus error occured"),
+ N_("An unexpected D-Bus error occurred"),
N_("Daemon connection failed"),
N_("Memory exhausted"),
N_("The object passed in was not valid"),
diff --git a/avahi-common/error.h b/avahi-common/error.h
index 392aaf5..94511c9 100644
--- a/avahi-common/error.h
+++ b/avahi-common/error.h
@@ -52,7 +52,7 @@ enum {
AVAHI_ERR_ACCESS_DENIED = -20, /**< Access denied */
AVAHI_ERR_INVALID_OPERATION = -21, /**< Invalid operation */
- AVAHI_ERR_DBUS_ERROR = -22, /**< An unexpected D-Bus error occured */
+ AVAHI_ERR_DBUS_ERROR = -22, /**< An unexpected D-Bus error occurred */
AVAHI_ERR_DISCONNECTED = -23, /**< Daemon connection failed */
AVAHI_ERR_NO_MEMORY = -24, /**< Memory exhausted */
AVAHI_ERR_INVALID_OBJECT = -25, /**< The object passed to this function was invalid */
diff --git a/po/bg.po b/po/bg.po
index c20eb6d..f59d43a 100644
--- a/po/bg.po
+++ b/po/bg.po
@@ -106,7 +106,7 @@ msgid "Invalid operation"
msgstr "Неправилна операция"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Неочаквана грешка от D-Bus"
#: ../avahi-common/error.c:55
diff --git a/po/ca.po b/po/ca.po
index 0985254..d3cff9c 100644
--- a/po/ca.po
+++ b/po/ca.po
@@ -118,7 +118,7 @@ msgid "Invalid operation"
msgstr "Operació no vàlida"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "S'ha produït un error inesperat al D-Bus"
#: ../avahi-common/error.c:55
diff --git a/po/cs.po b/po/cs.po
index c6c8e85..349bfbe 100644
--- a/po/cs.po
+++ b/po/cs.po
@@ -111,7 +111,7 @@ msgstr "Neplatná operace"
#: ../avahi-common/error.c:54
#, fuzzy
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Došlo k následující chybě:"
#: ../avahi-common/error.c:55
diff --git a/po/da.po b/po/da.po
index 9984965..0b231cb 100644
--- a/po/da.po
+++ b/po/da.po
@@ -115,7 +115,7 @@ msgid "Invalid operation"
msgstr "Ugyldig handling"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Der opstod en uventet D-Bus-fejl"
#: ../avahi-common/error.c:55
diff --git a/po/de.po b/po/de.po
index e4ee917..5b0a017 100644
--- a/po/de.po
+++ b/po/de.po
@@ -108,7 +108,7 @@ msgid "Invalid operation"
msgstr "Ungültige Operation"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Ein unerwarteter DBus-Fehler ist aufgetreten"
#: ../avahi-common/error.c:55
diff --git a/po/el.po b/po/el.po
index 2f095ee..53c53fb 100644
--- a/po/el.po
+++ b/po/el.po
@@ -107,7 +107,7 @@ msgid "Invalid operation"
msgstr "Λανθασμένη λειτουργία"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr ""
#: ../avahi-common/error.c:55
diff --git a/po/en_AU.po b/po/en_AU.po
index e510292..5e8918d 100644
--- a/po/en_AU.po
+++ b/po/en_AU.po
@@ -102,7 +102,7 @@ msgid "Invalid operation"
msgstr ""
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr ""
#: ../avahi-common/error.c:55
diff --git a/po/en_CA.po b/po/en_CA.po
index 2d70852..3c28764 100644
--- a/po/en_CA.po
+++ b/po/en_CA.po
@@ -102,7 +102,7 @@ msgid "Invalid operation"
msgstr ""
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr ""
#: ../avahi-common/error.c:55
diff --git a/po/en_GB.po b/po/en_GB.po
index 4f5b849..aab6526 100644
--- a/po/en_GB.po
+++ b/po/en_GB.po
@@ -105,7 +105,7 @@ msgid "Invalid operation"
msgstr "Invalid operation"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "An unexpected D-Bus error occurred"
#: ../avahi-common/error.c:55
diff --git a/po/es.po b/po/es.po
index 4d4fef7..56974da 100644
--- a/po/es.po
+++ b/po/es.po
@@ -112,7 +112,7 @@ msgid "Invalid operation"
msgstr "Operación no válida"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Ocurrió un error de D-Bus no esperado"
#: ../avahi-common/error.c:55
diff --git a/po/fi.po b/po/fi.po
index cbd0883..d37ec3a 100644
--- a/po/fi.po
+++ b/po/fi.po
@@ -107,7 +107,7 @@ msgid "Invalid operation"
msgstr "Virheellinen toiminto"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Tapahtui odottamaton D-Bus-virhe"
#: ../avahi-common/error.c:55
diff --git a/po/fo.po b/po/fo.po
index ff470a2..8b122af 100644
--- a/po/fo.po
+++ b/po/fo.po
@@ -107,7 +107,7 @@ msgid "Invalid operation"
msgstr "Ógildug atgerð"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Ein óvantað D-BUS villa hendi"
#: ../avahi-common/error.c:55
diff --git a/po/fr.po b/po/fr.po
index 144756a..59143da 100644
--- a/po/fr.po
+++ b/po/fr.po
@@ -111,7 +111,7 @@ msgid "Invalid operation"
msgstr "Opération invalide "
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Une erreur inattendue de D-Bus s'est produite"
#: ../avahi-common/error.c:55
diff --git a/po/gl.po b/po/gl.po
index f1da293..46f8a8f 100644
--- a/po/gl.po
+++ b/po/gl.po
@@ -107,7 +107,7 @@ msgid "Invalid operation"
msgstr "Operación incorrecta"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Produciuse un erro inesperado de D-BUS"
#: ../avahi-common/error.c:55
diff --git a/po/he.po b/po/he.po
index 6f4070b..f5a50c7 100644
--- a/po/he.po
+++ b/po/he.po
@@ -107,7 +107,7 @@ msgid "Invalid operation"
msgstr "פעולה שגויה"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "ארעה שגיאת D-Bus לא ידועה"
#: ../avahi-common/error.c:55
diff --git a/po/hu.po b/po/hu.po
index 138875e..800b90e 100644
--- a/po/hu.po
+++ b/po/hu.po
@@ -107,7 +107,7 @@ msgid "Invalid operation"
msgstr "Érvénytelen művelet"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Váratlan D-Bus hiba történt"
#: ../avahi-common/error.c:55
diff --git a/po/id.po b/po/id.po
index 1d56baa..453086a 100644
--- a/po/id.po
+++ b/po/id.po
@@ -108,7 +108,7 @@ msgid "Invalid operation"
msgstr "Operasi tidak valid"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Terjadi galat D-Bus yang tak diharapkan"
#: ../avahi-common/error.c:55
diff --git a/po/it.po b/po/it.po
index fbb51c1..1448cd3 100644
--- a/po/it.po
+++ b/po/it.po
@@ -114,7 +114,7 @@ msgid "Invalid operation"
msgstr "Operazione non valida"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Si è verificato un errore D-Bus inatteso"
#: ../avahi-common/error.c:55
diff --git a/po/ja.po b/po/ja.po
index 7f76ff6..ec3a05c 100644
--- a/po/ja.po
+++ b/po/ja.po
@@ -106,7 +106,7 @@ msgid "Invalid operation"
msgstr "不正な操作です"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "予期しない D-Bus のエラーが発生しました"
#: ../avahi-common/error.c:55
diff --git a/po/ms.po b/po/ms.po
index e9267f2..58db564 100644
--- a/po/ms.po
+++ b/po/ms.po
@@ -121,7 +121,7 @@ msgstr "Tanda operasi:"
#: ../avahi-common/error.c:54
#, fuzzy
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr ""
"Ralat tidak dijangka telah berlaku:\n"
"%s"
diff --git a/po/nl.po b/po/nl.po
index aeb7c91..f287d38 100644
--- a/po/nl.po
+++ b/po/nl.po
@@ -107,7 +107,7 @@ msgid "Invalid operation"
msgstr ""
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr ""
#: ../avahi-common/error.c:55
diff --git a/po/pl.po b/po/pl.po
index 6328939..a0b2f10 100644
--- a/po/pl.po
+++ b/po/pl.po
@@ -103,7 +103,7 @@ msgid "Invalid operation"
msgstr "Nieprawidłowe działanie"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Wystąpił nieoczekiwany błąd usługi D-Bus"
#: ../avahi-common/error.c:55
diff --git a/po/pt_BR.po b/po/pt_BR.po
index 2a38d19..bde3e62 100644
--- a/po/pt_BR.po
+++ b/po/pt_BR.po
@@ -110,7 +110,7 @@ msgid "Invalid operation"
msgstr "Operação inválida"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Ocorreu um erro inesperado do D-BUS"
#: ../avahi-common/error.c:55
diff --git a/po/ro.po b/po/ro.po
index 662fa8f..e270063 100644
--- a/po/ro.po
+++ b/po/ro.po
@@ -102,7 +102,7 @@ msgid "Invalid operation"
msgstr "Operație nevalidă"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "S-a produs o eroare D-Bus"
#: ../avahi-common/error.c:55
diff --git a/po/ru.po b/po/ru.po
index 00e8013..675a1d8 100644
--- a/po/ru.po
+++ b/po/ru.po
@@ -110,7 +110,7 @@ msgid "Invalid operation"
msgstr "Неверная операция"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Неожиданная ошибка D-Bus"
#: ../avahi-common/error.c:55
diff --git a/po/sl.po b/po/sl.po
index e9fed56..ab8e663 100644
--- a/po/sl.po
+++ b/po/sl.po
@@ -113,7 +113,7 @@ msgid "Invalid operation"
msgstr "Neveljavno dejanje"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Prišlo je do nepričakovane napake vodila D-Bus."
#: ../avahi-common/error.c:55
diff --git a/po/sr@latin.po b/po/sr@latin.po
index 137c73c..be1779c 100644
--- a/po/sr@latin.po
+++ b/po/sr@latin.po
@@ -109,7 +109,7 @@ msgid "Invalid operation"
msgstr "Netačna operacija"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Desila se neočekivana greška u D-Bus softveru"
#: ../avahi-common/error.c:55
diff --git a/po/sv.po b/po/sv.po
index 25abde7..74f9d87 100644
--- a/po/sv.po
+++ b/po/sv.po
@@ -105,7 +105,7 @@ msgid "Invalid operation"
msgstr "Ogiltig åtgärd"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Ett oväntat D-Bus-fel har inträffat"
#: ../avahi-common/error.c:55
diff --git a/po/uk.po b/po/uk.po
index f58c875..76f57fe 100644
--- a/po/uk.po
+++ b/po/uk.po
@@ -107,7 +107,7 @@ msgid "Invalid operation"
msgstr "Некоректна дія"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "Сталася непередбачена помилка D-Bus"
#: ../avahi-common/error.c:55
diff --git a/po/zh_CN.po b/po/zh_CN.po
index d217f7e..de850fa 100644
--- a/po/zh_CN.po
+++ b/po/zh_CN.po
@@ -106,7 +106,7 @@ msgid "Invalid operation"
msgstr "无效的操作"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "发生了一个未预期的 D-Bus 错误"
#: ../avahi-common/error.c:55
diff --git a/po/zh_TW.po b/po/zh_TW.po
index 56ddd8e..696173b 100644
--- a/po/zh_TW.po
+++ b/po/zh_TW.po
@@ -105,7 +105,7 @@ msgid "Invalid operation"
msgstr "無效的操作"
#: ../avahi-common/error.c:54
-msgid "An unexpected D-Bus error occured"
+msgid "An unexpected D-Bus error occurred"
msgstr "遭遇到未預期的 D-Bus 錯誤"
#: ../avahi-common/error.c:55
--
1.9.3

View File

@ -0,0 +1,89 @@
From 147cdce70b22ae7cee9fb4fe123db40952f31c9e Mon Sep 17 00:00:00 2001
From: David Zeuthen <zeuthen@chromium.org>
Date: Tue, 5 Mar 2013 11:52:38 -0800
Subject: [PATCH 8/8] avahi-daemon: add option "host-name-from-machine-id="
Signed-off-by: David Zeuthen <zeuthen@chromium.org>
---
avahi-daemon/main.c | 33 +++++++++++++++++++++++++++++++++
man/avahi-daemon.conf.5.xml.in | 6 ++++++
2 files changed, 39 insertions(+)
diff --git a/avahi-daemon/main.c b/avahi-daemon/main.c
index d46f40a..8c28fd6 100644
--- a/avahi-daemon/main.c
+++ b/avahi-daemon/main.c
@@ -65,6 +65,7 @@
#include <avahi-core/publish.h>
#include <avahi-core/dns-srv-rr.h>
#include <avahi-core/log.h>
+#include <avahi-core/util.h>
#ifdef ENABLE_CHROOT
#include "chroot.h"
@@ -576,6 +577,29 @@ static int parse_usec(const char *s, AvahiUsec *u) {
return 0;
}
+static char *get_machine_id(void) {
+ int fd;
+ char buf[32];
+
+ fd = open("/etc/machine-id", O_RDONLY|O_CLOEXEC|O_NOCTTY);
+ if (fd == -1 && errno == ENOENT)
+ fd = open("/var/lib/dbus/machine-id", O_RDONLY|O_CLOEXEC|O_NOCTTY);
+ if (fd == -1)
+ return NULL;
+
+ /* File is on a filesystem so we never get EINTR or partial reads */
+ if (read(fd, buf, sizeof buf) != sizeof buf) {
+ close(fd);
+ return NULL;
+ }
+ close(fd);
+
+ /* Contents can be lower, upper and even mixed case so normalize */
+ avahi_strdown(buf);
+
+ return avahi_strndup(buf, sizeof buf);
+}
+
static int load_config_file(DaemonConfig *c) {
int r = -1;
AvahiIniFile *f;
@@ -631,6 +655,15 @@ static int load_config_file(DaemonConfig *c) {
c->server_config.use_iff_running = is_yes(p->value);
else if (strcasecmp(p->key, "disallow-other-stacks") == 0)
c->server_config.disallow_other_stacks = is_yes(p->value);
+ else if (strcasecmp(p->key, "host-name-from-machine-id") == 0) {
+ if (*(p->value) == 'y' || *(p->value) == 'Y') {
+ char *machine_id = get_machine_id();
+ if (machine_id != NULL) {
+ avahi_free(c->server_config.host_name);
+ c->server_config.host_name = machine_id;
+ }
+ }
+ }
#ifdef HAVE_DBUS
else if (strcasecmp(p->key, "enable-dbus") == 0) {
diff --git a/man/avahi-daemon.conf.5.xml.in b/man/avahi-daemon.conf.5.xml.in
index bea7ed5..2d15017 100644
--- a/man/avahi-daemon.conf.5.xml.in
+++ b/man/avahi-daemon.conf.5.xml.in
@@ -40,6 +40,12 @@
</option>
<option>
+ <p><opt>host-name-from-machine-id=</opt> Takes a boolean
+ value ("yes" or "no"). If set to "yes" avahi-daemon
+ will use the machine-id as name on the LAN.</p>
+ </option>
+
+ <option>
<p><opt>domain-name=</opt> Set the default domain name avahi-daemon
tries to register its host name and services on the LAN in. If
omitted defaults to ".local".</p>
--
1.9.3

View File

@ -18,7 +18,7 @@
Name: avahi
Version: 0.6.31
Release: 37%{?dist}
Release: 38%{?dist}
Summary: Local network service discovery
License: LGPLv2+
URL: http://avahi.org
@ -50,7 +50,8 @@ BuildRequires: libdaemon-devel >= 0.11
BuildRequires: glib2-devel
BuildRequires: libcap-devel
BuildRequires: expat-devel
BuildRequires: python
BuildRequires: python2-devel
BuildRequires: python3-devel
BuildRequires: gdbm-devel
BuildRequires: pygtk2
BuildRequires: intltool
@ -67,18 +68,28 @@ Requires(postun): systemd
Requires(post): systemd-sysv
Source0: http://avahi.org/download/%{name}-%{version}.tar.gz
Patch0: avahi-0.6.30-mono-libdir.patch
## upstream patches
Patch1: 0001-avahi-daemon-don-t-add-0pointer.de-and-zeroconf.org-.patch
Patch2: 0002-avahi-daemon-don-t-leak-host-info-by-default.patch
Patch3: 0003-core-don-t-leak-hinfo-workstation-even-if-the-config.patch
Patch4: 0004-build-sys-fix-MKDIR_P-for-recent-automake.patch
Patch5: 0005-build-sys-fix-parallel-install-in-avahi-utils.patch
Patch6: 0006-build-sys-fix-previous-commit-for-recent-automake.patch
# munged a bit to make it apply against tarball
Patch7: 0007-avahi-common-typo-fix.patch
Patch8: 0008-avahi-daemon-add-option-host-name-from-machine-id.patch
Patch100: avahi-0.6.30-mono-libdir.patch
# Disable -Werror and remove G*_DISABLE_DEPRECATED definitions
Patch1: avahi-0.6.31-no-deprecations.patch
Patch101: avahi-0.6.31-no-deprecations.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1105647
Patch2: 0001-Disable-publish-workstation-and-publish-hinfo-by-def.patch
Patch3: 0001-netlink-check-that-the-origin-of-the-rtnetlink-messa.patch
Patch103: 0001-netlink-check-that-the-origin-of-the-rtnetlink-messa.patch
Patch4: 0001-Python3-support.patch
Patch104: 0001-Python3-support.patch
Patch5: avahi-0.6.31-reserve-space-for-record-data-when-size-estimate.patch
Patch105: avahi-0.6.31-reserve-space-for-record-data-when-size-estimate.patch
%description
Avahi is a system which facilitates service discovery on
@ -103,13 +114,12 @@ Requires: %{name} = %{version}-%{release}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: %{name}-glib%{?_isa} = %{version}-%{release}
Requires: %{name}-ui-gtk3%{?_isa} = %{version}-%{release}
Requires: python-avahi = %{version}-%{release}
Requires: %{name}-avahi = %{version}-%{release}
Requires: vnc
Requires: openssh-clients
Requires: pygtk2
Requires: pygtk2-libglade
Requires: gdbm
Requires: python
Requires: dbus-python
%description ui-tools
@ -328,6 +338,7 @@ fashion with mDNS.
%package -n python-avahi
Summary: Python2 Avahi bindings
Provides: python2-avahi = %{version}-%{release}
Requires: %{name} = %{version}-%{release}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
@ -342,17 +353,28 @@ Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description -n python3-avahi
%{summary}.
%prep
%setup -q
%patch0 -p1 -b .mono-libdir
%patch1 -p1 -b .no_deprecations
%patch2 -p1 -b .disable-workstation-hinfo
%patch3 -p1 -b .netlink-userns
%patch4 -p1 -b .python3
%patch5 -p1 -b .reserve-size
%patch1 -p1 -b .0001
%patch2 -p1 -b .0002
%patch3 -p1 -b .0003
%patch4 -p1 -b .0004
%patch5 -p1 -b .0005
%patch6 -p1 -b .0006
%patch7 -p1 -b .0007
%patch8 -p1 -b .0008
%patch100 -p1 -b .mono-libdir
%patch101 -p1 -b .no_deprecations
%patch103 -p1 -b .netlink-userns
%patch104 -p1 -b .python3
%patch105 -p1 -b .reserve-size
rm docs/INSTALL
# patch1 requires autogen
# patch101 requires autogen
rm -v missing
NOCONFIGURE=1 ./autogen.sh
%build
@ -410,9 +432,9 @@ ln -s avahi-compat-libdns_sd/dns_sd.h %{buildroot}/%{_includedir}/
%endif
# Add python3 support
mkdir -p %{buildroot}%{_prefix}/lib/python3.4/site-packages/avahi/
cp -r %{buildroot}%{_prefix}/lib/python2.?/site-packages/avahi/* %{buildroot}%{_prefix}/lib/python3.4/site-packages/avahi/
rm -fv %{buildroot}%{_prefix}/lib/python3.4/site-packages/avahi/*.py{c,o}
mkdir -p %{buildroot}%{python3_sitelib}/avahi/
cp -r %{buildroot}%{python2_sitelib}/avahi/* %{buildroot}%{python3_sitelib}/avahi/
rm -fv %{buildroot}%{buildroot}%{python3_sitelib}/avahi/*.py{c,o}
rm -fv %{buildroot}%{_sysconfdir}/rc.d/init.d/avahi-daemon
rm -fv %{buildroot}%{_sysconfdir}/rc.d/init.d/avahi-dnsconfd
@ -586,7 +608,7 @@ exit 0
%{_datadir}/appdata/*.appdata.xml
%{_datadir}/applications/avahi-discover.desktop
%{_datadir}/avahi/interfaces/
%{_prefix}/lib/python2.?/site-packages/avahi_discover/
%{python2_sitelib}/avahi_discover/
%files devel
%{_libdir}/libavahi-common.so
@ -693,13 +715,16 @@ exit 0
%files -n python-avahi
# These are .py files only, so they don't go in lib64
%{_prefix}/lib/python2.?/site-packages/avahi
%{python2_sitelib}/avahi/
%files -n python3-avahi
# These are .py files only, so they don't go in lib64
%{_prefix}/lib/python3.?/site-packages/
%{python3_sitelib}/avahi/
%changelog
* Thu Sep 17 2015 Rex Dieter <rdieter@fedoraproject.org> 0.6.31-38
- pull in post 0.6.31 upstream fixes, python related packaging polish
* Tue Jul 14 2015 Jason L Tibbitts III <tibbs@math.uh.edu> - 0.6.31-37
- Add old patch from SuSE to fix 100%% CPU bug (RHBZ 952193).
- Don't install py2.7 .py{o,c} files in py3.4 package.