Refresh the patches, and remove one that is no longer needed.

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2015-10-14 15:00:20 -06:00
parent 8b92b35b7f
commit d2e646292a
11 changed files with 130 additions and 254 deletions

View File

@ -1,7 +1,7 @@
Index: src/generate/unix/Makefile.config
Index: acpica-unix2-20150930/generate/unix/Makefile.config
===================================================================
--- src.orig/generate/unix/Makefile.config
+++ src/generate/unix/Makefile.config
--- acpica-unix2-20150930.orig/generate/unix/Makefile.config
+++ acpica-unix2-20150930/generate/unix/Makefile.config
@@ -23,6 +23,9 @@
# OPT_CFLAGS can be overridden on the make command line by
# adding OPT_CFLAGS="..." to the invocation.

View File

@ -31,8 +31,7 @@ Patch4: re-enable-big-endian.patch
Patch5: OPT_LDFLAGS.patch
Patch6: int-format.patch
Patch7: f23-harden.patch
Patch8: rename-file.patch
Patch9: asllookup-ppc64.patch
Patch8: asllookup-ppc64.patch
BuildRequires: bison patchutils flex
@ -90,8 +89,7 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
%patch5 -p1 -b .OPT_LDFLAGS
%patch6 -p1 -b .int-format
%patch7 -p1 -b .f23-harden
%patch8 -p1 -b .rename-file
%patch9 -p1 -b .asllookup-ppc64
%patch8 -p1 -b .asllookup-ppc64
cp -p %{SOURCE2} README.Fedora
cp -p %{SOURCE3} iasl.1
@ -188,6 +186,7 @@ fi
%changelog
* Wed Oct 14 2015 Al Stone <ahs3@redhat.com> - 20150930-1
- Update to latest upstream. Closes BZ#1267772.
- Refresh patches, and remove one no longer needed.
* Thu Sep 10 2015 Al Stone <ahs3@redhat.com> - 20150818-2
- Remove extraneous patch files for AAPITS.

View File

@ -1,7 +1,7 @@
Index: src/source/compiler/asllookup.c
Index: acpica-unix2-20150930/source/compiler/asllookup.c
===================================================================
--- src.orig/source/compiler/asllookup.c
+++ src/source/compiler/asllookup.c
--- acpica-unix2-20150930.orig/source/compiler/asllookup.c
+++ acpica-unix2-20150930/source/compiler/asllookup.c
@@ -119,6 +119,7 @@ LkIsObjectUsed (
{
ACPI_NAMESPACE_NODE *Node = ACPI_CAST_PTR (ACPI_NAMESPACE_NODE, ObjHandle);

View File

@ -1,7 +1,8 @@
diff -Naur acpica-unix2-20150818/source/compiler/asllookup.c acpica-unix2-20150818.fixes/source/compiler/asllookup.c
--- acpica-unix2-20150818/source/compiler/asllookup.c 2015-09-10 16:07:37.573262497 -0600
+++ acpica-unix2-20150818.fixes/source/compiler/asllookup.c 2015-09-10 16:26:26.336912875 -0600
@@ -176,7 +176,8 @@
Index: acpica-unix2-20150930/source/compiler/asllookup.c
===================================================================
--- acpica-unix2-20150930.orig/source/compiler/asllookup.c
+++ acpica-unix2-20150930/source/compiler/asllookup.c
@@ -176,7 +176,8 @@ LkIsObjectUsed (
* We ignore the predefined methods since often, not
* all arguments are needed or used.
*/

View File

@ -1,7 +1,7 @@
Index: src/source/compiler/aslcodegen.c
Index: acpica-unix2-20150930/source/compiler/aslcodegen.c
===================================================================
--- src.orig/source/compiler/aslcodegen.c
+++ src/source/compiler/aslcodegen.c
--- acpica-unix2-20150930.orig/source/compiler/aslcodegen.c
+++ acpica-unix2-20150930/source/compiler/aslcodegen.c
@@ -249,16 +249,12 @@ CgWriteAmlOpcode (
ACPI_PARSE_OBJECT *Op)
{
@ -239,10 +239,10 @@ Index: src/source/compiler/aslcodegen.c
case AML_RAW_DATA_BUFFER:
Index: src/source/compiler/aslopcodes.c
Index: acpica-unix2-20150930/source/compiler/aslopcodes.c
===================================================================
--- src.orig/source/compiler/aslopcodes.c
+++ src/source/compiler/aslopcodes.c
--- acpica-unix2-20150930.orig/source/compiler/aslopcodes.c
+++ acpica-unix2-20150930/source/compiler/aslopcodes.c
@@ -531,6 +531,7 @@ OpcDoUnicode (
UINT32 i;
UINT8 *AsciiString;
@ -261,10 +261,10 @@ Index: src/source/compiler/aslopcodes.c
}
/*
Index: src/source/compiler/aslrestype1.c
Index: acpica-unix2-20150930/source/compiler/aslrestype1.c
===================================================================
--- src.orig/source/compiler/aslrestype1.c
+++ src/source/compiler/aslrestype1.c
--- acpica-unix2-20150930.orig/source/compiler/aslrestype1.c
+++ acpica-unix2-20150930/source/compiler/aslrestype1.c
@@ -143,6 +143,11 @@ RsDoMemory24Descriptor (
ACPI_PARSE_OBJECT *LengthOp = NULL;
ASL_RESOURCE_NODE *Rnode;
@ -461,10 +461,10 @@ Index: src/source/compiler/aslrestype1.c
RsCreateDwordField (InitializerOp, ACPI_RESTAG_LENGTH,
CurrentByteOffset + ASL_RESDESC_OFFSET (FixedMemory32.AddressLength));
break;
Index: src/source/compiler/aslrestype1i.c
Index: acpica-unix2-20150930/source/compiler/aslrestype1i.c
===================================================================
--- src.orig/source/compiler/aslrestype1i.c
+++ src/source/compiler/aslrestype1i.c
--- acpica-unix2-20150930.orig/source/compiler/aslrestype1i.c
+++ acpica-unix2-20150930/source/compiler/aslrestype1i.c
@@ -198,6 +198,8 @@ RsDoFixedDmaDescriptor (
ACPI_PARSE_OBJECT *InitializerOp;
ASL_RESOURCE_NODE *Rnode;
@ -601,10 +601,10 @@ Index: src/source/compiler/aslrestype1i.c
+ ACPI_MOVE_16_TO_16(&Descriptor->Irq.IrqMask, &IrqMask);
return (Rnode);
}
Index: src/source/compiler/aslrestype2.c
Index: acpica-unix2-20150930/source/compiler/aslrestype2.c
===================================================================
--- src.orig/source/compiler/aslrestype2.c
+++ src/source/compiler/aslrestype2.c
--- acpica-unix2-20150930.orig/source/compiler/aslrestype2.c
+++ acpica-unix2-20150930/source/compiler/aslrestype2.c
@@ -76,6 +76,7 @@ RsDoGeneralRegisterDescriptor (
ACPI_PARSE_OBJECT *InitializerOp;
ASL_RESOURCE_NODE *Rnode;
@ -700,10 +700,10 @@ Index: src/source/compiler/aslrestype2.c
/* Point to end-of-descriptor for vendor data */
Index: src/source/compiler/aslrestype2d.c
Index: acpica-unix2-20150930/source/compiler/aslrestype2d.c
===================================================================
--- src.orig/source/compiler/aslrestype2d.c
+++ src/source/compiler/aslrestype2d.c
--- acpica-unix2-20150930.orig/source/compiler/aslrestype2d.c
+++ acpica-unix2-20150930/source/compiler/aslrestype2d.c
@@ -79,7 +79,13 @@ RsDoDwordIoDescriptor (
ACPI_PARSE_OBJECT *GranOp = NULL;
ASL_RESOURCE_NODE *Rnode;
@ -1059,10 +1059,10 @@ Index: src/source/compiler/aslrestype2d.c
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS32) +
OptionIndex + StringLength;
return (Rnode);
Index: src/source/compiler/aslrestype2e.c
Index: acpica-unix2-20150930/source/compiler/aslrestype2e.c
===================================================================
--- src.orig/source/compiler/aslrestype2e.c
+++ src/source/compiler/aslrestype2e.c
--- acpica-unix2-20150930.orig/source/compiler/aslrestype2e.c
+++ acpica-unix2-20150930/source/compiler/aslrestype2e.c
@@ -78,6 +78,13 @@ RsDoExtendedIoDescriptor (
ACPI_PARSE_OBJECT *GranOp = NULL;
ASL_RESOURCE_NODE *Rnode;
@ -1168,10 +1168,10 @@ Index: src/source/compiler/aslrestype2e.c
Rnode->BufferLength = sizeof (AML_RESOURCE_EXTENDED_ADDRESS64) +
StringLength;
return (Rnode);
Index: src/source/compiler/aslrestype2q.c
Index: acpica-unix2-20150930/source/compiler/aslrestype2q.c
===================================================================
--- src.orig/source/compiler/aslrestype2q.c
+++ src/source/compiler/aslrestype2q.c
--- acpica-unix2-20150930.orig/source/compiler/aslrestype2q.c
+++ acpica-unix2-20150930/source/compiler/aslrestype2q.c
@@ -80,7 +80,13 @@ RsDoQwordIoDescriptor (
ASL_RESOURCE_NODE *Rnode;
UINT8 *OptionalFields;
@ -1510,10 +1510,10 @@ Index: src/source/compiler/aslrestype2q.c
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS64) +
OptionIndex + StringLength;
return (Rnode);
Index: src/source/compiler/aslrestype2s.c
Index: acpica-unix2-20150930/source/compiler/aslrestype2s.c
===================================================================
--- src.orig/source/compiler/aslrestype2s.c
+++ src/source/compiler/aslrestype2s.c
--- acpica-unix2-20150930.orig/source/compiler/aslrestype2s.c
+++ acpica-unix2-20150930/source/compiler/aslrestype2s.c
@@ -290,6 +290,9 @@ RsDoGpioIntDescriptor (
UINT16 VendorLength;
UINT16 InterruptLength;
@ -1827,10 +1827,10 @@ Index: src/source/compiler/aslrestype2s.c
MpSaveSerialInfo (Info->MappingOp, Descriptor, ResourceSource);
return (Rnode);
}
Index: src/source/compiler/aslrestype2w.c
Index: acpica-unix2-20150930/source/compiler/aslrestype2w.c
===================================================================
--- src.orig/source/compiler/aslrestype2w.c
+++ src/source/compiler/aslrestype2w.c
--- acpica-unix2-20150930.orig/source/compiler/aslrestype2w.c
+++ acpica-unix2-20150930/source/compiler/aslrestype2w.c
@@ -81,6 +81,12 @@ RsDoWordIoDescriptor (
UINT8 *OptionalFields;
UINT16 StringLength = 0;
@ -2174,10 +2174,10 @@ Index: src/source/compiler/aslrestype2w.c
Rnode->BufferLength = sizeof (AML_RESOURCE_ADDRESS16) +
OptionIndex + StringLength;
return (Rnode);
Index: src/source/include/acmacros.h
Index: acpica-unix2-20150930/source/include/acmacros.h
===================================================================
--- src.orig/source/include/acmacros.h
+++ src/source/include/acmacros.h
--- acpica-unix2-20150930.orig/source/include/acmacros.h
+++ acpica-unix2-20150930/source/include/acmacros.h
@@ -100,7 +100,8 @@
/* 32-bit source, 16/32/64 destination */
@ -2215,10 +2215,10 @@ Index: src/source/include/acmacros.h
#define ACPI_MOVE_32_TO_32(d, s) *(UINT32 *)(void *)(d) = *(UINT32 *)(void *)(s)
#define ACPI_MOVE_32_TO_64(d, s) *(UINT64 *)(void *)(d) = *(UINT32 *)(void *)(s)
Index: src/source/include/platform/aclinux.h
Index: acpica-unix2-20150930/source/include/platform/aclinux.h
===================================================================
--- src.orig/source/include/platform/aclinux.h
+++ src/source/include/platform/aclinux.h
--- acpica-unix2-20150930.orig/source/include/platform/aclinux.h
+++ acpica-unix2-20150930/source/include/platform/aclinux.h
@@ -167,6 +167,7 @@
#include <stdlib.h>
#include <ctype.h>

View File

@ -15,11 +15,11 @@ Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
source/include/actypes.h | 26 +++++++++++++-------------
3 file modificati, 32 inserzioni(+), 21 rimozioni(-)
Index: src/source/compiler/asltree.c
Index: acpica-unix2-20150930/source/compiler/asltree.c
===================================================================
--- src.orig/source/compiler/asltree.c
+++ src/source/compiler/asltree.c
@@ -862,28 +862,31 @@ TrCreateValuedLeafNode (
--- acpica-unix2-20150930.orig/source/compiler/asltree.c
+++ acpica-unix2-20150930/source/compiler/asltree.c
@@ -863,28 +863,31 @@ TrCreateValuedLeafNode (
"\nCreateValuedLeafNode Ln/Col %u/%u NewNode %p Op %s Value %8.8X%8.8X ",
Op->Asl.LineNumber, Op->Asl.Column, Op, UtGetOpName(ParseOpcode),
ACPI_FORMAT_UINT64 (Value));
@ -56,7 +56,7 @@ Index: src/source/compiler/asltree.c
break;
case PARSEOP_METHOD:
@@ -893,12 +896,14 @@ TrCreateValuedLeafNode (
@@ -894,12 +897,14 @@ TrCreateValuedLeafNode (
case PARSEOP_INTEGER:
@ -71,10 +71,10 @@ Index: src/source/compiler/asltree.c
break;
}
Index: src/source/components/executer/exoparg2.c
Index: acpica-unix2-20150930/source/components/executer/exoparg2.c
===================================================================
--- src.orig/source/components/executer/exoparg2.c
+++ src/source/components/executer/exoparg2.c
--- acpica-unix2-20150930.orig/source/components/executer/exoparg2.c
+++ acpica-unix2-20150930/source/components/executer/exoparg2.c
@@ -172,6 +172,8 @@ AcpiExOpcode_2A_2T_1R (
ACPI_OPERAND_OBJECT **Operand = &WalkState->Operands[0];
ACPI_OPERAND_OBJECT *ReturnDesc1 = NULL;
@ -115,10 +115,10 @@ Index: src/source/components/executer/exoparg2.c
break;
case AML_CONCAT_OP: /* Concatenate (Data1, Data2, Result) */
Index: src/source/include/actypes.h
Index: acpica-unix2-20150930/source/include/actypes.h
===================================================================
--- src.orig/source/include/actypes.h
+++ src/source/include/actypes.h
--- acpica-unix2-20150930.orig/source/include/actypes.h
+++ acpica-unix2-20150930/source/include/actypes.h
@@ -143,6 +143,19 @@ typedef COMPILER_DEPENDENT_INT64
*/
#define ACPI_THREAD_ID UINT64

View File

@ -1,7 +1,7 @@
Index: src/generate/unix/Makefile.config
Index: acpica-unix2-20150930/generate/unix/Makefile.config
===================================================================
--- src.orig/generate/unix/Makefile.config
+++ src/generate/unix/Makefile.config
--- acpica-unix2-20150930.orig/generate/unix/Makefile.config
+++ acpica-unix2-20150930/generate/unix/Makefile.config
@@ -167,6 +167,8 @@ ifneq ($(NOFORTIFY),TRUE)
OPT_CFLAGS += -D_FORTIFY_SOURCE=2
endif
@ -11,11 +11,11 @@ Index: src/generate/unix/Makefile.config
CFLAGS += \
-D$(HOST)\
-D_GNU_SOURCE\
Index: src/generate/unix/iasl/Makefile
Index: acpica-unix2-20150930/generate/unix/iasl/Makefile
===================================================================
--- src.orig/generate/unix/iasl/Makefile
+++ src/generate/unix/iasl/Makefile
@@ -303,20 +303,21 @@ $(OBJDIR)/prparserparse.c : $(ASL_COM
--- acpica-unix2-20150930.orig/generate/unix/iasl/Makefile
+++ acpica-unix2-20150930/generate/unix/iasl/Makefile
@@ -305,20 +305,21 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prpa
# Cannot use the common compile warning flags since the C files are created
# by the utilities above and they are not necessarily ANSI C, etc.
#

View File

@ -1,8 +1,8 @@
Index: src/source/compiler/aslcompile.c
Index: acpica-unix2-20150930/source/compiler/aslcompile.c
===================================================================
--- src.orig/source/compiler/aslcompile.c
+++ src/source/compiler/aslcompile.c
@@ -696,7 +696,7 @@ CmCleanupAndExit (
--- acpica-unix2-20150930.orig/source/compiler/aslcompile.c
+++ acpica-unix2-20150930/source/compiler/aslcompile.c
@@ -699,7 +699,7 @@ CmCleanupAndExit (
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
{
@ -11,10 +11,10 @@ Index: src/source/compiler/aslcompile.c
ASL_MAX_ERROR_COUNT);
}
Index: src/source/tools/acpiexec/aemain.c
Index: acpica-unix2-20150930/source/tools/acpiexec/aemain.c
===================================================================
--- src.orig/source/tools/acpiexec/aemain.c
+++ src/source/tools/acpiexec/aemain.c
--- acpica-unix2-20150930.orig/source/tools/acpiexec/aemain.c
+++ acpica-unix2-20150930/source/tools/acpiexec/aemain.c
@@ -203,7 +203,7 @@ AeDoOptions (
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))
@ -24,10 +24,10 @@ Index: src/source/tools/acpiexec/aemain.c
(UINT32) strlen (AcpiGbl_Optarg), (AE_BUFFER_SIZE -1));
return (-1);
}
Index: src/source/compiler/aslerror.c
Index: acpica-unix2-20150930/source/compiler/aslerror.c
===================================================================
--- src.orig/source/compiler/aslerror.c
+++ src/source/compiler/aslerror.c
--- acpica-unix2-20150930.orig/source/compiler/aslerror.c
+++ acpica-unix2-20150930/source/compiler/aslerror.c
@@ -685,7 +685,7 @@ AslCommonError (
Gbl_ExceptionCount[Level]++;
if (Gbl_ExceptionCount[ASL_ERROR] > ASL_MAX_ERROR_COUNT)
@ -46,10 +46,10 @@ Index: src/source/compiler/aslerror.c
ASL_MAX_DISABLED_MESSAGES);
return (AE_LIMIT);
}
Index: src/source/components/debugger/dbexec.c
Index: acpica-unix2-20150930/source/components/debugger/dbexec.c
===================================================================
--- src.orig/source/components/debugger/dbexec.c
+++ src/source/components/debugger/dbexec.c
--- acpica-unix2-20150930.orig/source/components/debugger/dbexec.c
+++ acpica-unix2-20150930/source/components/debugger/dbexec.c
@@ -214,7 +214,7 @@ AcpiDbExecuteMethod (
ACPI_ERROR ((AE_INFO,
"Possible overflow of internal debugger "
@ -59,10 +59,10 @@ Index: src/source/components/debugger/dbexec.c
}
}
Index: src/source/compiler/aslopt.c
Index: acpica-unix2-20150930/source/compiler/aslopt.c
===================================================================
--- src.orig/source/compiler/aslopt.c
+++ src/source/compiler/aslopt.c
--- acpica-unix2-20150930.orig/source/compiler/aslopt.c
+++ acpica-unix2-20150930/source/compiler/aslopt.c
@@ -576,7 +576,7 @@ OptOptimizeNamePath (
}
@ -72,10 +72,10 @@ Index: src/source/compiler/aslopt.c
Op->Asl.LogicalLineNumber,
AcpiPsGetOpcodeName (Op->Common.Parent->Common.AmlOpcode),
AcpiPsGetOpcodeName (Op->Common.AmlOpcode)));
Index: src/source/components/dispatcher/dsmthdat.c
Index: acpica-unix2-20150930/source/components/dispatcher/dsmthdat.c
===================================================================
--- src.orig/source/components/dispatcher/dsmthdat.c
+++ src/source/components/dispatcher/dsmthdat.c
--- acpica-unix2-20150930.orig/source/components/dispatcher/dsmthdat.c
+++ acpica-unix2-20150930/source/components/dispatcher/dsmthdat.c
@@ -287,7 +287,7 @@ AcpiDsMethodDataGetNode (
if (Index > ACPI_METHOD_MAX_LOCAL)
{
@ -94,10 +94,10 @@ Index: src/source/components/dispatcher/dsmthdat.c
Index, ACPI_METHOD_MAX_ARG));
return_ACPI_STATUS (AE_AML_INVALID_INDEX);
}
Index: src/source/compiler/aslpredef.c
Index: acpica-unix2-20150930/source/compiler/aslpredef.c
===================================================================
--- src.orig/source/compiler/aslpredef.c
+++ src/source/compiler/aslpredef.c
--- acpica-unix2-20150930.orig/source/compiler/aslpredef.c
+++ acpica-unix2-20150930/source/compiler/aslpredef.c
@@ -114,7 +114,7 @@ ApCheckForPredefinedMethod (
if (MethodInfo->NumArguments != 0)
@ -107,10 +107,10 @@ Index: src/source/compiler/aslpredef.c
AslError (ASL_WARNING, ASL_MSG_RESERVED_ARG_COUNT_HI, Op,
MsgBuffer);
Index: src/source/compiler/aslprepkg.c
Index: acpica-unix2-20150930/source/compiler/aslprepkg.c
===================================================================
--- src.orig/source/compiler/aslprepkg.c
+++ src/source/compiler/aslprepkg.c
--- acpica-unix2-20150930.orig/source/compiler/aslprepkg.c
+++ acpica-unix2-20150930/source/compiler/aslprepkg.c
@@ -298,7 +298,7 @@ ApCheckPackage (
if (Count & 1)
@ -120,10 +120,10 @@ Index: src/source/compiler/aslprepkg.c
Predefined->Info.Name, Count);
AslError (ASL_ERROR, ASL_MSG_RESERVED_PACKAGE_LENGTH,
Index: src/source/components/dispatcher/dsutils.c
Index: acpica-unix2-20150930/source/components/dispatcher/dsutils.c
===================================================================
--- src.orig/source/components/dispatcher/dsutils.c
+++ src/source/components/dispatcher/dsutils.c
--- acpica-unix2-20150930.orig/source/components/dispatcher/dsutils.c
+++ acpica-unix2-20150930/source/components/dispatcher/dsutils.c
@@ -787,7 +787,7 @@ AcpiDsCreateOperands (
}
@ -133,10 +133,10 @@ Index: src/source/components/dispatcher/dsutils.c
WalkState->NumOperands, ArgCount, Index));
/* Create the interpreter arguments, in reverse order */
Index: src/source/components/dispatcher/dswscope.c
Index: acpica-unix2-20150930/source/components/dispatcher/dswscope.c
===================================================================
--- src.orig/source/components/dispatcher/dswscope.c
+++ src/source/components/dispatcher/dswscope.c
--- acpica-unix2-20150930.orig/source/components/dispatcher/dswscope.c
+++ acpica-unix2-20150930/source/components/dispatcher/dswscope.c
@@ -148,7 +148,7 @@ AcpiDsScopeStackPush (
WalkState->ScopeDepth++;
@ -155,10 +155,10 @@ Index: src/source/components/dispatcher/dswscope.c
(UINT32) WalkState->ScopeDepth,
AcpiUtGetNodeName (ScopeInfo->Scope.Node),
AcpiUtGetTypeName (ScopeInfo->Common.Value)));
Index: src/source/components/events/evgpe.c
Index: acpica-unix2-20150930/source/components/events/evgpe.c
===================================================================
--- src.orig/source/components/events/evgpe.c
+++ src/source/components/events/evgpe.c
--- acpica-unix2-20150930.orig/source/components/events/evgpe.c
+++ acpica-unix2-20150930/source/components/events/evgpe.c
@@ -430,7 +430,7 @@ AcpiEvGpeDetect (
"Ignore disabled registers for GPE %02X-%02X: "
"RunEnable=%02X, WakeEnable=%02X\n",
@ -177,10 +177,10 @@ Index: src/source/components/events/evgpe.c
StatusReg, EnableReg,
GpeRegisterInfo->EnableForRun,
GpeRegisterInfo->EnableForWake));
Index: src/source/components/executer/exdump.c
Index: acpica-unix2-20150930/source/components/executer/exdump.c
===================================================================
--- src.orig/source/components/executer/exdump.c
+++ src/source/components/executer/exdump.c
--- acpica-unix2-20150930.orig/source/components/executer/exdump.c
+++ acpica-unix2-20150930/source/components/executer/exdump.c
@@ -664,7 +664,7 @@ AcpiExDumpOperand (
if (Depth > 0)
{
@ -190,10 +190,10 @@ Index: src/source/components/executer/exdump.c
}
else
{
Index: src/source/components/executer/exnames.c
Index: acpica-unix2-20150930/source/components/executer/exnames.c
===================================================================
--- src.orig/source/components/executer/exnames.c
+++ src/source/components/executer/exnames.c
--- acpica-unix2-20150930.orig/source/components/executer/exnames.c
+++ acpica-unix2-20150930/source/components/executer/exnames.c
@@ -239,7 +239,7 @@ AcpiExNameSegment (
*/
ACPI_DEBUG_PRINT ((ACPI_DB_INFO,
@ -212,10 +212,10 @@ Index: src/source/components/executer/exnames.c
}
*InAmlAddress = ACPI_CAST_PTR (UINT8, AmlAddress);
Index: src/source/components/executer/exfldio.c
Index: acpica-unix2-20150930/source/components/executer/exfldio.c
===================================================================
--- src.orig/source/components/executer/exfldio.c
+++ src/source/components/executer/exfldio.c
--- acpica-unix2-20150930.orig/source/components/executer/exfldio.c
+++ acpica-unix2-20150930/source/components/executer/exfldio.c
@@ -679,7 +679,7 @@ AcpiExWriteWithUpdateRule (
ACPI_ERROR ((AE_INFO,
@ -225,10 +225,10 @@ Index: src/source/components/executer/exfldio.c
return_ACPI_STATUS (AE_AML_OPERAND_VALUE);
}
}
Index: src/source/components/tables/tbfadt.c
Index: acpica-unix2-20150930/source/components/tables/tbfadt.c
===================================================================
--- src.orig/source/components/tables/tbfadt.c
+++ src/source/components/tables/tbfadt.c
--- acpica-unix2-20150930.orig/source/components/tables/tbfadt.c
+++ acpica-unix2-20150930/source/components/tables/tbfadt.c
@@ -233,7 +233,7 @@ AcpiTbInitGenericAddress (
if (!(Flags & ACPI_FADT_GPE_REGISTER))
{
@ -256,10 +256,10 @@ Index: src/source/components/tables/tbfadt.c
Name, Address32,
ACPI_FORMAT_UINT64 (Address64->Address),
AcpiGbl_Use32BitFadtAddresses ? 32 : 64));
Index: src/source/components/hardware/hwregs.c
Index: acpica-unix2-20150930/source/components/hardware/hwregs.c
===================================================================
--- src.orig/source/components/hardware/hwregs.c
+++ src/source/components/hardware/hwregs.c
--- acpica-unix2-20150930.orig/source/components/hardware/hwregs.c
+++ acpica-unix2-20150930/source/components/hardware/hwregs.c
@@ -299,7 +299,7 @@ AcpiHwClearAcpiStatus (
@ -269,10 +269,10 @@ Index: src/source/components/hardware/hwregs.c
ACPI_FORMAT_UINT64 (AcpiGbl_XPm1aStatus.Address)));
LockFlags = AcpiOsAcquireLock (AcpiGbl_HardwareLock);
Index: src/source/components/tables/tbxfroot.c
Index: acpica-unix2-20150930/source/components/tables/tbxfroot.c
===================================================================
--- src.orig/source/components/tables/tbxfroot.c
+++ src/source/components/tables/tbxfroot.c
--- acpica-unix2-20150930.orig/source/components/tables/tbxfroot.c
+++ acpica-unix2-20150930/source/components/tables/tbxfroot.c
@@ -177,7 +177,7 @@ AcpiFindRootPointer (
{
ACPI_ERROR ((AE_INFO,
@ -300,10 +300,10 @@ Index: src/source/components/tables/tbxfroot.c
return_ACPI_STATUS (AE_NO_MEMORY);
}
Index: src/source/components/utilities/utownerid.c
Index: acpica-unix2-20150930/source/components/utilities/utownerid.c
===================================================================
--- src.orig/source/components/utilities/utownerid.c
+++ src/source/components/utilities/utownerid.c
--- acpica-unix2-20150930.orig/source/components/utilities/utownerid.c
+++ acpica-unix2-20150930/source/components/utilities/utownerid.c
@@ -230,7 +230,7 @@ AcpiUtReleaseOwnerId (
else
{

View File

@ -4,10 +4,10 @@ to be compared were being treated as 32-bit ints, and not strings. Hence,
the characters were re-ordered incorrectly, mismatching the assumptions
made in the remainder of the function.
Index: src/source/compiler/aslanalyze.c
Index: acpica-unix2-20150930/source/compiler/aslanalyze.c
===================================================================
--- src.orig/source/compiler/aslanalyze.c
+++ src/source/compiler/aslanalyze.c
--- acpica-unix2-20150930.orig/source/compiler/aslanalyze.c
+++ acpica-unix2-20150930/source/compiler/aslanalyze.c
@@ -445,7 +445,7 @@ ApCheckForGpeNameConflict (
/* Need a null-terminated string version of NameSeg */

View File

@ -2,11 +2,11 @@ Re-enable use of these tools on big-endian machines.
Al Stone <ahs3@redhat.com>
Index: src/source/compiler/aslmain.c
Index: acpica-unix2-20150930/source/compiler/aslmain.c
===================================================================
--- src.orig/source/compiler/aslmain.c
+++ src/source/compiler/aslmain.c
@@ -339,18 +339,6 @@ main (
--- acpica-unix2-20150930.orig/source/compiler/aslmain.c
+++ acpica-unix2-20150930/source/compiler/aslmain.c
@@ -340,18 +340,6 @@ main (
int ReturnStatus = 0;

View File

@ -1,124 +0,0 @@
diff -Naur acpica-unix2-20150818/source/tools/acpinames/acpinames.h acpica-unix2-20150818.fixes/source/tools/acpinames/acpinames.h
--- acpica-unix2-20150818/source/tools/acpinames/acpinames.h 1969-12-31 17:00:00.000000000 -0700
+++ acpica-unix2-20150818.fixes/source/tools/acpinames/acpinames.h 2015-09-09 17:40:12.850371450 -0600
@@ -0,0 +1,58 @@
+/******************************************************************************
+ *
+ * Module Name: acpinames.h - Common include for AcpiNames utility
+ *
+ *****************************************************************************/
+
+/*
+ * Copyright (C) 2000 - 2015, Intel Corp.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions, and the following disclaimer,
+ * without modification.
+ * 2. Redistributions in binary form must reproduce at minimum a disclaimer
+ * substantially similar to the "NO WARRANTY" disclaimer below
+ * ("Disclaimer") and any redistribution must be conditioned upon
+ * including a substantially similar Disclaimer requirement for further
+ * binary redistribution.
+ * 3. Neither the names of the above-listed copyright holders nor the names
+ * of any contributors may be used to endorse or promote products derived
+ * from this software without specific prior written permission.
+ *
+ * Alternatively, this software may be distributed under the terms of the
+ * GNU General Public License ("GPL") version 2 as published by the Free
+ * Software Foundation.
+ *
+ * NO WARRANTY
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+ * HOLDERS OR CONTRIBUTORS BE LIABLE FOR SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+ * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+ * IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGES.
+ */
+
+#ifndef _ACPINAMES_H
+#define _ACPINAMES_H
+
+#include "acpi.h"
+#include "accommon.h"
+#include "acapps.h"
+#include "acutils.h"
+#include "../acpiexec/aecommon.h"
+
+#include <stdio.h>
+
+#define ACPI_MAX_INIT_TABLES (32)
+
+extern BOOLEAN AcpiGbl_NsLoadOnly;
+#endif
diff -Naur acpica-unix2-20150818/source/tools/acpinames/AcpiNames.h acpica-unix2-20150818.fixes/source/tools/acpinames/AcpiNames.h
--- acpica-unix2-20150818/source/tools/acpinames/AcpiNames.h 2015-08-18 14:11:26.000000000 -0600
+++ acpica-unix2-20150818.fixes/source/tools/acpinames/AcpiNames.h 1969-12-31 17:00:00.000000000 -0700
@@ -1,58 +0,0 @@
-/******************************************************************************
- *
- * Module Name: acpinames.h - Common include for AcpiNames utility
- *
- *****************************************************************************/
-
-/*
- * Copyright (C) 2000 - 2015, Intel Corp.
- * All rights reserved.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions, and the following disclaimer,
- * without modification.
- * 2. Redistributions in binary form must reproduce at minimum a disclaimer
- * substantially similar to the "NO WARRANTY" disclaimer below
- * ("Disclaimer") and any redistribution must be conditioned upon
- * including a substantially similar Disclaimer requirement for further
- * binary redistribution.
- * 3. Neither the names of the above-listed copyright holders nor the names
- * of any contributors may be used to endorse or promote products derived
- * from this software without specific prior written permission.
- *
- * Alternatively, this software may be distributed under the terms of the
- * GNU General Public License ("GPL") version 2 as published by the Free
- * Software Foundation.
- *
- * NO WARRANTY
- * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
- * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
- * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR
- * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
- * HOLDERS OR CONTRIBUTORS BE LIABLE FOR SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
- * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
- * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
- * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
- * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
- * IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- * POSSIBILITY OF SUCH DAMAGES.
- */
-
-#ifndef _ACPINAMES_H
-#define _ACPINAMES_H
-
-#include "acpi.h"
-#include "accommon.h"
-#include "acapps.h"
-#include "acutils.h"
-#include "../acpiexec/aecommon.h"
-
-#include <stdio.h>
-
-#define ACPI_MAX_INIT_TABLES (32)
-
-extern BOOLEAN AcpiGbl_NsLoadOnly;
-#endif