acpica-tools/OPT_LDFLAGS.patch
Al Stone d2e646292a Refresh the patches, and remove one that is no longer needed.
Signed-off-by: Al Stone <ahs3@redhat.com>
2015-10-14 15:00:20 -06:00

36 lines
1.1 KiB
Diff

Index: acpica-unix2-20150930/generate/unix/Makefile.config
===================================================================
--- acpica-unix2-20150930.orig/generate/unix/Makefile.config
+++ acpica-unix2-20150930/generate/unix/Makefile.config
@@ -23,6 +23,9 @@
# OPT_CFLAGS can be overridden on the make command line by
# adding OPT_CFLAGS="..." to the invocation.
#
+# OPT_LDFLAGS can be overridden on the make command line by
+# adding OPT_LDFLAGS="..." to the invocation.
+#
# Notes:
# gcc should be version 4 or greater, otherwise some of the options
# used will not be recognized.
@@ -43,7 +46,7 @@ CC = gcc
OBJDIR = obj
BINDIR = bin
COMPILEOBJ = $(CC) -c $(CFLAGS) $(OPT_CFLAGS) -o $@ $<
-LINKPROG = $(CC) $(OBJECTS) -o $(PROG) $(LDFLAGS)
+LINKPROG = $(CC) $(OBJECTS) -o $(PROG) $(LDFLAGS) $(OPT_LDFLAGS)
PREFIX ?= /usr
INSTALLDIR = $(PREFIX)/bin
UNAME_S := $(shell uname -s)
@@ -144,6 +147,11 @@ ACPICA_HEADERS = \
OPT_CFLAGS ?= $(CWARNINGFLAGS)
#
+# Common linker flags
+#
+OPT_LDFLAGS ?=
+
+#
# Optionally disable optimizations. Optimization causes problems on
# some compilers such as gcc 4.4
#