Remove AAPITS patches that are no longer in use.

Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
Al Stone 2015-09-10 16:07:15 -06:00
parent 0a7eb74d55
commit 0403c80d07
3 changed files with 4 additions and 357 deletions

View File

@ -1,321 +0,0 @@
Index: src/tests/aapits/atexec.c
===================================================================
--- src.orig/tests/aapits/atexec.c
+++ src/tests/aapits/atexec.c
@@ -639,6 +639,7 @@ AtBuildLocalFADT2 (
}
+#if ACPI_MACHINE_WIDTH == 32
/*******************************************************************************
*
* FUNCTION: AtBuildLocalRSDT
@@ -757,6 +758,7 @@ AtBuildLocalRSDT (
LocalRSDT->Header.Checksum = (UINT8)~LocalRSDT->Header.Checksum;
}
}
+#endif
/*******************************************************************************
@@ -1424,7 +1426,7 @@ AeRegionHandler (
ACPI_WARNING ((AE_INFO,
"Request on [%4.4s] is beyond region limit Req-%X+%X, Base=%X, Len-%X\n",
(RegionObject->Region.Node)->Name.Ascii, (UINT32) Address,
- ByteWidth, (UINT32) BufferAddress, Length));
+ ByteWidth, (UINT32) BufferAddress, (UINT32) Length));
return (AE_AML_REGION_LIMIT);
}
@@ -1799,7 +1801,9 @@ AtCheckInteger(
Path, Obj.Integer.Value, Value);
#else
printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n",
- Path, Obj.Integer.Value, Value);
+ Path,
+ (long long unsigned int) Obj.Integer.Value,
+ (long long unsigned int) Value);
#endif
Status = AE_ERROR;
}
@@ -1878,7 +1882,7 @@ AtCheckString(
{
TestErrors++;
printf ("Test Error: cannot allocate buffer of %d bytes\n",
- Results.Length);
+ (int) Results.Length);
return (AE_NO_MEMORY);
}
Results.Pointer = Object;
@@ -1959,7 +1963,8 @@ AtCheckBuffer(
{
printf ("AtCheckBuffer: unexpected length %d of Buffer vs"
" calculated %d bytes\n",
- Results.Length, ACPI_ROUND_UP_TO_NATIVE_WORD(sizeof (ACPI_OBJECT) + Length));
+ (int)Results.Length,
+ (int)(ACPI_ROUND_UP_TO_NATIVE_WORD(sizeof (ACPI_OBJECT) + Length)));
}
/* Initialize the return buffer structure */
@@ -1968,7 +1973,7 @@ AtCheckBuffer(
{
TestErrors++;
printf ("Test Error: cannot allocate buffer of %d bytes\n",
- Results.Length);
+ (int) Results.Length);
return (AE_NO_MEMORY);
}
Results.Pointer = Object;
Index: src/tests/aapits/atinit.c
===================================================================
--- src.orig/tests/aapits/atinit.c
+++ src/tests/aapits/atinit.c
@@ -3024,7 +3024,7 @@ AtInitTest0041(void)
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (Info));
+ (int) OutBuffer.Length, (int) sizeof (Info));
return (AE_ERROR);
}
@@ -3046,7 +3046,7 @@ AtInitTest0041(void)
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (Info));
+ (int) OutBuffer.Length, (int) sizeof (Info));
return (AE_ERROR);
}
@@ -3066,7 +3066,7 @@ AtInitTest0041(void)
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (Info));
+ (int) OutBuffer.Length, (int) sizeof (Info));
return (AE_ERROR);
}
else if (OutBuffer.Pointer != &Info)
@@ -3149,7 +3149,7 @@ AtInitTest0042(void)
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (Info));
+ (int) OutBuffer.Length, (int) sizeof (Info));
return (AE_ERROR);
}
else if (OutBuffer.Pointer != &Info)
@@ -3214,7 +3214,7 @@ AtInitTest0043(void)
AapiErrors++;
printf ("API Error: AcpiGetSystemInfo() returned"
" Length %d, expected %d\n",
- OutBuffer.Length, sizeof (ACPI_SYSTEM_INFO));
+ (int) OutBuffer.Length, (int) sizeof (ACPI_SYSTEM_INFO));
return (AE_ERROR);
}
else
Index: src/tests/aapits/atmain.c
===================================================================
--- src.orig/tests/aapits/atmain.c
+++ src/tests/aapits/atmain.c
@@ -345,7 +345,7 @@ ExecuteTest (
{
printf ("ACPICA API TS err: test num %ld of test case %ld"
" is not implemented\n",
- test_num, test_case);
+ (long int) test_num, (long int) test_case);
return (AtRetNotImpl);
}
@@ -460,7 +460,7 @@ main(
if (test_case < 1 || test_case > AT_TEST_CASE_NUM)
{
printf ("ACPICA API TS err: test case %ld is out of range 1 - %d\n",
- test_case, AT_TEST_CASE_NUM);
+ (long int) test_case, (int) AT_TEST_CASE_NUM);
return (AtRetBadParam);
}
@@ -468,7 +468,7 @@ main(
if (test_num < 0 || test_num > AtTestCase[test_case].TestsNum)
{
printf ("ACPICA API TS err: test num %ld is out of range 0 - %d\n",
- test_num, AtTestCase[test_case].TestsNum);
+ (long int) test_num, AtTestCase[test_case].TestsNum);
return (AtRetBadParam);
}
Index: src/tests/aapits/atnamespace.c
===================================================================
--- src.orig/tests/aapits/atnamespace.c
+++ src/tests/aapits/atnamespace.c
@@ -2535,7 +2535,8 @@ AtGetObjectInfoTypeCommon(
#else
printf ("API Error: Address of %s (0x%llX) != (0x%llX)\n",
PathNames[2 * i + 1],
- Info->Address, ExpectedInfo[i].Address);
+ (long long unsigned int) Info->Address,
+ (long long unsigned int) ExpectedInfo[i].Address);
#endif
#else
printf ("API Error: Address of %s (0x%X) != (0x%X)\n",
@@ -2908,7 +2909,8 @@ AtGetNextObjectTypeCommon(
TestErrors++;
printf ("AtGetNextObjectTypeCommon: different numbers of entities"
"in TypesNames (%d) and LevelTypes0000 (%d)\n",
- TypesCount, sizeof (LevelTypes0000) / sizeof (ACPI_OBJECT_TYPE));
+ TypesCount,
+ (int) (sizeof (LevelTypes0000) / sizeof (ACPI_OBJECT_TYPE)));
return (AE_ERROR);
}
@@ -4192,7 +4194,9 @@ AtCheckHandlePathMapping(
Pathname, Obj.Integer.Value, Value);
#else
printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n",
- Pathname, Obj.Integer.Value, Value);
+ Pathname,
+ (long long unsigned int) Obj.Integer.Value,
+ (long long unsigned int) Value);
#endif
Status = AE_ERROR;
}
@@ -5199,7 +5203,7 @@ AtGetNameExceptionTest(
{
AapiErrors++;
printf ("API Error: AcpiOsAllocate(%d) returned NULL\n",
- OutName.Length);
+ (int) OutName.Length);
return (AE_ERROR);
}
}
Index: src/tests/aapits/atosxfctrl.c
===================================================================
--- src.orig/tests/aapits/atosxfctrl.c
+++ src/tests/aapits/atosxfctrl.c
@@ -737,13 +737,15 @@ ACPI_OSXF_EMUL_REG
#if ACPI_MACHINE_WIDTH == 64
#ifdef _MSC_VER
printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%I64x\n",
+ Width, Address);
#else
printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%llx\n",
+ Width, (long long unsigned int) Address);
#endif
#else
printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%x\n",
-#endif
Width, Address);
+#endif
return (NULL);
}
@@ -764,15 +766,19 @@ ACPI_OSXF_EMUL_REG
#ifdef _MSC_VER
printf("OsxfCtrlFingReg: intersection Regs (0x%I64x: 0x%x)"
" and (0x%I64x: 0x%x)\n",
+ Reg->Address, Reg->Width, Address, Width);
#else
printf("OsxfCtrlFingReg: intersection Regs (0x%llx: 0x%x)"
" and (0x%llx: 0x%x)\n",
+ (long long unsigned int) Reg->Address,
+ Reg->Width,
+ (long long unsigned int) Address, Width);
#endif
#else
printf("OsxfCtrlFingReg: intersection Regs (0x%x: 0x%x)"
" and (0x%x: 0x%x)\n",
-#endif
Reg->Address, Reg->Width, Address, Width);
+#endif
return (NULL);
}
}
@@ -786,13 +792,15 @@ ACPI_OSXF_EMUL_REG
#if ACPI_MACHINE_WIDTH == 64
#ifdef _MSC_VER
printf("OsxfCtrlFingReg: no memory for Reg (0x%I64x: 0x%x)\n",
+ Reg->Address, Reg->Width);
#else
printf("OsxfCtrlFingReg: no memory for Reg (0x%llx: 0x%x)\n",
+ (long long unsigned int) Reg->Address, Reg->Width);
#endif
#else
printf("OsxfCtrlFingReg: no memory for Reg (0x%x: 0x%x)\n",
-#endif
Reg->Address, Reg->Width);
+#endif
return (NULL);
}
Reg->Type = Type;
@@ -932,14 +940,19 @@ OsxfCtrlRegService(UINT32 ServiceFlag)
#if ACPI_MACHINE_WIDTH == 64
#ifdef _MSC_VER
printf("%.2u (%s Address 0x%I64x: Width %.2u) r/w counts: %u/%u\n",
+ i, (Reg->Type == EMUL_REG_SYS)? "SYS": "IO",
+ Reg->Address, Reg->Width, Reg->ReadCount, Reg->WriteCount);
#else
printf("%.2u (%s Address 0x%llx: Width %.2u) r/w counts: %u/%u\n",
+ i, (Reg->Type == EMUL_REG_SYS)? "SYS": "IO",
+ (long long unsigned int) Reg->Address,
+ Reg->Width, Reg->ReadCount, Reg->WriteCount);
#endif
#else
printf("%.2u (%s Address 0x%.4x: Width %.2u) r/w counts: %u/%u\n",
-#endif
i, (Reg->Type == EMUL_REG_SYS)? "SYS": "IO",
Reg->Address, Reg->Width, Reg->ReadCount, Reg->WriteCount);
+#endif
Reg = Reg->Next;
i++;
}
Index: src/tests/aapits/atresource.c
===================================================================
--- src.orig/tests/aapits/atresource.c
+++ src/tests/aapits/atresource.c
@@ -174,7 +174,7 @@ AtRsrcTest0000(void)
AapiErrors++;
printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d,"
" expected %d\n",
- Pathname, OutBuffer.Length, RT0000_DEV0_CRS_LEN);
+ Pathname, (int) OutBuffer.Length, RT0000_DEV0_CRS_LEN);
return (AE_ERROR);
}
@@ -490,7 +490,7 @@ AtRsrcTest0005(void)
AapiErrors++;
printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d,"
" expected %d\n",
- Pathname, OutBuffer.Length, RT0000_DEV0_CRS_LEN);
+ Pathname, (int) OutBuffer.Length, RT0000_DEV0_CRS_LEN);
return (AE_ERROR);
}
@@ -689,7 +689,7 @@ AtRsrcTest0007(void)
AapiErrors++;
printf ("Api Error: Resource->Length (%d) != %d\n",
CurrentResource->Length,
- ACPI_ROUND_UP_TO_NATIVE_WORD (ACPI_RS_SIZE (ACPI_RESOURCE_IRQ)));
+ (int) (ACPI_ROUND_UP_TO_NATIVE_WORD (ACPI_RS_SIZE (ACPI_RESOURCE_IRQ))));
}
if (CurrentResource->Data.Irq.Triggering != 0) /* Level-Triggered */
@@ -981,7 +981,7 @@ AtRsrcTest0012(void)
AapiErrors++;
printf ("API Error: AcpiGetPossibleResources(%s) returned Length %d,"
" expected %d\n",
- Pathname, OutBuffer.Length, RT0000_DEV0_CRS_LEN);
+ Pathname, (int) OutBuffer.Length, RT0000_DEV0_CRS_LEN);
return (AE_ERROR);
}
@@ -1923,7 +1923,7 @@ AtRsrcTest0026(void)
AapiErrors++;
printf ("API Error: AcpiGetIrqRoutingTable(%s) returned Length %d,"
" expected %d\n",
- Pathname, OutBuffer.Length, 0xA48);
+ Pathname, (int) OutBuffer.Length, 0xA48);
return (AE_ERROR);
}

View File

@ -1,35 +0,0 @@
diff -Naur acpica-unix2-20150717/tests/aapits/Makefile acpica-unix2-20150717-aapits/tests/aapits/Makefile
--- acpica-unix2-20150717/tests/aapits/Makefile 2015-07-17 10:05:11.000000000 -0600
+++ acpica-unix2-20150717-aapits/tests/aapits/Makefile 2015-08-05 10:20:14.776322314 -0600
@@ -31,6 +31,7 @@
../../source/components/debugger/dbinput.c \
../../source/components/debugger/dbmethod.c \
../../source/components/debugger/dbnames.c \
+ ../../source/components/debugger/dbobject.c \
../../source/components/debugger/dbstats.c \
../../source/components/debugger/dbtest.c \
../../source/components/debugger/dbutils.c \
@@ -39,7 +40,6 @@
../../source/components/disassembler/dmcstyle.c \
../../source/components/disassembler/dmdeferred.c \
../../source/components/disassembler/dmnames.c \
- ../../source/components/disassembler/dmobject.c \
../../source/components/disassembler/dmopcode.c \
../../source/components/disassembler/dmresrc.c \
../../source/components/disassembler/dmresrcl.c \
@@ -71,6 +71,7 @@
../../source/components/hardware/hwxfsleep.c \
../../source/components/dispatcher/dsargs.c \
../../source/components/dispatcher/dscontrol.c \
+ ../../source/components/dispatcher/dsdebug.c \
../../source/components/dispatcher/dsfield.c \
../../source/components/dispatcher/dsinit.c \
../../source/components/dispatcher/dsmethod.c \
@@ -183,6 +184,7 @@
../../source/components/utilities/utmath.c \
../../source/components/utilities/utmisc.c \
../../source/components/utilities/utmutex.c \
+ ../../source/components/utilities/utnonansi.c \
../../source/components/utilities/utobject.c \
../../source/components/utilities/utosi.c \
../../source/components/utilities/utownerid.c \

View File

@ -1,6 +1,6 @@
Name: acpica-tools
Version: 20150818
Release: 1%{?dist}
Release: 2%{?dist}
Summary: ACPICA tools for the development and debug of ACPI tables
Group: Development/Languages
@ -184,6 +184,9 @@ fi
%changelog
* Thu Sep 10 2015 Al Stone <ahs3@redhat.com> - 20150818-2
- Remove extraneous patch files for AAPITS.
* Wed Sep 9 2015 Al Stone <ahs3@redhat.com> - 20150818-1
- Update to latest upstream. Closes BZ#1256134.
- Refresh patches