Update to 20150818 sources
Signed-off-by: Al Stone <ahs3@redhat.com>
This commit is contained in:
parent
f3e7000ede
commit
0a7eb74d55
2
.gitignore
vendored
2
.gitignore
vendored
@ -34,3 +34,5 @@
|
||||
/acpitests-unix-20150619.tar.gz
|
||||
/acpitests-unix-20150717.tar.gz
|
||||
/acpica-unix2-20150717.tar.gz
|
||||
/acpica-unix2-20150818.tar.gz
|
||||
/acpitests-unix-20150818.tar.gz
|
||||
|
@ -1,5 +1,5 @@
|
||||
Name: acpica-tools
|
||||
Version: 20150717
|
||||
Version: 20150818
|
||||
Release: 1%{?dist}
|
||||
Summary: ACPICA tools for the development and debug of ACPI tables
|
||||
|
||||
@ -26,13 +26,12 @@ Source14: COPYING
|
||||
Patch0: debian-big_endian.patch
|
||||
Patch1: debian-unaligned.patch
|
||||
Patch2: name-miscompare.patch
|
||||
Patch3: aapits-linux.patch
|
||||
Patch4: asllookup-miscompare.patch
|
||||
Patch5: re-enable-big-endian.patch
|
||||
Patch6: OPT_LDFLAGS.patch
|
||||
Patch7: int-format.patch
|
||||
Patch8: f23-harden.patch
|
||||
Patch9: aapits-make.patch
|
||||
Patch3: asllookup-miscompare.patch
|
||||
Patch4: re-enable-big-endian.patch
|
||||
Patch5: OPT_LDFLAGS.patch
|
||||
Patch6: int-format.patch
|
||||
Patch7: f23-harden.patch
|
||||
Patch8: rename-file.patch
|
||||
|
||||
BuildRequires: bison patchutils flex
|
||||
|
||||
@ -85,13 +84,12 @@ gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
|
||||
%patch0 -p1 -b .debian-big_endian
|
||||
%patch1 -p1 -b .debian-unaligned
|
||||
%patch2 -p1 -b .name-miscompare
|
||||
%patch3 -p1 -b .aapits-linux
|
||||
%patch4 -p1 -b .asllookup-miscompare
|
||||
%patch5 -p1 -b .re-enable-big-endian
|
||||
%patch6 -p1 -b .OPT_LDFLAGS
|
||||
%patch7 -p1 -b .int-format
|
||||
%patch8 -p1 -b .f23-harden
|
||||
%patch9 -p1 -b .aapits-make
|
||||
%patch3 -p1 -b .asllookup-miscompare
|
||||
%patch4 -p1 -b .re-enable-big-endian
|
||||
%patch5 -p1 -b .OPT_LDFLAGS
|
||||
%patch6 -p1 -b .int-format
|
||||
%patch7 -p1 -b .f23-harden
|
||||
%patch8 -p1 -b .rename-file
|
||||
|
||||
cp -p %{SOURCE2} README.Fedora
|
||||
cp -p %{SOURCE3} iasl.1
|
||||
@ -139,16 +137,6 @@ cd tests
|
||||
./aslts.sh # relies on non-zero exit
|
||||
[ $? -eq 0 ] || exit 1
|
||||
|
||||
# API tests
|
||||
cd aapits
|
||||
make
|
||||
cd asl
|
||||
ASL=%{buildroot}%{_bindir}/iasl make
|
||||
cd ../bin
|
||||
./aapitsrun
|
||||
[ $? -eq 0 ] || exit 1
|
||||
cd ../..
|
||||
|
||||
# misc tests
|
||||
./run-misc-tests.sh %{buildroot}%{_bindir} %{version}
|
||||
|
||||
@ -196,6 +184,16 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Sep 9 2015 Al Stone <ahs3@redhat.com> - 20150818-1
|
||||
- Update to latest upstream. Closes BZ#1256134.
|
||||
- Refresh patches
|
||||
- This version deprecates aapits (ACPICA API Test Suite) for now; this is
|
||||
in accordance with upstream wishes, but in this maintainer's view, may
|
||||
not be the correct long term solution as there is no other API specific
|
||||
test suite.
|
||||
- Add a patch to rename source/tools/acpinames/AcpiNames.h to remove the
|
||||
camel case; this is a leftover in the conversion to Un*x files.
|
||||
|
||||
* Tue Aug 4 2015 Al Stone <ahs3@redhat.com> - 20150717-1
|
||||
- Update to latest upstream. Closes BZ#1244449.
|
||||
- Refresh patches
|
||||
|
@ -15,7 +15,7 @@ Index: src/generate/unix/iasl/Makefile
|
||||
===================================================================
|
||||
--- src.orig/generate/unix/iasl/Makefile
|
||||
+++ src/generate/unix/iasl/Makefile
|
||||
@@ -302,20 +302,21 @@ $(OBJDIR)/prparserparse.c : $(ASL_COM
|
||||
@@ -303,20 +303,21 @@ $(OBJDIR)/prparserparse.c : $(ASL_COM
|
||||
# Cannot use the common compile warning flags since the C files are created
|
||||
# by the utilities above and they are not necessarily ANSI C, etc.
|
||||
#
|
||||
|
@ -15,7 +15,7 @@ Index: src/source/tools/acpiexec/aemain.c
|
||||
===================================================================
|
||||
--- src.orig/source/tools/acpiexec/aemain.c
|
||||
+++ src/source/tools/acpiexec/aemain.c
|
||||
@@ -197,7 +197,7 @@ AeDoOptions (
|
||||
@@ -203,7 +203,7 @@ AeDoOptions (
|
||||
|
||||
if (strlen (AcpiGbl_Optarg) > (AE_BUFFER_SIZE -1))
|
||||
{
|
||||
@ -51,9 +51,9 @@ Index: src/source/components/debugger/dbexec.c
|
||||
--- src.orig/source/components/debugger/dbexec.c
|
||||
+++ src/source/components/debugger/dbexec.c
|
||||
@@ -214,7 +214,7 @@ AcpiDbExecuteMethod (
|
||||
{
|
||||
ACPI_ERROR ((AE_INFO,
|
||||
"Possible overflow of internal debugger buffer (size 0x%X needed 0x%X)",
|
||||
"Possible overflow of internal debugger "
|
||||
"buffer (size 0x%X needed 0x%X)",
|
||||
- ACPI_DEBUG_BUFFER_SIZE, (UINT32) ReturnObj->Length));
|
||||
+ (UINT32) ACPI_DEBUG_BUFFER_SIZE, (UINT32) ReturnObj->Length));
|
||||
}
|
||||
|
@ -6,7 +6,7 @@ Index: src/source/compiler/aslmain.c
|
||||
===================================================================
|
||||
--- src.orig/source/compiler/aslmain.c
|
||||
+++ src/source/compiler/aslmain.c
|
||||
@@ -336,18 +336,6 @@ main (
|
||||
@@ -339,18 +339,6 @@ main (
|
||||
int ReturnStatus = 0;
|
||||
|
||||
|
||||
|
124
rename-file.patch
Normal file
124
rename-file.patch
Normal file
@ -0,0 +1,124 @@
|
||||
diff -Naur acpica-unix2-20150818/source/tools/acpinames/acpinames.h acpica-unix2-20150818.fixes/source/tools/acpinames/acpinames.h
|
||||
--- acpica-unix2-20150818/source/tools/acpinames/acpinames.h 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ acpica-unix2-20150818.fixes/source/tools/acpinames/acpinames.h 2015-09-09 17:40:12.850371450 -0600
|
||||
@@ -0,0 +1,58 @@
|
||||
+/******************************************************************************
|
||||
+ *
|
||||
+ * Module Name: acpinames.h - Common include for AcpiNames utility
|
||||
+ *
|
||||
+ *****************************************************************************/
|
||||
+
|
||||
+/*
|
||||
+ * Copyright (C) 2000 - 2015, Intel Corp.
|
||||
+ * All rights reserved.
|
||||
+ *
|
||||
+ * Redistribution and use in source and binary forms, with or without
|
||||
+ * modification, are permitted provided that the following conditions
|
||||
+ * are met:
|
||||
+ * 1. Redistributions of source code must retain the above copyright
|
||||
+ * notice, this list of conditions, and the following disclaimer,
|
||||
+ * without modification.
|
||||
+ * 2. Redistributions in binary form must reproduce at minimum a disclaimer
|
||||
+ * substantially similar to the "NO WARRANTY" disclaimer below
|
||||
+ * ("Disclaimer") and any redistribution must be conditioned upon
|
||||
+ * including a substantially similar Disclaimer requirement for further
|
||||
+ * binary redistribution.
|
||||
+ * 3. Neither the names of the above-listed copyright holders nor the names
|
||||
+ * of any contributors may be used to endorse or promote products derived
|
||||
+ * from this software without specific prior written permission.
|
||||
+ *
|
||||
+ * Alternatively, this software may be distributed under the terms of the
|
||||
+ * GNU General Public License ("GPL") version 2 as published by the Free
|
||||
+ * Software Foundation.
|
||||
+ *
|
||||
+ * NO WARRANTY
|
||||
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
+ * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
+ * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR
|
||||
+ * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||
+ * HOLDERS OR CONTRIBUTORS BE LIABLE FOR SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
|
||||
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
|
||||
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
|
||||
+ * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
|
||||
+ * IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
|
||||
+ * POSSIBILITY OF SUCH DAMAGES.
|
||||
+ */
|
||||
+
|
||||
+#ifndef _ACPINAMES_H
|
||||
+#define _ACPINAMES_H
|
||||
+
|
||||
+#include "acpi.h"
|
||||
+#include "accommon.h"
|
||||
+#include "acapps.h"
|
||||
+#include "acutils.h"
|
||||
+#include "../acpiexec/aecommon.h"
|
||||
+
|
||||
+#include <stdio.h>
|
||||
+
|
||||
+#define ACPI_MAX_INIT_TABLES (32)
|
||||
+
|
||||
+extern BOOLEAN AcpiGbl_NsLoadOnly;
|
||||
+#endif
|
||||
diff -Naur acpica-unix2-20150818/source/tools/acpinames/AcpiNames.h acpica-unix2-20150818.fixes/source/tools/acpinames/AcpiNames.h
|
||||
--- acpica-unix2-20150818/source/tools/acpinames/AcpiNames.h 2015-08-18 14:11:26.000000000 -0600
|
||||
+++ acpica-unix2-20150818.fixes/source/tools/acpinames/AcpiNames.h 1969-12-31 17:00:00.000000000 -0700
|
||||
@@ -1,58 +0,0 @@
|
||||
-/******************************************************************************
|
||||
- *
|
||||
- * Module Name: acpinames.h - Common include for AcpiNames utility
|
||||
- *
|
||||
- *****************************************************************************/
|
||||
-
|
||||
-/*
|
||||
- * Copyright (C) 2000 - 2015, Intel Corp.
|
||||
- * All rights reserved.
|
||||
- *
|
||||
- * Redistribution and use in source and binary forms, with or without
|
||||
- * modification, are permitted provided that the following conditions
|
||||
- * are met:
|
||||
- * 1. Redistributions of source code must retain the above copyright
|
||||
- * notice, this list of conditions, and the following disclaimer,
|
||||
- * without modification.
|
||||
- * 2. Redistributions in binary form must reproduce at minimum a disclaimer
|
||||
- * substantially similar to the "NO WARRANTY" disclaimer below
|
||||
- * ("Disclaimer") and any redistribution must be conditioned upon
|
||||
- * including a substantially similar Disclaimer requirement for further
|
||||
- * binary redistribution.
|
||||
- * 3. Neither the names of the above-listed copyright holders nor the names
|
||||
- * of any contributors may be used to endorse or promote products derived
|
||||
- * from this software without specific prior written permission.
|
||||
- *
|
||||
- * Alternatively, this software may be distributed under the terms of the
|
||||
- * GNU General Public License ("GPL") version 2 as published by the Free
|
||||
- * Software Foundation.
|
||||
- *
|
||||
- * NO WARRANTY
|
||||
- * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
- * "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
- * LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR
|
||||
- * A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||
- * HOLDERS OR CONTRIBUTORS BE LIABLE FOR SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
|
||||
- * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
|
||||
- * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||
- * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
|
||||
- * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
|
||||
- * IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
|
||||
- * POSSIBILITY OF SUCH DAMAGES.
|
||||
- */
|
||||
-
|
||||
-#ifndef _ACPINAMES_H
|
||||
-#define _ACPINAMES_H
|
||||
-
|
||||
-#include "acpi.h"
|
||||
-#include "accommon.h"
|
||||
-#include "acapps.h"
|
||||
-#include "acutils.h"
|
||||
-#include "../acpiexec/aecommon.h"
|
||||
-
|
||||
-#include <stdio.h>
|
||||
-
|
||||
-#define ACPI_MAX_INIT_TABLES (32)
|
||||
-
|
||||
-extern BOOLEAN AcpiGbl_NsLoadOnly;
|
||||
-#endif
|
Loading…
Reference in New Issue
Block a user