import SLOF-20191022-3.git899d9883.module+el8.3.0+6423+e4cb6418

This commit is contained in:
CentOS Sources 2020-06-09 20:51:03 +00:00 committed by Stepan Oksanichenko
commit f0316b670f
5 changed files with 580 additions and 0 deletions

1
.SLOF.metadata Normal file
View File

@ -0,0 +1 @@
8b17e3cd9c6cd9ea46febee20738bc194405c83d SOURCES/qemu-slof-20191022.tar.gz

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/qemu-slof-20191022.tar.gz

View File

@ -0,0 +1,240 @@
From d53b544b88877a8a91a6579d54a2b384ee8a3715 Mon Sep 17 00:00:00 2001
From: David Gibson <dgibson@redhat.com>
Date: Tue, 7 Jan 2020 00:40:36 +0000
Subject: [PATCH 2/2] fdt: Fix updating the tree at H_CAS
RH-Author: David Gibson <dgibson@redhat.com>
Message-id: <20200107004037.421470-3-dgibson@redhat.com>
Patchwork-id: 93281
O-Subject: [RHEL-AV-8.2.0 SLOF PATCH 2/2] fdt: Fix updating the tree at H_CAS
Bugzilla: 1778704
RH-Acked-by: Laurent Vivier <lvivier@redhat.com>
RH-Acked-by: Thomas Huth <thuth@redhat.com>
RH-Acked-by: Miroslav Rezanina <mrezanin@redhat.com>
From: Alexey Kardashevskiy <aik@ozlabs.ru>
The previous approach to merge the QEMU FDT into the existing tree and
then patch it turned to be broken as we patch properties based on their
names only so we patch not just what QEMU provides (which was
the intention) but also all properties SLOF created. This breaks one of
them - "interrupt-map" - it is created by QEMU for a PHB but SLOF creates
it for PCI bridges and since they have different sizes, patching phandles
at fixed offset fails.
Rather than skipping certain nodes in the SLOF tree, this uses different
approach: now we read the QEMU FDT in 3 passes:
1. find all phandle/linux-phandle properties and store these in the SLOF
internal tree to allow phandle->node lookup later;
2. walk through all FDT properties, patch them if needed using
phandles from the SLOF tree and save patched values in SLOF properties;
3. delete phandle/linux-phandle properties created in 1. This is safe
as SLOF does not create these properties anyway.
Fixes: 44d06f9e68cf ("fdt: Update phandles after H_CAS")
Signed-off-by: Alexey Kardashevskiy <aik@ozlabs.ru>
(cherry picked from commit 497f61400d3b10cde3f2bd98201bf99441ec0eae)
Signed-off-by: David Gibson <dgibson@redhat.com>
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
---
board-qemu/slof/archsupport.fs | 1 -
board-qemu/slof/fdt.fs | 123 +++++++++++++++++++++++++++++++++++++++--
2 files changed, 117 insertions(+), 7 deletions(-)
diff --git a/board-qemu/slof/archsupport.fs b/board-qemu/slof/archsupport.fs
index 6512d57..fc48830 100644
--- a/board-qemu/slof/archsupport.fs
+++ b/board-qemu/slof/archsupport.fs
@@ -33,7 +33,6 @@
fdt-check-header
fdt-struct fdt-fix-cas-node
fdt-fix-cas-success NOT ( memaddr err? )
- s" /" find-node fdt-fix-phandles
ELSE
FALSE
THEN
diff --git a/board-qemu/slof/fdt.fs b/board-qemu/slof/fdt.fs
index 5ece270..fc39a82 100644
--- a/board-qemu/slof/fdt.fs
+++ b/board-qemu/slof/fdt.fs
@@ -12,6 +12,7 @@
0 VALUE fdt-debug
TRUE VALUE fdt-cas-fix?
+0 VALUE fdt-cas-pass
\ Bail out if no fdt
fdt-start 0 = IF -1 throw THEN
@@ -294,6 +295,81 @@ fdt-claim-reserve
2drop 2drop
;
+: (phandle>node) ( phandle current -- node|0 )
+ dup s" phandle" rot get-property 0= IF
+ decode-int nip nip ( phandle current phandle-prop )
+ 2 pick = IF
+ fdt-debug IF ." Found phandle; " dup . ." <= " over . cr THEN
+ nip ( current )
+ EXIT
+ THEN
+ ELSE
+ dup s" linux-phandle" rot get-property 0= IF
+ decode-int nip nip ( phandle current phandle-prop )
+ 2 pick = IF
+ fdt-debug IF ." Found linux-phandle; " dup . ." <= " over . cr THEN
+ nip ( current )
+ EXIT
+ THEN
+ THEN
+ THEN
+ child BEGIN
+ dup
+ WHILE
+ 2dup
+ RECURSE
+ ?dup 0<> IF
+ nip nip
+ EXIT
+ THEN
+ PEER
+ REPEAT
+ 2drop 0
+;
+
+: phandle>node ( phandle -- node ) s" /" find-node (phandle>node) ;
+
+: (fdt-patch-phandles) ( prop-addr prop-len -- )
+ BEGIN
+ dup
+ WHILE ( prop-addr prop-len )
+ over l@ phandle>node
+ ?dup 0<> IF
+ fdt-debug IF ." ### Patching phandle=" 2 pick l@ . cr THEN
+ 2 pick l!
+ TRUE TO (fdt-phandle-replaced)
+ THEN
+ 4 - swap 4 + swap
+ REPEAT
+ 2drop
+;
+
+: (fdt-patch-interrupt-map) ( prop-addr prop-len -- )
+ \ interrupt-controller phandle is expected to be the same accross the map
+ over 10 + l@ phandle>node ?dup 0= IF 2drop EXIT THEN
+ -rot
+ fdt-debug IF ." ### Patching interrupt-map: " over 10 + l@ . ." => " 2 pick . cr THEN
+
+ TRUE TO (fdt-phandle-replaced)
+ BEGIN
+ dup
+ WHILE ( newph prop-addr prop-len )
+ 2 pick 2 pick 10 + l!
+ 1c - swap 1c + swap
+ REPEAT
+ 3drop
+;
+
+: fdt-patch-phandles ( prop-addr prop-len nameadd namelen -- )
+ 2dup s" interrupt-map" str= IF 2drop (fdt-patch-interrupt-map) EXIT THEN
+ 2dup s" interrupt-parent" str= IF 2drop (fdt-patch-phandles) EXIT THEN
+ 2dup s" ibm,gpu" str= IF 2drop (fdt-patch-phandles) EXIT THEN
+ 2dup s" ibm,npu" str= IF 2drop (fdt-patch-phandles) EXIT THEN
+ 2dup s" ibm,nvlink" str= IF 2drop (fdt-patch-phandles) EXIT THEN
+ 2dup s" memory-region" str= IF 2drop (fdt-patch-phandles) EXIT THEN
+ 4drop
+;
+
\ Replace one phandle "old" with a phandle "new" in "node" and recursively
\ in its child nodes:
: fdt-replace-all-phandles ( old new node -- )
@@ -394,6 +470,12 @@ r> drop
find-node ?dup 0 <> IF set-node THEN
;
+: str=phandle? ( s len -- true|false )
+ 2dup s" phandle" str= >r
+ s" linux,phandle" str=
+ r> or
+;
+
: (fdt-fix-cas-node) ( start -- end )
recursive
fdt-next-tag dup OF_DT_BEGIN_NODE <> IF
@@ -414,7 +496,7 @@ r> drop
2dup find-node ?dup 0 <> IF
set-node 2drop
ELSE
- fdt-debug IF ." Node not found, creating " 2dup type cr THEN
+ fdt-debug IF ." Creating node: " 2dup type cr THEN
fdt-create-cas-node
THEN
fdt-debug IF ." Current now: " pwd cr THEN
@@ -422,22 +504,48 @@ r> drop
fdt-next-tag dup OF_DT_END_NODE <>
WHILE
dup OF_DT_PROP = IF
- fdt-debug IF ." Found property " cr THEN
drop dup ( drop tag, dup addr : a1 a1 )
dup l@ dup rot 4 + ( fetch size, stack is : a1 s s a2)
dup l@ swap 4 + ( fetch nameid, stack is : a1 s s i a3 )
rot ( we now have: a1 s i a3 s )
fdt-encode-prop rot ( a1 s pa ps i)
fdt-fetch-string ( a1 s pa ps na ns )
- property
- fdt-debug IF ." Setting property done " cr THEN
+
+ fdt-cas-pass CASE
+ 0 OF
+ 2dup str=phandle? IF
+ fdt-debug IF 4dup ." Phandle: " type ." =" swap ." @" . ." " .d ." bytes" cr THEN
+ property
+ ELSE
+ 4drop
+ THEN
+ ENDOF
+ 1 OF
+ 2dup str=phandle? not IF
+ fdt-debug IF 4dup ." Property: " type ." =" swap ." @" . ." " .d ." bytes" cr THEN
+ 4dup fdt-patch-phandles
+ property
+ ELSE
+ 4drop
+ THEN
+ ENDOF
+ 2 OF
+ 2dup str=phandle? IF
+ fdt-debug IF 4dup ." Deleting: " type ." =" swap ." @" . ." " .d ." bytes" cr THEN
+ delete-property
+ 2drop
+ ELSE
+ 4drop
+ THEN
+ ENDOF
+ ENDCASE
+
+ 8 + 3 + fffffffc and
ELSE dup OF_DT_BEGIN_NODE = IF
drop ( drop tag )
4 -
(fdt-fix-cas-node)
get-parent set-node
- fdt-debug IF ." Returning back " pwd cr THEN
ELSE
." Error " cr
drop
@@ -450,7 +558,10 @@ r> drop
;
: fdt-fix-cas-node ( start -- )
- (fdt-fix-cas-node) drop
+ 0 to fdt-cas-pass dup (fdt-fix-cas-node) drop \ Add phandles
+ 1 to fdt-cas-pass dup (fdt-fix-cas-node) drop \ Patch+add other properties
+ 2 to fdt-cas-pass dup (fdt-fix-cas-node) drop \ Delete phandles from pass 1
+ drop
;
: fdt-fix-cas-success
--
1.8.3.1

View File

@ -0,0 +1,96 @@
From 16b3bfa4f74942d9c2f49159715008d8d93c0f2d Mon Sep 17 00:00:00 2001
From: David Gibson <dgibson@redhat.com>
Date: Tue, 7 Jan 2020 00:40:35 +0000
Subject: [PATCH 1/2] ibm, client-architecture-support: Fix stack handling
RH-Author: David Gibson <dgibson@redhat.com>
Message-id: <20200107004037.421470-2-dgibson@redhat.com>
Patchwork-id: 93280
O-Subject: [RHEL-AV-8.2.0 SLOF PATCH 1/2] ibm, client-architecture-support: Fix stack handling
Bugzilla: 1778704
RH-Acked-by: Laurent Vivier <lvivier@redhat.com>
RH-Acked-by: Thomas Huth <thuth@redhat.com>
RH-Acked-by: Miroslav Rezanina <mrezanin@redhat.com>
From: Alexey Kardashevskiy <aik@ozlabs.ru>
fdt-fix-cas-node returns the end address after it's finished which
the caller (ibm,client-architecture-support) does not use or drop.
This renames fdt-fix-cas-node to (fdt-fix-cas-node) and adds a wrapper
on top of that which does the drop. This will be used later for 2-pass
tree patching.
While at this, exit the function if memory allocation failed.
Signed-off-by: Alexey Kardashevskiy <aik@ozlabs.ru>
(cherry picked from commit c50195e007319bf39c5315289ab93a2d7d02828b)
Signed-off-by: David Gibson <dgibson@redhat.com>
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
---
board-qemu/slof/archsupport.fs | 8 ++++++--
board-qemu/slof/fdt.fs | 8 ++++++--
2 files changed, 12 insertions(+), 4 deletions(-)
diff --git a/board-qemu/slof/archsupport.fs b/board-qemu/slof/archsupport.fs
index 33ea765..6512d57 100644
--- a/board-qemu/slof/archsupport.fs
+++ b/board-qemu/slof/archsupport.fs
@@ -18,7 +18,11 @@
\ to come back to right boot device
\ Allocate memory for H_CALL
cas-buffer-size alloc-mem ( vec memaddr )
- dup 0= IF ." out of memory during ibm,client-architecture-support" cr THEN
+ dup 0= IF
+ ." out of memory during ibm,client-architecture-support" cr
+ 2drop TRUE
+ EXIT
+ THEN
swap over cas-buffer-size ( memaddr vec memaddr size )
\ make h_call to hypervisor
hv-cas 0= IF ( memaddr )
@@ -28,7 +32,7 @@
dup 4 + fdt-init
fdt-check-header
fdt-struct fdt-fix-cas-node
- fdt-fix-cas-success NOT
+ fdt-fix-cas-success NOT ( memaddr err? )
s" /" find-node fdt-fix-phandles
ELSE
FALSE
diff --git a/board-qemu/slof/fdt.fs b/board-qemu/slof/fdt.fs
index 3e4c1b3..5ece270 100644
--- a/board-qemu/slof/fdt.fs
+++ b/board-qemu/slof/fdt.fs
@@ -394,7 +394,7 @@ r> drop
find-node ?dup 0 <> IF set-node THEN
;
-: fdt-fix-cas-node ( start -- end )
+: (fdt-fix-cas-node) ( start -- end )
recursive
fdt-next-tag dup OF_DT_BEGIN_NODE <> IF
." Error " cr
@@ -435,7 +435,7 @@ r> drop
ELSE dup OF_DT_BEGIN_NODE = IF
drop ( drop tag )
4 -
- fdt-fix-cas-node
+ (fdt-fix-cas-node)
get-parent set-node
fdt-debug IF ." Returning back " pwd cr THEN
ELSE
@@ -449,6 +449,10 @@ r> drop
drop \ drop tag
;
+: fdt-fix-cas-node ( start -- )
+ (fdt-fix-cas-node) drop
+;
+
: fdt-fix-cas-success
fdt-cas-fix?
;
--
1.8.3.1

242
SPECS/SLOF.spec Normal file
View File

@ -0,0 +1,242 @@
%define GITDATE 20191022
%define GITCOMMIT 899d9883
%global debug_package %{nil}
Name: SLOF
Version: %{GITDATE}
Release: 3.git%{GITCOMMIT}%{?dist}
Summary: Slimline Open Firmware
Group: Applications/Emulators
License: BSD
URL: http://www.openfirmware.info/SLOF
Source0: https://github.com/aik/SLOF/archive/qemu-slof-20191022.tar.gz
# For bz#1778704 - Guest failed to boot up with device under pci-bridge
Patch2: slof-ibm-client-architecture-support-Fix-stack-handling.patch
# For bz#1778704 - Guest failed to boot up with device under pci-bridge
Patch3: slof-fdt-Fix-updating-the-tree-at-H_CAS.patch
BuildArch: noarch
ExclusiveArch: %{power64}
BuildRequires: binutils
BuildRequires: perl(Data::Dumper)
%description
Slimline Open Firmware (SLOF) is initialization and boot source code
based on the IEEE-1275 (Open Firmware) standard, developed by
engineers of the IBM Corporation.
The SLOF source code provides illustrates what's needed to initialize
and boot Linux or a hypervisor on the industry Open Firmware boot
standard.
Note that you normally wouldn't need to install this package
separately. It is a dependency of qemu-system-ppc64.
%prep
%setup -q -n SLOF-qemu-slof-%{GITDATE}
%autopatch -p1
%build
export CROSS=""
# Workaround for problems on the TPS machines. They have a
# environment variable called "RELEASE" which somehow confuses the
# SLOF Makefiles which also use a variable named RELEASE.
unset RELEASE
make qemu %{?_smp_mflags} V=2
%install
mkdir -p $RPM_BUILD_ROOT%{_datadir}/qemu-kvm
install -c -m 0644 boot_rom.bin $RPM_BUILD_ROOT%{_datadir}/qemu-kvm/slof.bin
%files
%doc LICENSE
%doc README
%dir %{_datadir}/qemu-kvm
%{_datadir}/qemu-kvm/slof.bin
%changelog
* Mon Apr 27 2020 Danilo C. L. de Paula <ddepaula@redhat.com> - 20191022
- Resolves: bz#1810193
(Upgrade components in virt:rhel module:stream for RHEL-8.3 release)
* Fri Jun 28 2019 Danilo de Paula <ddepaula@redhat.com> - 20171214-6.gitfa98132
- Rebuild all virt packages to fix RHEL's upgrade path
- Resolves: rhbz#1695587
(Ensure modular RPM upgrade path)
* Fri Jan 04 2019 Danilo Cesar Lemes de Paula <ddepaula@redhat.com> - 20171214-5.gitfa98132.el8
- slof-board-qemu-slof-vio-vscsi-Scan-up-to-64-SCSI-IDs.patch [bz#1655649]
- slof-usb-storage-Invert-the-logic-of-the-IF-statements.patch [bz#1654196]
- slof-usb-storage-Implement-block-write-support.patch [bz#1654196]
- Resolves: bz#1654196
([RHEL8.0][USB] guest failed to boot from emulated usb-storage)
- Resolves: bz#1655649
(RHEL8.0 - ISST-LTE:KVM:Failed to boot the guest from cdrom drive)
* Fri Aug 10 2018 Danilo Cesar Lemes de Paula <ddepaula@redhat.com> - 20171214-4.gitfa98132.el8
- slof-libelf-Add-REL32-to-the-list-of-ignored-relocations.patch [bz#1613619]
- slof-Fix-bad-assembler-statements-for-compiling-with-gcc-.patch [bz#1613619]
- slof-make.rules-Compile-SLOF-with-fno-asynchronous-unwind.patch [bz#1613619]
- slof-romfs-tools-Remove-superfluous-union-around-the-rom-.patch [bz#1613619]
- slof-romfs-tools-Silence-GCC-8.1-compiler-warning-with-FL.patch [bz#1613619]
- slof-romfs-tools-Silence-more-compiler-warnings-with-GCC-.patch [bz#1613619]
- Resolves: bz#1613619
([RHEL8.0]Console contains error message (ERROR: Unhandled relocation (A) type 26) after continuing a guest)
- Resolves: bz#1600154
(SLOF needs to be build in power hosts)
* Wed Jul 11 2018 Danilo Cesar Lemes de Paula - 20171214-3.gitfa98132.el8
- Release to RHEL-8.0
* Fri Jun 01 2018 Miroslav Rezanina <mrezanin@redhat.com> - 20171214-2.gitfa98132.el7
- slof-Fix-output-word.patch [bz#1495467]
- slof-resolve-ihandle-and-xt-handle-in-the-input-command-l.patch [bz#1495467]
- Resolves: bz#1495467
(SLOF does not honour output-path environment variable)
* Wed Apr 18 2018 Miroslav Rezanina <mrezanin@redhat.com> - 20171214-1.gitfa98132.el7
- Rebase to qemu-slof-20171214 [bz#1562106]
- Resolves: bz#1562106
(Rebase SLOF for RHEL-7.6)
* Mon Oct 09 2017 Miroslav Rezanina <mrezanin@redhat.com> - 20170724-2.git89f519f.el7
- slof-virtio-net-rework-the-driver-to-support-multiple-ope.patch [bz#1477937]
- Resolves: bz#1477937
(VM fails to boot at SLOF prompt with "Out of internal memory." with lots of virtio-net-pci devices)
* Mon Oct 02 2017 Miroslav Rezanina <mrezanin@redhat.com> - 20170724-1.git89f519f.el7
- Rebase to qemu-slof-20170724 [bz#1471284]
- Resolves: bz#1471284
(Rebase SLOF for RHEL-7.5)
* Fri May 19 2017 Miroslav Rezanina <mrezanin@redhat.com> - 20170303-4.git66d250e.el7
- slof-pci-Reserve-free-space-at-the-end-of-bridge-windows-.patch [bz#1443433]
- Resolves: bz#1443433
([ppc64le] Guest failed to boot up with 8 nested pci-bridge)
* Fri May 05 2017 Miroslav Rezanina <mrezanin@redhat.com> - 20170303-3.git66d250e.el7
- slof-pci-Put-non-prefetchable-64bit-BARs-into-32bit-MMIO-.patch [bz#1442930]
- slof-pci-Fix-assigned-addresses-for-64bit-nonprefetchable.patch [bz#1442930]
- slof-pci-phb-Set-pci-max-mem64-to-the-correct-value.patch [bz#1442930]
- slof-pci-Generate-a-64-bit-range-property-if-necessary.patch [bz#1442930]
- Resolves: bz#1442930
([ppc64le] BARs are incorrectly assigned for some devices under P2P bridges)
* Fri Apr 28 2017 Miroslav Rezanina <mrezanin@redhat.com> - 20170303-2.git66d250e.el7
- slof-logo-Update-the-logo.patch [bz#1443904]
- slof-Rework-the-printing-of-the-banner-during-boot.patch [bz#1443904]
- Resolves: bz#1443904
(SLOF user interface display bootable device and "SLOF" words duplicate)
* Thu Mar 09 2017 Miroslav Rezanina <mrezanin@redhat.com> - 20170303-0.git66d250e.el7
- Rebaes to SLOF version used by QEMU 2.9 [bz#1392055]
- Resolves: bz#1392055
(Rebase SLOF for RHEL-7.4)
* Fri Aug 05 2016 Miroslav Rezanina <mrezanin@redhat.com> - 20160223-6.gitdbbfda4.el7
- slof-usb-Move-XHCI-port-state-arrays-from-header-to-.c-fi.patch [bz#1352765]
- slof-usb-Increase-amount-of-maximum-slot-IDs-and-add-a-sa.patch [bz#1352765]
- slof-usb-Initialize-USB3-devices-on-a-hub-and-keep-track-.patch [bz#1352765]
- slof-usb-Build-correct-route-string-for-USB3-devices-behi.patch [bz#1352765]
- slof-usb-Set-XHCI-slot-speed-according-to-port-status.patch [bz#1352765]
- Resolves: bz#1352765
(SLOF can not handle devices attached to an XHCI USB hub)
* Tue Jul 26 2016 Miroslav Rezanina <mrezanin@redhat.com> - 20160223-5.gitdbbfda4.el7
- slof-usb-hid-Fix-non-working-comma-key.patch [bz#1352821]
- Resolves: bz#1352821
(Key "," can not be inputted during SLOF and yaboot stage)
* Tue Jun 07 2016 Miroslav Rezanina <mrezanin@redhat.com> - 20160223-4.gitdbbfda4.el7
- slof-xhci-add-memory-barrier-after-filling-the-trb.patch [bz#1339528]
- slof-xhci-fix-missing-keys-from-keyboard.patch [bz#1339528]
- slof-Improve-F12-key-handling-in-boot-menu.patch [bz#1339528]
- Resolves: bz#1339528
(SLOF boot menu gets delayed if press 'F12' key for multiple times)
* Wed May 11 2016 Miroslav Rezanina <mrezanin@redhat.com> - 20160223-3.gitdbbfda4.el7
- slof-ipv6-Do-not-use-unitialized-MAC-address-array.patch [bz#1287716]
- slof-ipv6-send_ipv6-has-to-return-after-doing-NDP.patch [bz#1287716]
- slof-ipv6-Fix-possible-NULL-pointer-dereference-in-send_i.patch [bz#1287716]
- slof-ipv6-Clear-memory-after-malloc-if-necessary.patch [bz#1287716]
- slof-ipv6-Fix-memory-leak-in-set_ipv6_address-ip6_create_.patch [bz#1287716]
- slof-ipv6-Indent-code-with-tabs-not-with-spaces.patch [bz#1287716]
- slof-ipv6-Fix-NULL-pointer-dereference-in-ip6addr_add.patch [bz#1287716]
- slof-ipv6-Replace-magic-number-1500-with-ETH_MTU_SIZE-i.e.patch [bz#1287716]
- Resolves: bz#1287716
(IPv6 boot support in SLOF)
* Fri May 06 2016 Miroslav Rezanina <mrezanin@redhat.com> - 20160223-2.gitdbbfda4.el7
- slof-dev-null-The-read-function-has-to-return-0-if-nothin.patch [bz#1310737]
- slof-ipv6-Add-support-for-sending-packets-through-a-route.patch [bz#1301081]
- slof-virtio-net-initialize-to-populate-mac-address.patch [bz#1331698]
- Resolves: bz#1301081
(IPv6 boot does not work in SLOF when TFTP server is behind a router)
- Resolves: bz#1310737
(SLOF cannot boot without a console)
- Resolves: bz#1331698
(Network booting in grub fails when using virtio-net and SLOF-20160223-0)
* Fri Sep 18 2015 Miroslav Rezanina <mrezanin@redhat.com> - 20150313-5.gitc89b0df.el7
- slof-pci-Use-QEMU-created-PCI-device-nodes.patch [bz#1250326]
- Resolves: bz#1250326
(vfio device can't be hot unplugged on powerpc guest)
* Wed Sep 16 2015 Miroslav Rezanina <mrezanin@redhat.com> - 20150313-4.gitc89b0df.el7
- slof-cas-Increase-FDT-buffer-size-to-accomodate-larger-ib.patch [bz#1263039]
- slof-Downstream-only-Correctly-set-ibm-my-drc-index.patch [bz#1250326]
- Resolves: bz#1250326
(vfio device can't be hot unplugged on powerpc guest)
- Resolves: bz#1263039
(SLOF doesn't allow enough room for CAS response with large maxmem)
* Thu Aug 06 2015 Miroslav Rezanina <mrezanin@redhat.com> - 20150313-3.gitc89b0df.el7
- slof-fbuffer-Improve-invert-region-helper.patch [bz#1237052]
- slof-fbuffer-Use-a-smaller-cursor.patch [bz#1237052]
- slof-terminal-Disable-the-terminal-write-trace-by-default.patch [bz#1237052]
- slof-fbuffer-Precalculate-line-length-in-bytes.patch [bz#1237052]
- slof-fbuffer-Implement-MRMOVE-as-an-accelerated-primitive.patch [bz#1237052]
- slof-fbuffer-Implement-RFILL-as-an-accelerated-primitive.patch [bz#1237052]
- slof-Add-missing-half-word-access-case-to-_FASTRMOVE-and-.patch [bz#1237052]
- Resolves: bz#1237052
(Curser movement issue - the curser would move right and left before get its position in grub interface of a qemu-kvm guest)
* Tue Jun 09 2015 Miroslav Rezanina <mrezanin@redhat.com> - 20150313-2.gitc89b0df.el7
- slof-fbuffer-simplify-address-computations-in-fb8-toggle-.patch [bz#1212256]
- slof-fbuffer-introduce-the-invert-region-helper.patch [bz#1212256]
- slof-fbuffer-introduce-the-invert-region-x-helper.patch [bz#1212256]
- slof-spec-Remove-FlashingSLOF.pdf.patch [bz#1226264]
- Resolves: bz#1212256
([Power KVM] Grub interface of guest response slow)
- Resolves: bz#1226264
(Remove FlashingSLOF.pdf)
* Thu May 28 2015 Miroslav Rezanina <mrezanin@redhat.com> - 20150313-1.gitc89b0df
- rebase to 20150313 version
- Resolves: bz#1225720
(Update SLOF package to match current qemu-kvm-rhev package)
* Tue Jan 27 2015 Miroslav Rezanina <mrezanin@redhat.com> - 20140630-4.gitf284ab3
- slof-Downstream-only-Workaround-for-TPS-environment-oddit.patch [bz#1183927]
- Resolves: bz#1183927
(TPS srpm rebuild test failure for SLOF)
* Fri Nov 14 2014 Miroslav Rezanina <mrezanin@redhat.com> - 20140630-3.gitf284ab3
- slof-net-snk-use-socket-descriptor-in-the-network-stack.patch [bz#1158217]
- slof-ipv4-Fix-send-packet-across-a-subnet.patch [bz#1158217]
- Resolves: bz#1158217
(SLOF can not reach tftp server on different subnet)
* Thu Aug 28 2014 Miroslav Rezanina <mrezanin@redhat.com> - 20140630-2.gitf284ab3
- building as noarch
* Tue Jun 24 2014 Miroslav Rezanina <mrezanin@redhat.com> - 20140630-1.gitf284ab3
- Initial version