Package 0.13.72
- Fixes CVE-2020-18442 - Resolves: rhbz#1973831 - Switch build to CMake, drop 32-bit patches as checks integrated in CMake already Signed-off-by: Alexander Bokovoy <abokovoy@redhat.com>
This commit is contained in:
parent
4a515dd0a9
commit
79ad2633a3
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@ zziplib-0.13.49.tar.bz2
|
||||
/v0.13.68.tar.gz
|
||||
/v0.13.69.tar.gz
|
||||
/v0.13.71.tar.gz
|
||||
/v0.13.72.tar.gz
|
||||
|
@ -1,29 +0,0 @@
|
||||
--- ./a/zzip/_config.h 2021-07-21 14:18:09.000000000 +0200
|
||||
+++ ./b/zzip/_config.h 2021-07-21 14:46:24.037432969 +0200
|
||||
@@ -138,9 +138,12 @@
|
||||
|
||||
/* whether the system defaults to 32bit off_t but can do 64bit when requested
|
||||
*/
|
||||
+#if __WORDSIZE == 32
|
||||
#ifndef ZZIP_LARGEFILE_SENSITIVE
|
||||
#define ZZIP_LARGEFILE_SENSITIVE 1
|
||||
#endif
|
||||
+#endif
|
||||
+/* #undef LARGEFILE_SENSITIVE */
|
||||
|
||||
/* Define to the sub-directory where libtool stores uninstalled libraries. */
|
||||
#ifndef ZZIP_LT_OBJDIR
|
||||
@@ -227,9 +230,13 @@
|
||||
#endif
|
||||
|
||||
/* Number of bits in a file offset, on hosts where this is settable. */
|
||||
+#if __WORDSIZE == 32
|
||||
#ifndef ZZIP__FILE_OFFSET_BITS
|
||||
#define ZZIP__FILE_OFFSET_BITS 64
|
||||
#endif
|
||||
+#endif
|
||||
+/* #undef _FILE_OFFSET_BITS */
|
||||
+
|
||||
|
||||
/* Define for large files, on AIX-style hosts. */
|
||||
/* #undef _LARGE_FILES */
|
@ -1,29 +0,0 @@
|
||||
--- ./a/zzip/_config.h 2021-07-21 14:18:14.000000000 +0200
|
||||
+++ ./b/zzip/_config.h 2021-07-21 14:46:24.037432969 +0200
|
||||
@@ -138,6 +138,11 @@
|
||||
|
||||
/* whether the system defaults to 32bit off_t but can do 64bit when requested
|
||||
*/
|
||||
+#if __WORDSIZE == 32
|
||||
+#ifndef ZZIP_LARGEFILE_SENSITIVE
|
||||
+#define ZZIP_LARGEFILE_SENSITIVE 1
|
||||
+#endif
|
||||
+#endif
|
||||
/* #undef LARGEFILE_SENSITIVE */
|
||||
|
||||
/* Define to the sub-directory where libtool stores uninstalled libraries. */
|
||||
@@ -225,8 +230,14 @@
|
||||
#endif
|
||||
|
||||
/* Number of bits in a file offset, on hosts where this is settable. */
|
||||
+#if __WORDSIZE == 32
|
||||
+#ifndef ZZIP__FILE_OFFSET_BITS
|
||||
+#define ZZIP__FILE_OFFSET_BITS 64
|
||||
+#endif
|
||||
+#endif
|
||||
/* #undef _FILE_OFFSET_BITS */
|
||||
|
||||
+
|
||||
/* Define for large files, on AIX-style hosts. */
|
||||
/* #undef _LARGE_FILES */
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -19143,7 +19143,7 @@ Name: @PACKAGE_NAME@
|
||||
Description: @PACKAGE_DESCRIPTION@
|
||||
Version: @PACKAGE_VERSION@
|
||||
Requires: @PACKAGE_REQUIRES@
|
||||
-Libs: -L\${libdir} @LDFLAGS@ @LIBS@
|
||||
+Libs: -L\${libdir} @LIBS@
|
||||
Cflags: -I\${includedir} @CPPFLAGS@
|
||||
AXEOF
|
||||
fi # DONE generate $pkgconfig_generate.in
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (v0.13.71.tar.gz) = e035d0ac26dca78335ae3defc652543ff7b353a1a95d76ed1beeb21a08e16f287a62d488f528cfbb77d5b558581b68d439aa0823577524e9aa61a3cf5f208cb5
|
||||
SHA512 (v0.13.72.tar.gz) = 4bb089e74813c6fac9657cd96e44e4a6469bf86aba3980d885c4573e8db45e74fd07bbdfcec9f36297c72227c8c0b2c37dab1bc4326cef8529960e482fe501c8
|
||||
|
44
zziplib.spec
44
zziplib.spec
@ -1,15 +1,11 @@
|
||||
Summary: Lightweight library to easily extract data from zip files
|
||||
Name: zziplib
|
||||
Version: 0.13.71
|
||||
Release: 7%{?dist}
|
||||
Version: 0.13.72
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+ or MPLv1.1
|
||||
URL: http://zziplib.sourceforge.net/
|
||||
Source: https://github.com/gdraheim/zziplib/archive/v%{version}.tar.gz
|
||||
|
||||
Patch1: remove_ldflags_pkconfig_files.patch
|
||||
Patch100: multilib-32.patch
|
||||
Patch101: multilib-64.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
BuildRequires: perl-interpreter
|
||||
@ -20,8 +16,7 @@ BuildRequires: xmlto
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: SDL-devel
|
||||
BuildRequires: pkgconfig
|
||||
#BuildRequires: autoconf
|
||||
#BuildRequires: automake
|
||||
BuildRequires: cmake
|
||||
|
||||
%description
|
||||
The zziplib library is intentionally lightweight, it offers the ability to
|
||||
@ -62,35 +57,14 @@ zziplib library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
||||
%configure \
|
||||
--disable-static \
|
||||
--enable-sdl \
|
||||
--enable-frame-pointer
|
||||
# Remove rpath on 64bit archs
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
# Only patch generated _config.h on non-i686 and armv7hl
|
||||
# These platforms have a correct _config.h already
|
||||
|
||||
|
||||
pushd %{_builddir}/zziplib-%{version}
|
||||
%ifarch i686 armv7hl
|
||||
patch -p2 < %{PATCH100}
|
||||
%else
|
||||
patch -p2 < %{PATCH101}
|
||||
%endif
|
||||
popd
|
||||
|
||||
|
||||
%make_build
|
||||
%cmake -B "%{_vpath_builddir}"
|
||||
|
||||
%make_build -C "%{_vpath_builddir}"
|
||||
|
||||
%install
|
||||
%make_install
|
||||
%make_install -C "%{_vpath_builddir}"
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
@ -111,6 +85,12 @@ popd
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Wed Feb 09 2022 Alexander Bokovoy <abokovoy@redhat.com> - 0.13.72-1
|
||||
- 0.13.72
|
||||
- Fixes CVE-2020-18442
|
||||
- Resolves: rhbz#1973831
|
||||
- Switch build to CMake, drop 32-bit patches as checks integrated in CMake already
|
||||
|
||||
* Sat Feb 05 2022 Leigh Scott <leigh123linux@gmail.com> - 0.13.71-7
|
||||
- Fix pkgconfig files
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user