Fix multilib conflicts in hte devel package.
Resolves: rhbz#1915747
This commit is contained in:
parent
9460144491
commit
634bd2d780
29
multilib-32.patch
Normal file
29
multilib-32.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- ./a/zzip/_config.h 2021-07-21 14:18:09.000000000 +0200
|
||||||
|
+++ ./b/zzip/_config.h 2021-07-21 14:46:24.037432969 +0200
|
||||||
|
@@ -138,9 +138,12 @@
|
||||||
|
|
||||||
|
/* whether the system defaults to 32bit off_t but can do 64bit when requested
|
||||||
|
*/
|
||||||
|
+#if __WORDSIZE == 32
|
||||||
|
#ifndef ZZIP_LARGEFILE_SENSITIVE
|
||||||
|
#define ZZIP_LARGEFILE_SENSITIVE 1
|
||||||
|
#endif
|
||||||
|
+#endif
|
||||||
|
+/* #undef LARGEFILE_SENSITIVE */
|
||||||
|
|
||||||
|
/* Define to the sub-directory where libtool stores uninstalled libraries. */
|
||||||
|
#ifndef ZZIP_LT_OBJDIR
|
||||||
|
@@ -227,9 +230,13 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* Number of bits in a file offset, on hosts where this is settable. */
|
||||||
|
+#if __WORDSIZE == 32
|
||||||
|
#ifndef ZZIP__FILE_OFFSET_BITS
|
||||||
|
#define ZZIP__FILE_OFFSET_BITS 64
|
||||||
|
#endif
|
||||||
|
+#endif
|
||||||
|
+/* #undef _FILE_OFFSET_BITS */
|
||||||
|
+
|
||||||
|
|
||||||
|
/* Define for large files, on AIX-style hosts. */
|
||||||
|
/* #undef _LARGE_FILES */
|
29
multilib-64.patch
Normal file
29
multilib-64.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- ./a/zzip/_config.h 2021-07-21 14:18:14.000000000 +0200
|
||||||
|
+++ ./b/zzip/_config.h 2021-07-21 14:46:24.037432969 +0200
|
||||||
|
@@ -138,6 +138,11 @@
|
||||||
|
|
||||||
|
/* whether the system defaults to 32bit off_t but can do 64bit when requested
|
||||||
|
*/
|
||||||
|
+#if __WORDSIZE == 32
|
||||||
|
+#ifndef ZZIP_LARGEFILE_SENSITIVE
|
||||||
|
+#define ZZIP_LARGEFILE_SENSITIVE 1
|
||||||
|
+#endif
|
||||||
|
+#endif
|
||||||
|
/* #undef LARGEFILE_SENSITIVE */
|
||||||
|
|
||||||
|
/* Define to the sub-directory where libtool stores uninstalled libraries. */
|
||||||
|
@@ -225,8 +230,14 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* Number of bits in a file offset, on hosts where this is settable. */
|
||||||
|
+#if __WORDSIZE == 32
|
||||||
|
+#ifndef ZZIP__FILE_OFFSET_BITS
|
||||||
|
+#define ZZIP__FILE_OFFSET_BITS 64
|
||||||
|
+#endif
|
||||||
|
+#endif
|
||||||
|
/* #undef _FILE_OFFSET_BITS */
|
||||||
|
|
||||||
|
+
|
||||||
|
/* Define for large files, on AIX-style hosts. */
|
||||||
|
/* #undef _LARGE_FILES */
|
||||||
|
|
@ -1,31 +0,0 @@
|
|||||||
diff -up ./_builddir/zzip/_config.h.orig ./_builddir/zzip/_config.h
|
|
||||||
--- ./_builddir/zzip/_config.h.orig 2018-07-23 09:11:59.971840954 +0300
|
|
||||||
+++ ./_builddir/zzip/_config.h 2018-07-23 09:12:07.438731527 +0300
|
|
||||||
@@ -139,6 +139,11 @@
|
|
||||||
/* whether the system defaults to 32bit off_t but can do 64bit when requested
|
|
||||||
*/
|
|
||||||
/* #undef LARGEFILE_SENSITIVE */
|
|
||||||
+#if __WORDSIZE == 32
|
|
||||||
+#ifndef ZZIP_LARGEFILE_SENSITIVE
|
|
||||||
+#define ZZIP_LARGEFILE_SENSITIVE 1
|
|
||||||
+#endif
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
/* Define to the sub-directory where libtool stores uninstalled libraries. */
|
|
||||||
#ifndef ZZIP_LT_OBJDIR
|
|
||||||
@@ -197,6 +202,15 @@
|
|
||||||
/* The number of bytes in type short */
|
|
||||||
/* #undef SIZEOF_SHORT */
|
|
||||||
|
|
||||||
+/* The number of bytes in type long */
|
|
||||||
+#ifndef ZZIP_SIZEOF_LONG
|
|
||||||
+#if __WORDSIZE == 32
|
|
||||||
+#define ZZIP_SIZEOF_LONG 4
|
|
||||||
+#elif __WORDSIZE == 64
|
|
||||||
+#define ZZIP_SIZEOF_LONG 8
|
|
||||||
+#endif
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
/* Define to 1 if you have the ANSI C header files. */
|
|
||||||
#ifndef ZZIP_STDC_HEADERS
|
|
||||||
#define ZZIP_STDC_HEADERS 1
|
|
16
zziplib.spec
16
zziplib.spec
@ -5,7 +5,8 @@ Release: 4%{?dist}
|
|||||||
License: LGPLv2+ or MPLv1.1
|
License: LGPLv2+ or MPLv1.1
|
||||||
URL: http://zziplib.sourceforge.net/
|
URL: http://zziplib.sourceforge.net/
|
||||||
Source: https://github.com/gdraheim/zziplib/archive/v%{version}.tar.gz
|
Source: https://github.com/gdraheim/zziplib/archive/v%{version}.tar.gz
|
||||||
Patch0: zziplib-0.13.69-multilib.patch
|
Patch100: multilib-32.patch
|
||||||
|
Patch101: multilib-64.patch
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -73,9 +74,14 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
|||||||
# Only patch generated _config.h on non-i686 and armv7hl
|
# Only patch generated _config.h on non-i686 and armv7hl
|
||||||
# These platforms have a correct _config.h already
|
# These platforms have a correct _config.h already
|
||||||
|
|
||||||
%ifnarch i686 armv7hl
|
pushd %{_builddir}/zziplib-%{version}
|
||||||
%apply_patch %{PATCH0} -p2
|
%ifarch i686 armv7hl
|
||||||
|
patch -p2 < %{PATCH100}
|
||||||
%endif
|
%endif
|
||||||
|
%ifnarch i686 armv7hl
|
||||||
|
patch -p2 < %{PATCH101}
|
||||||
|
%endif
|
||||||
|
popd
|
||||||
|
|
||||||
%make_build
|
%make_build
|
||||||
|
|
||||||
@ -102,6 +108,10 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
|||||||
%{_mandir}/man3/*
|
%{_mandir}/man3/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 22 2021 Jakub Martisko <jamartis@redhat.com> - 0.13.71-5
|
||||||
|
- Refresh the multilib patch
|
||||||
|
Resolves: rhbz#1915747
|
||||||
|
|
||||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.13.71-4
|
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 0.13.71-4
|
||||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user