810102f265
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/zstd#acbbb2c675385bc5a3d9d38b43c68d56e72f160a
21 lines
614 B
Diff
21 lines
614 B
Diff
diff -Naur zstd-1.4.5.orig/lib/Makefile zstd-1.4.5/lib/Makefile
|
|
--- zstd-1.4.5.orig/lib/Makefile 2020-05-22 05:04:00.000000000 +0000
|
|
+++ zstd-1.4.5/lib/Makefile 2020-05-25 14:11:28.947300726 +0000
|
|
@@ -220,13 +220,14 @@
|
|
.PHONY: lib
|
|
lib : libzstd.a libzstd
|
|
|
|
-.PHONY: lib-mt
|
|
+# note : do not define lib-mt or lib-release as .PHONY
|
|
+# make does not consider implicit pattern rule for .PHONY target
|
|
+
|
|
%-mt : CPPFLAGS += -DZSTD_MULTITHREAD
|
|
%-mt : LDFLAGS += -pthread
|
|
%-mt : %
|
|
@echo multi-threading build completed
|
|
|
|
-.PHONY: lib-release
|
|
%-release : DEBUGFLAGS :=
|
|
%-release : %
|
|
@echo release build completed
|