latest upstream (1.4.7)
This commit is contained in:
parent
acbbb2c675
commit
e9b032a3cc
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
|||||||
/zstd-1.4.2.tar.gz
|
/zstd-1.4.2.tar.gz
|
||||||
/zstd-1.4.4.tar.gz
|
/zstd-1.4.4.tar.gz
|
||||||
/zstd-1.4.5.tar.gz
|
/zstd-1.4.5.tar.gz
|
||||||
|
/zstd-1.4.7.tar.gz
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
diff -Naur zstd-1.4.5.orig/lib/Makefile zstd-1.4.5/lib/Makefile
|
|
||||||
--- zstd-1.4.5.orig/lib/Makefile 2020-05-22 05:04:00.000000000 +0000
|
|
||||||
+++ zstd-1.4.5/lib/Makefile 2020-05-25 14:11:28.947300726 +0000
|
|
||||||
@@ -220,13 +220,14 @@
|
|
||||||
.PHONY: lib
|
|
||||||
lib : libzstd.a libzstd
|
|
||||||
|
|
||||||
-.PHONY: lib-mt
|
|
||||||
+# note : do not define lib-mt or lib-release as .PHONY
|
|
||||||
+# make does not consider implicit pattern rule for .PHONY target
|
|
||||||
+
|
|
||||||
%-mt : CPPFLAGS += -DZSTD_MULTITHREAD
|
|
||||||
%-mt : LDFLAGS += -pthread
|
|
||||||
%-mt : %
|
|
||||||
@echo multi-threading build completed
|
|
||||||
|
|
||||||
-.PHONY: lib-release
|
|
||||||
%-release : DEBUGFLAGS :=
|
|
||||||
%-release : %
|
|
||||||
@echo release build completed
|
|
@ -1,7 +1,7 @@
|
|||||||
diff -Naur zstd-1.4.5.orig/programs/zstd.1 zstd-1.4.5/programs/zstd.1
|
diff -Naur zstd-1.4.7.orig/programs/zstd.1 zstd-1.4.7/programs/zstd.1
|
||||||
--- zstd-1.4.5.orig/programs/zstd.1 2020-05-22 05:04:00.000000000 +0000
|
--- zstd-1.4.7.orig/programs/zstd.1 2020-12-16 23:00:18.000000000 +0000
|
||||||
+++ zstd-1.4.5/programs/zstd.1 2020-05-22 13:01:37.443798417 +0000
|
+++ zstd-1.4.7/programs/zstd.1 2020-12-17 15:15:22.586152398 +0000
|
||||||
@@ -202,6 +202,14 @@
|
@@ -208,6 +208,14 @@
|
||||||
.
|
.
|
||||||
.IP "\(bu" 4
|
.IP "\(bu" 4
|
||||||
\fB\-\-\fR: All arguments after \fB\-\-\fR are treated as files
|
\fB\-\-\fR: All arguments after \fB\-\-\fR are treated as files
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (zstd-1.4.5.tar.gz) = 417b813ade6c8436690bd9d6da34a9f87f50e7378752b72e63066befbee496392a4b72896fa56688d814f461871ab31d3c6637497ff2ed7a282d58513631a38b
|
SHA512 (zstd-1.4.7.tar.gz) = 43b2292e6518123bebfe0623ec8d7f832850ad1f4fd5b845328665330dd104574a27debd5530c204bf44d0d36737b3e57e07097e5ac6e8bb3bae4e9eeb0f2e0c
|
||||||
|
10
zstd.spec
10
zstd.spec
@ -12,8 +12,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: zstd
|
Name: zstd
|
||||||
Version: 1.4.5
|
Version: 1.4.7
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Zstd compression library
|
Summary: Zstd compression library
|
||||||
|
|
||||||
License: BSD and GPLv2
|
License: BSD and GPLv2
|
||||||
@ -21,7 +21,6 @@ URL: https://github.com/facebook/zstd
|
|||||||
Source0: https://github.com/facebook/zstd/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
Source0: https://github.com/facebook/zstd/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
Patch1: pzstd.1.patch
|
Patch1: pzstd.1.patch
|
||||||
Patch2: lib-make.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc gtest-devel
|
BuildRequires: gcc gtest-devel
|
||||||
%if %{with pzstd}
|
%if %{with pzstd}
|
||||||
@ -58,7 +57,6 @@ find -name .gitignore -delete
|
|||||||
%if %{with pzstd}
|
%if %{with pzstd}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%endif
|
%endif
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="$RPM_OPT_FLAGS"
|
export CFLAGS="$RPM_OPT_FLAGS"
|
||||||
@ -110,7 +108,6 @@ install -D -m644 programs/%{name}.1 %{buildroot}%{_mandir}/man1/p%{name}.1
|
|||||||
%license COPYING LICENSE
|
%license COPYING LICENSE
|
||||||
|
|
||||||
%files -n lib%{name}-devel
|
%files -n lib%{name}-devel
|
||||||
%{_includedir}/zbuff.h
|
|
||||||
%{_includedir}/zdict.h
|
%{_includedir}/zdict.h
|
||||||
%{_includedir}/zstd.h
|
%{_includedir}/zstd.h
|
||||||
%{_includedir}/zstd_errors.h
|
%{_includedir}/zstd_errors.h
|
||||||
@ -123,6 +120,9 @@ install -D -m644 programs/%{name}.1 %{buildroot}%{_mandir}/man1/p%{name}.1
|
|||||||
%ldconfig_scriptlets -n lib%{name}
|
%ldconfig_scriptlets -n lib%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 17 2020 Pádraig Brady <P@draigBrady.com> - 1.4.7-1
|
||||||
|
- Latest upstream
|
||||||
|
|
||||||
* Wed Aug 26 2020 Jeff Law <law@redhat.com> - 1.4.5-6
|
* Wed Aug 26 2020 Jeff Law <law@redhat.com> - 1.4.5-6
|
||||||
- Do not force C++11 mode
|
- Do not force C++11 mode
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user