From e9628f1f42e82ba947cb55c7777dfe113ecf2f5d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?P=C3=A1draig=20Brady?=
Date: Mon, 8 May 2017 06:48:12 -0700
Subject: [PATCH] latest upstream (1.2.0)
---
.gitignore | 1 +
pzstd-warning.patch | 44 --------------------------------------------
pzstd.1.patch | 22 ++++++++++++----------
sources | 2 +-
zstd.spec | 8 +++++---
5 files changed, 19 insertions(+), 58 deletions(-)
delete mode 100644 pzstd-warning.patch
diff --git a/.gitignore b/.gitignore
index fa39155..99dbef4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
/zstd-1.1.0.tar.gz
/zstd-1.1.1.tar.gz
/zstd-1.1.3.tar.gz
+/zstd-1.2.0.tar.gz
diff --git a/pzstd-warning.patch b/pzstd-warning.patch
deleted file mode 100644
index 806e676..0000000
--- a/pzstd-warning.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naur zstd-1.1.3/contrib/pzstd/Pzstd.cpp zstd-1.1.3.new/contrib/pzstd/Pzstd.cpp
---- zstd-1.1.3/contrib/pzstd/Pzstd.cpp 2017-02-06 17:17:34.000000000 +0000
-+++ zstd-1.1.3.new/contrib/pzstd/Pzstd.cpp 2017-03-06 03:10:16.130418128 +0000
-@@ -410,7 +410,7 @@
- });
- // Pass the output queue to the writer thread.
- chunks.push(std::move(out));
-- state.log(VERBOSE, "Starting a new frame\n");
-+ state.log(VERBOSE, "%s\n", "Starting a new frame");
- // Fill the input queue for the compression job we just started
- status = readData(*in, ZSTD_CStreamInSize(), step, fd, &bytesRead);
- }
-@@ -547,8 +547,8 @@
- if (frameSize == 0) {
- // We hit a non SkippableFrame ==> not compressed by pzstd or corrupted
- // Pass the rest of the source to this decompression task
-- state.log(VERBOSE,
-- "Input not in pzstd format, falling back to serial decompression\n");
-+ state.log(VERBOSE, "%s\n",
-+ "Input not in pzstd format, falling back to serial decompression");
- while (status == FileStatus::Continue && !state.errorHolder.hasError()) {
- status = readData(*in, chunkSize, chunkSize, fd, &totalBytesRead);
- }
-diff -Naur zstd-1.1.3/contrib/pzstd/Pzstd.h zstd-1.1.3.new/contrib/pzstd/Pzstd.h
---- zstd-1.1.3/contrib/pzstd/Pzstd.h 2017-02-06 17:17:34.000000000 +0000
-+++ zstd-1.1.3.new/contrib/pzstd/Pzstd.h 2017-03-06 03:08:23.019542883 +0000
-@@ -41,7 +41,7 @@
- auto parameters = options.determineParameters();
- cStreamPool.reset(new ResourcePool{
- [this, parameters]() -> ZSTD_CStream* {
-- this->log(VERBOSE, "Creating new ZSTD_CStream\n");
-+ this->log(VERBOSE, "%s\n", "Creating new ZSTD_CStream");
- auto zcs = ZSTD_createCStream();
- if (zcs) {
- auto err = ZSTD_initCStream_advanced(
-@@ -59,7 +59,7 @@
- } else {
- dStreamPool.reset(new ResourcePool{
- [this]() -> ZSTD_DStream* {
-- this->log(VERBOSE, "Creating new ZSTD_DStream\n");
-+ this->log(VERBOSE, "%s\n", "Creating new ZSTD_DStream");
- auto zds = ZSTD_createDStream();
- if (zds) {
- auto err = ZSTD_initDStream(zds);
diff --git a/pzstd.1.patch b/pzstd.1.patch
index 7570f45..1f391b4 100644
--- a/pzstd.1.patch
+++ b/pzstd.1.patch
@@ -1,10 +1,12 @@
-diff -Naur zstd-1.1.1.orig/programs/zstd.1 zstd-1.1.1/programs/zstd.1
---- zstd-1.1.1.orig/programs/zstd.1 2016-11-01 18:13:22.000000000 +0000
-+++ zstd-1.1.1/programs/zstd.1 2016-11-02 13:01:39.964648652 +0000
-@@ -219,6 +219,13 @@
- All arguments after -- are treated as files
-
-
+diff -Naur zstd-1.2.0.orig/programs/zstd.1 zstd-1.2.0/programs/zstd.1
+--- zstd-1.2.0.orig/programs/zstd.1 2017-05-04 18:18:24.000000000 +0000
++++ zstd-1.2.0/programs/zstd.1 2017-05-08 13:26:25.639811525 +0000
+@@ -162,7 +162,14 @@
+ .TP
+ \fB\-\-\fR
+ All arguments after \fB\-\-\fR are treated as files
+-.
++
+.SH Parallel Zstd OPTIONS
+Additional options for the pzstd utility
+.TP
@@ -12,6 +14,6 @@ diff -Naur zstd-1.1.1.orig/programs/zstd.1 zstd-1.1.1/programs/zstd.1
+ number of threads to use for (de)compression (default:4)
+
+
- .SH DICTIONARY BUILDER
- .PP
- \fBzstd\fR offers \fIdictionary\fR compression, useful for very small files and messages.
+ .SH "DICTIONARY BUILDER"
+ \fBzstd\fR offers \fIdictionary\fR compression, useful for very small files and messages\. It\'s possible to train \fBzstd\fR with some samples, the result of which is saved into a file called a \fBdictionary\fR\. Then during compression and decompression, reference the same dictionary\. It will improve compression ratio of small files\. Typical gains range from 10% (at 64KB) to x5 better (at <1KB)\.
+ .
diff --git a/sources b/sources
index 704c88e..9d7e1d5 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (zstd-1.1.3.tar.gz) = 6c025ca3899d0487bf2b4a9b333b47c6e2bb525ae3fc7328cc040f50d6f3c53a1bb9bd17e104352ddbc7b96b240c250c60d5be99e0a980332dbd3c518b2a81e1
+SHA512 (zstd-1.2.0.tar.gz) = b21910c6bdcfad3199c07b9f70f7c049062ebd1cce9249dd33c36153e29f24dd9e796ddbc2f37846b9f508c14b0d0f67651fd8d2bdce558128f20bdfff50a7df
diff --git a/zstd.spec b/zstd.spec
index 6d4736b..2691322 100644
--- a/zstd.spec
+++ b/zstd.spec
@@ -8,7 +8,7 @@
%endif
Name: zstd
-Version: 1.1.3
+Version: 1.2.0
Release: 1%{?dist}
Summary: Zstd compression library
@@ -17,7 +17,6 @@ URL: https://github.com/facebook/zstd
Source0: https://github.com/facebook/zstd/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
Patch1: pzstd.1.patch
-Patch2: pzstd-warning.patch
BuildRequires: gcc gtest-devel
@@ -44,7 +43,6 @@ Header files for Zstd library.
find -name .gitignore -delete
%if 0%{?with_pzstd}
%patch1 -p1
-%patch2 -p1
%endif
%build
@@ -82,6 +80,7 @@ install -D -m644 programs/%{name}.1 %{buildroot}/%{_mandir}/man1/p%{name}.1
%{_bindir}/p%{name}
%{_mandir}/man1/p%{name}.1*
%endif
+%{_bindir}/%{name}mt
%{_bindir}/un%{name}
%{_bindir}/%{name}cat
%{_mandir}/man1/%{name}.1*
@@ -105,6 +104,9 @@ install -D -m644 programs/%{name}.1 %{buildroot}/%{_mandir}/man1/p%{name}.1
%postun -n lib%{name} -p /sbin/ldconfig
%changelog
+* Mon May 08 2017 Pádraig Brady - 1.2.0-1
+- Latest upstream
+
* Mon Mar 06 2017 Pádraig Brady
- 1.1.3-1
- Latest upstream