Rebase to zstd 1.5.5
Resolves: RHEL-62221
This commit is contained in:
parent
dcda9fe564
commit
65ac97bcf2
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@
|
|||||||
/zstd-1.4.9.tar.gz
|
/zstd-1.4.9.tar.gz
|
||||||
/zstd-1.5.0.tar.gz
|
/zstd-1.5.0.tar.gz
|
||||||
/zstd-1.5.1.tar.gz
|
/zstd-1.5.1.tar.gz
|
||||||
|
/zstd-1.5.5.tar.gz
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
diff -Naur zstd-1.5.1.orig/programs/zstd.1 zstd-1.5.1/programs/zstd.1
|
diff -Naur zstd-1.5.4/programs/zstd.1 zstd-1.5.4.new/programs/zstd.1
|
||||||
--- zstd-1.5.1.orig/programs/zstd.1 2021-12-20 22:49:18.000000000 +0000
|
--- zstd-1.5.4/programs/zstd.1 2023-02-10 00:41:50.000000000 +0000
|
||||||
+++ zstd-1.5.1/programs/zstd.1 2021-12-22 16:49:17.160850340 +0000
|
+++ zstd-1.5.4.new/programs/zstd.1 2023-02-13 12:44:01.575160149 +0000
|
||||||
@@ -146,6 +146,14 @@
|
@@ -162,6 +162,13 @@
|
||||||
\fB\-\-show\-default\-cparams\fR: Shows the default compression parameters that will be used for a particular src file\. If the provided src file is not a regular file (eg\. named pipe), the cli will just output the default parameters\. That is, the parameters that are used when the src size is unknown\.
|
\fB\-\-show\-default\-cparams\fR: shows the default compression parameters that will be used for a particular input file, based on the provided compression level and the input size\. If the provided file is not a regular file (e\.g\. a pipe), this flag will output the parameters used for inputs of unknown size\.
|
||||||
.IP "\[ci]" 4
|
.IP "\[ci]" 4
|
||||||
\fB\-\-\fR: All arguments after \fB\-\-\fR are treated as files
|
\fB\-\-\fR: All arguments after \fB\-\-\fR are treated as files
|
||||||
+
|
+
|
||||||
@ -11,8 +11,7 @@ diff -Naur zstd-1.5.1.orig/programs/zstd.1 zstd-1.5.1/programs/zstd.1
|
|||||||
+.TP
|
+.TP
|
||||||
+.BR \-p ", " --processes
|
+.BR \-p ", " --processes
|
||||||
+ number of threads to use for (de)compression (default:4)
|
+ number of threads to use for (de)compression (default:4)
|
||||||
+
|
|
||||||
+
|
+
|
||||||
.IP "" 0
|
.IP "" 0
|
||||||
.SS "Restricted usage of Environment Variables"
|
.SS "gzip Operation Modifiers"
|
||||||
Using environment variables to set parameters has security implications\. Therefore, this avenue is intentionally restricted\. Only \fBZSTD_CLEVEL\fR and \fBZSTD_NBTHREADS\fR are currently supported\. They set the compression level and number of threads to use during compression, respectively\.
|
When invoked via a \fBgzip\fR symlink, \fBzstd\fR will support further options that intend to mimic the \fBgzip\fR behavior:
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (zstd-1.5.1.tar.gz) = 00c7f5f6f6a2b51557f3ede56026d54d8e023c85f9824496f4522524ce8ced495e88d56452e3510df6ec1bf53e659b2633cdcc84d016bcdbfdcc76e142d3620f
|
SHA512 (zstd-1.5.5.tar.gz) = 99109ec0e07fa65c2101c9cb36be56b672bbd0ee69d265f924718e61f9192ae8385c8d9e4d0c318be9edfa6d849fd3d60e5f164fa120961449429ea3c5dab6b6
|
||||||
|
10
zstd.spec
10
zstd.spec
@ -33,8 +33,8 @@
|
|||||||
%bcond_with gtest
|
%bcond_with gtest
|
||||||
|
|
||||||
Name: zstd
|
Name: zstd
|
||||||
Version: 1.5.1
|
Version: 1.5.5
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Zstd compression library
|
Summary: Zstd compression library
|
||||||
|
|
||||||
License: BSD and GPLv2
|
License: BSD and GPLv2
|
||||||
@ -42,7 +42,6 @@ URL: https://github.com/facebook/zstd
|
|||||||
Source0: https://github.com/facebook/zstd/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
Source0: https://github.com/facebook/zstd/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
Patch1: pzstd.1.patch
|
Patch1: pzstd.1.patch
|
||||||
Patch2: enable-CET.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -93,7 +92,6 @@ find -name .gitignore -delete
|
|||||||
%if %{with pzstd}
|
%if %{with pzstd}
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%endif
|
%endif
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="$RPM_OPT_FLAGS"
|
export CFLAGS="$RPM_OPT_FLAGS"
|
||||||
@ -163,6 +161,10 @@ install -D -m644 programs/%{name}.1 %{buildroot}%{_mandir}/man1/p%{name}.1
|
|||||||
%ldconfig_scriptlets -n lib%{name}
|
%ldconfig_scriptlets -n lib%{name}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 01 2024 Jakub Martisko <jamartis@redhat.com> - 1.5.5-1
|
||||||
|
- Rebase to 1.5.5
|
||||||
|
Resolves: RHEL-62221
|
||||||
|
|
||||||
* Mon Feb 07 2022 Jakub Martisko <jamartis@redhat.com> - 1.5.1-2
|
* Mon Feb 07 2022 Jakub Martisko <jamartis@redhat.com> - 1.5.1-2
|
||||||
- Add some basic gating tests
|
- Add some basic gating tests
|
||||||
Resolves: rhbz#2050272
|
Resolves: rhbz#2050272
|
||||||
|
Loading…
Reference in New Issue
Block a user