diff --git a/0006-zsh-5.5.1-fix-wait.patch b/0006-zsh-5.5.1-fix-wait.patch
new file mode 100644
index 0000000..f89073e
--- /dev/null
+++ b/0006-zsh-5.5.1-fix-wait.patch
@@ -0,0 +1,28 @@
+From 6af0b07cc7950159129156cb85ef3f72fdd828cc Mon Sep 17 00:00:00 2001
+From: Peter Stephenson
+Date: Sat, 3 Aug 2019 19:48:18 +0100
+Subject: [PATCH] 44635: Don't apply STAT_NOPRINT to backgrounded jobs
+
+Upstream-commit: e0d063a2ade821baf570eb300d4be93692b494f8
+Signed-off-by: Kamil Dudka
+---
+ Src/exec.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Src/exec.c b/Src/exec.c
+index 8045db2..da089d6 100644
+--- a/Src/exec.c
++++ b/Src/exec.c
+@@ -1666,7 +1666,8 @@ execpline(Estate state, wordcode slcode, int how, int last1)
+
+ lastwj = thisjob = newjob;
+
+- if (list_pipe || (pline_level && !(how & Z_TIMED)))
++ if (list_pipe || (pline_level && !(how & Z_TIMED) &&
++ !(jn->stat & STAT_NOSTTY)))
+ jn->stat |= STAT_NOPRINT;
+
+ if (nowait) {
+--
+2.34.1
+
diff --git a/zsh.spec b/zsh.spec
index bd37d4e..0efe556 100644
--- a/zsh.spec
+++ b/zsh.spec
@@ -1,7 +1,7 @@
Summary: Powerful interactive shell
Name: zsh
Version: 5.5.1
-Release: 9%{?dist}
+Release: 10%{?dist}
License: MIT
URL: http://zsh.sourceforge.net/
Source0: https://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
@@ -27,6 +27,9 @@ Patch4: 0004-zsh-5.5.1-CVE-2019-20044.patch
# do not perform PROMPT_SUBST evaluation on %F/%K arguments (CVE-2021-45444)
Patch5: 0005-zsh-5.5.1-CVE-2021-45444.patch
+# make zsh wait built-in wait properly for all active child processes (#2070342)
+Patch6: 0006-zsh-5.5.1-fix-wait.patch
+
BuildRequires: autoconf
BuildRequires: coreutils
BuildRequires: gawk
@@ -182,6 +185,9 @@ fi
%doc Doc/*.html
%changelog
+* Fri Apr 01 2022 Kamil Dudka - 5.5.1-10
+- make zsh wait built-in wait properly for all active child processes (#2070342)
+
* Tue Feb 22 2022 Kamil Dudka - 5.5.1-9
- do not perform PROMPT_SUBST evaluation on %F/%K arguments (CVE-2021-45444)