Fix bug #142237 - problem with "./files" containing archives
This commit is contained in:
parent
9ce77aa6c7
commit
f1880abc10
11
zip-2.3-currdir.patch
Normal file
11
zip-2.3-currdir.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- zip-2.3/util.c.pom 1999-11-07 11:29:38.000000000 +0100
|
||||||
|
+++ zip-2.3/util.c 2005-01-17 13:46:26.165396792 +0100
|
||||||
|
@@ -190,6 +190,8 @@
|
||||||
|
/* Compare the sh pattern p with the string s and return true if they match,
|
||||||
|
false if they don't or if there is a syntax error in the pattern. */
|
||||||
|
{
|
||||||
|
+ while (s[0] == '.' && s[1] == '/')
|
||||||
|
+ s += 2; /* strip redundant leading "./" sections */
|
||||||
|
return recmatch((ZCONST uch *) p, (ZCONST uch *) s, cs) == 1;
|
||||||
|
}
|
||||||
|
|
7
zip.spec
7
zip.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A file compression and packaging utility compatible with PKZIP.
|
Summary: A file compression and packaging utility compatible with PKZIP.
|
||||||
Name: zip
|
Name: zip
|
||||||
Version: 2.3
|
Version: 2.3
|
||||||
Release: 24
|
Release: 25
|
||||||
License: distributable
|
License: distributable
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
Source: ftp.uu.net:/pub/archiving/zip/src/zip23.tar.gz
|
Source: ftp.uu.net:/pub/archiving/zip/src/zip23.tar.gz
|
||||||
@ -12,6 +12,7 @@ Patch1: exec-shield.patch
|
|||||||
Patch2: zip23-umask.patch
|
Patch2: zip23-umask.patch
|
||||||
Patch3: zip-2.3-near-4GB.patch
|
Patch3: zip-2.3-near-4GB.patch
|
||||||
Patch4: zip-2.3-configure.patch
|
Patch4: zip-2.3-configure.patch
|
||||||
|
Patch5: zip-2.3-currdir.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -30,6 +31,7 @@ program.
|
|||||||
%patch2 -p1 -b .umask
|
%patch2 -p1 -b .umask
|
||||||
%patch3 -p1 -b .4gb
|
%patch3 -p1 -b .4gb
|
||||||
%patch4 -p1 -b .cfg
|
%patch4 -p1 -b .cfg
|
||||||
|
%patch5 -p1 -b .currdir
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make -f unix/Makefile prefix=/usr "CFLAGS=$RPM_OPT_FLAGS -I. -DUNIX -D_LARGEFILE64_SOURCE" generic_gcc
|
make -f unix/Makefile prefix=/usr "CFLAGS=$RPM_OPT_FLAGS -I. -DUNIX -D_LARGEFILE64_SOURCE" generic_gcc
|
||||||
@ -62,6 +64,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/zip.1*
|
%{_mandir}/man1/zip.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 17 2005 Ivana Varekova <varekova@redhat.com> 2.3-25
|
||||||
|
- Fix bug #142237 - problem with -d and ./files containing archives
|
||||||
|
|
||||||
* Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 2.3-24
|
* Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 2.3-24
|
||||||
- Extend max file/archive size to 2^32-8193 (4294959103) bytes
|
- Extend max file/archive size to 2^32-8193 (4294959103) bytes
|
||||||
- Include better debugging output for configure script
|
- Include better debugging output for configure script
|
||||||
|
Loading…
Reference in New Issue
Block a user