auto-import changelog data from zip-2.3-8.src.rpm

Fri Aug 25 2000 Bill Nottingham <notting@redhat.com>
- add encryption code (#16878)
Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
- automatic rebuild
Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
- rebuild in new environment
Mon Mar 13 2000 Bill Nottingham <notting@redhat.com>
- spec file cleanups (#10143)
Mon Feb 07 2000 Bill Nottingham <notting@redhat.com>
- fix some perms
Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
- fix description
- man pages are compressed
Tue Jan 11 2000 Bill Nottingham <notting@redhat.com>
- update to 2.3
Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
- update to 2.2
Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
- auto rebuild in the new build environment (release 8)
Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
- updated text in the spec file
Fri Jan 15 1999 Cristian Gafton <gafton@redhat.com>
- patch top build on the arm
Mon Dec 21 1998 Michael Maher <mike@redhat.com>
- built package for 6.0
Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
- build root
Fri May 08 1998 Prospector System <bugs@redhat.com>
- translations modified for de, fr, tr
Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
- built against glibc
This commit is contained in:
cvsdist 2004-09-09 15:14:43 +00:00
parent 7dc96079f2
commit b69576337c
4 changed files with 198 additions and 0 deletions

View File

@ -0,0 +1,2 @@
zcrypt29.tar.gz
zip23.tar.gz

View File

@ -0,0 +1,2 @@
922f7f38f8e50ec353fd5b3102e4d4d6 zcrypt29.tar.gz
5206a99541f3b0ab90f1baa167392c4f zip23.tar.gz

101
zip.spec Normal file
View File

@ -0,0 +1,101 @@
Summary: A file compression and packaging utility compatible with PKZIP.
Name: zip
Version: 2.3
Release: 8
Copyright: distributable
Group: Applications/Archiving
Source: ftp.uu.net:/pub/archiving/zip/src/zip23.tar.gz
Source1: ftp://ftp.freesoftware.com/pub/infozip/src/zcrypt29.tar.gz
Patch0: zip23.patch
Prefix: /usr
BuildRoot: /var/tmp/zip-root
%description
The zip program is a compression and file packaging utility. Zip is
analogous to a combination of the UNIX tar and compress commands and
is compatible with PKZIP (a compression and file packaging utility for
MS-DOS systems).
Install the zip package if you need to compress files using the zip
program.
%prep
%setup -q -a 1
%patch0 -p1 -b .zip
%build
make -f unix/Makefile prefix=%{prefix} "CFLAGS=$RPM_OPT_FLAGS -I. -DUNIX" generic_gcc
%install
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{prefix}/bin
mkdir -p $RPM_BULD_ROOT%{_mandir}/man1
make -f unix/Makefile prefix=$RPM_BUILD_ROOT%{prefix} \
MANDIR=$RPM_BUILD_ROOT%{_mandir}/man1 install
pushd $RPM_BUILD_ROOT
for n in zipnote zipsplit zip zipcloak ; do
strip .%{prefix}/bin/$n
chmod 755 .%{prefix}/bin/$n
done
popd
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%doc README BUGS CHANGES MANUAL TODO WHATSNEW WHERE proginfo/algorith.txt
%{prefix}/bin/zipnote
%{prefix}/bin/zipsplit
%{prefix}/bin/zip
%{prefix}/bin/zipcloak
%{_mandir}/man1/zip.1*
%changelog
* Thu Aug 25 2000 Bill Nottingham <notting@redhat.com>
- add encryption code (#16878)
* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
- automatic rebuild
* Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
- rebuild in new environment
* Mon Mar 13 2000 Bill Nottingham <notting@redhat.com>
- spec file cleanups (#10143)
* Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
- fix some perms
* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
- fix description
- man pages are compressed
* Tue Jan 11 2000 Bill Nottingham <notting@redhat.com>
- update to 2.3
* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
- update to 2.2
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
- auto rebuild in the new build environment (release 8)
* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
- updated text in the spec file
* Fri Jan 15 1999 Cristian Gafton <gafton@redhat.com>
- patch top build on the arm
* Mon Dec 21 1998 Michael Maher <mike@redhat.com>
- built package for 6.0
* Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
- build root
* Fri May 08 1998 Prospector System <bugs@redhat.com>
- translations modified for de, fr, tr
* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
- built against glibc

93
zip23.patch Normal file
View File

@ -0,0 +1,93 @@
--- zip-2.3/zip.h.zip Mon Nov 8 14:36:51 1999
+++ zip-2.3/zip.h Tue Jan 11 11:46:06 2000
@@ -60,6 +60,7 @@
/* Set up portability */
#include "tailor.h"
+#include <strings.h>
#ifdef USE_ZLIB
# include "zlib.h"
@@ -433,12 +434,6 @@
int setfileattr OF((char *, int));
char *tempname OF((char *));
int fcopy OF((FILE *, FILE *, ulg));
-
-#ifdef ZMEM
- char *memset OF((char *, int, unsigned int));
- char *memcpy OF((char *, char *, unsigned int));
- int memcmp OF((char *, char *, unsigned int));
-#endif /* ZMEM */
/* in system dependent fileio code (<system>.c) */
#ifndef UTIL
--- zip-2.3/fileio.c.zip Sun Nov 7 05:29:03 1999
+++ zip-2.3/fileio.c Tue Jan 11 11:46:43 2000
@@ -918,67 +918,3 @@
}
#endif /* NO_RENAME */
-
-
-#ifdef ZMEM
-
-/************************/
-/* Function memset() */
-/************************/
-
-/*
- * memset - for systems without it
- * bill davidsen - March 1990
- */
-
-char *
-memset(buf, init, len)
-register char *buf; /* buffer loc */
-register int init; /* initializer */
-register unsigned int len; /* length of the buffer */
-{
- char *start;
-
- start = buf;
- while (len--) *(buf++) = init;
- return(start);
-}
-
-
-/************************/
-/* Function memcpy() */
-/************************/
-
-char *
-memcpy(dst,src,len) /* v2.0f */
-register char *dst, *src;
-register unsigned int len;
-{
- char *start;
-
- start = dst;
- while (len--)
- *dst++ = *src++;
- return(start);
-}
-
-
-/************************/
-/* Function memcmp() */
-/************************/
-
-int
-memcmp(b1,b2,len) /* jpd@usl.edu -- 11/16/90 */
-register char *b1, *b2;
-register unsigned int len;
-{
-
- if (len) do { /* examine each byte (if any) */
- if (*b1++ != *b2++)
- return (*((uch *)b1-1) - *((uch *)b2-1)); /* exit when miscompare */
- } while (--len);
-
- return(0); /* no miscompares, yield 0 result */
-}
-
-#endif /* ZMEM */