Really build with -std=gnu89 (#2143565)
This commit is contained in:
parent
9006220708
commit
98b40e35ca
15
zip-gnu89-build.patch
Normal file
15
zip-gnu89-build.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
zip uses C89-only features, so it needs to be built in C89 mode.
|
||||||
|
|
||||||
|
diff --git a/unix/Makefile b/unix/Makefile
|
||||||
|
index 86cf54bf0f56cea9..244390893eab5fc6 100644
|
||||||
|
--- a/unix/Makefile
|
||||||
|
+++ b/unix/Makefile
|
||||||
|
@@ -202,7 +202,7 @@ generic: flags
|
||||||
|
eval $(MAKE) $(MAKEF) zips `cat flags`
|
||||||
|
|
||||||
|
generic_gcc:
|
||||||
|
- $(MAKE) $(MAKEF) generic CC=gcc CPP="gcc -E"
|
||||||
|
+ $(MAKE) $(MAKEF) generic CC="gcc -std=gnu89" CPP="gcc -E"
|
||||||
|
|
||||||
|
# AT&T 6300 PLUS (don't know yet how to allocate 64K bytes):
|
||||||
|
att6300nodir:
|
9
zip.spec
9
zip.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A file compression and packaging utility compatible with PKZIP
|
Summary: A file compression and packaging utility compatible with PKZIP
|
||||||
Name: zip
|
Name: zip
|
||||||
Version: 3.0
|
Version: 3.0
|
||||||
Release: 34%{?dist}
|
Release: 35%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Source: http://downloads.sourceforge.net/infozip/zip30.tar.gz
|
Source: http://downloads.sourceforge.net/infozip/zip30.tar.gz
|
||||||
URL: http://www.info-zip.org/Zip.html
|
URL: http://www.info-zip.org/Zip.html
|
||||||
@ -16,6 +16,7 @@ Patch3: zip-3.0-time.patch
|
|||||||
Patch4: man.patch
|
Patch4: man.patch
|
||||||
Patch5: zip-3.0-format-security.patch
|
Patch5: zip-3.0-format-security.patch
|
||||||
Patch6: zipnote.patch
|
Patch6: zipnote.patch
|
||||||
|
Patch7: zip-gnu89-build.patch
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: bzip2-devel, gcc
|
BuildRequires: bzip2-devel, gcc
|
||||||
Requires: unzip
|
Requires: unzip
|
||||||
@ -37,9 +38,10 @@ program.
|
|||||||
%patch4 -p1 -b .man
|
%patch4 -p1 -b .man
|
||||||
%patch5 -p1 -b .format-security
|
%patch5 -p1 -b .format-security
|
||||||
%patch6 -p1 -b .zipnote
|
%patch6 -p1 -b .zipnote
|
||||||
|
%patch7 -p1 -b .gnu89-build
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{make_build} -f unix/Makefile prefix=%{_prefix} "CFLAGS_NOOPT=-I. -DUNIX -std=gnu89 $RPM_OPT_FLAGS" generic
|
%{make_build} -f unix/Makefile prefix=%{_prefix} "CFLAGS_NOOPT=-I. -DUNIX $RPM_OPT_FLAGS" generic_gcc
|
||||||
|
|
||||||
%install
|
%install
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
||||||
@ -62,6 +64,9 @@ mkdir -p $RPM_BULD_ROOT%{_mandir}/man1
|
|||||||
%{_mandir}/man1/zipsplit.1*
|
%{_mandir}/man1/zipsplit.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 18 2022 Florian Weimer <fweimer@redhat.com> - 3.0-35
|
||||||
|
- Really build with -std=gnu89 (#2143565)
|
||||||
|
|
||||||
* Thu Nov 17 2022 Florian Weimer <fweimer@redhat.com> - 3.0-34
|
* Thu Nov 17 2022 Florian Weimer <fweimer@redhat.com> - 3.0-34
|
||||||
- Build with -std=gnu89 (#2143565)
|
- Build with -std=gnu89 (#2143565)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user