- fix "zip does not honor umask setting when creating archives"
- fix "zip segfaults by attempt to archive big file" - spec file cleanup
This commit is contained in:
parent
d35c9b9c30
commit
68b5760de6
11
zip-2.3-sf.patch
Normal file
11
zip-2.3-sf.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- zip-2.3/unix/unix.c.pom 2006-10-09 16:24:47.000000000 +0200
|
||||||
|
+++ zip-2.3/unix/unix.c 2006-10-09 17:14:18.000000000 +0200
|
||||||
|
@@ -208,7 +208,7 @@
|
||||||
|
doesn't collide with error values. 2^32 - 8193 should be plenty until
|
||||||
|
info-zip supports zip64. */
|
||||||
|
if (s.st_size > MAX_ZIP_SIZE) {
|
||||||
|
- zipwarn("file too large: ", a);
|
||||||
|
+ zipwarn("file too large: ", n);
|
||||||
|
return ZE_MISS;
|
||||||
|
}
|
||||||
|
|
12
zip-2.31-umask_mode.patch
Normal file
12
zip-2.31-umask_mode.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up zip-2.31/fileio.c.pom zip-2.31/fileio.c
|
||||||
|
--- zip-2.31/fileio.c.pom 2007-11-05 14:02:41.000000000 +0100
|
||||||
|
+++ zip-2.31/fileio.c 2007-11-05 14:03:09.000000000 +0100
|
||||||
|
@@ -976,7 +976,7 @@ lfopen(const char *path, const char *mod
|
||||||
|
prev = mode[x];
|
||||||
|
}
|
||||||
|
|
||||||
|
- fd = open(path, flags, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
|
||||||
|
+ fd = open(path, flags, S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH );
|
||||||
|
if (fd == -1)
|
||||||
|
return NULL;
|
||||||
|
|
15
zip.spec
15
zip.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A file compression and packaging utility compatible with PKZIP
|
Summary: A file compression and packaging utility compatible with PKZIP
|
||||||
Name: zip
|
Name: zip
|
||||||
Version: 2.31
|
Version: 2.31
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
Source: http://ftp.info-zip.org/pub/infozip/src/zip231.tar.gz
|
Source: http://ftp.info-zip.org/pub/infozip/src/zip231.tar.gz
|
||||||
@ -15,6 +15,8 @@ Patch6: zip-2.31-install.patch
|
|||||||
Patch7: zip-2.31-near-4GB.patch
|
Patch7: zip-2.31-near-4GB.patch
|
||||||
Patch8: zip-2.31-configure.patch
|
Patch8: zip-2.31-configure.patch
|
||||||
Patch9: zip-2.31-time.patch
|
Patch9: zip-2.31-time.patch
|
||||||
|
Patch10: zip-2.3-sf.patch
|
||||||
|
Patch11: zip-2.31-umask_mode.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -36,6 +38,8 @@ program.
|
|||||||
%patch7 -p1 -b .4gb
|
%patch7 -p1 -b .4gb
|
||||||
%patch8 -p1 -b .lhh
|
%patch8 -p1 -b .lhh
|
||||||
%patch9 -p1 -b .time
|
%patch9 -p1 -b .time
|
||||||
|
%patch10 -p1 -b .out
|
||||||
|
%patch11 -p1 -b .um
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make -f unix/Makefile prefix=%{_prefix} "CFLAGS=$RPM_OPT_FLAGS -I. -DUNIX -D_LARGEFILE64_SOURCE" generic_gcc %{?_smp_mflags}
|
make -f unix/Makefile prefix=%{_prefix} "CFLAGS=$RPM_OPT_FLAGS -I. -DUNIX -D_LARGEFILE64_SOURCE" generic_gcc %{?_smp_mflags}
|
||||||
@ -58,8 +62,8 @@ popd
|
|||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root,-)
|
||||||
%doc README BUGS CHANGES MANUAL TODO WHATSNEW WHERE LICENSE
|
%doc README CHANGES TODO WHATSNEW WHERE LICENSE README.CR
|
||||||
%doc proginfo/algorith.txt
|
%doc proginfo/algorith.txt
|
||||||
%{_bindir}/zipnote
|
%{_bindir}/zipnote
|
||||||
%{_bindir}/zipsplit
|
%{_bindir}/zipsplit
|
||||||
@ -68,6 +72,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/zip.1*
|
%{_mandir}/man1/zip.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 5 2007 Ivana Varekova <varekova@redhat.com> - 2.31-4
|
||||||
|
- fix "zip does not honor umask setting when creating archives"
|
||||||
|
- fix "zip segfaults by attempt to archive big file"
|
||||||
|
- spec file cleanup
|
||||||
|
|
||||||
* Wed Feb 7 2007 Ivana Varekova <varekova@redhat.com> - 2.31-3
|
* Wed Feb 7 2007 Ivana Varekova <varekova@redhat.com> - 2.31-3
|
||||||
- incorporate the next peckage review comment
|
- incorporate the next peckage review comment
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user