auto-import changelog data from zip-2.3-20.src.rpm
Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> - rebuilt Mon Dec 22 2003 Lon Hohberger <lhh@redhat.com> 2.3-19 - Make temp file have umask 0066 mode (#112516)
This commit is contained in:
parent
e3bd6b653a
commit
0810376848
10
zip.spec
10
zip.spec
@ -1,7 +1,7 @@
|
||||
Summary: A file compression and packaging utility compatible with PKZIP.
|
||||
Name: zip
|
||||
Version: 2.3
|
||||
Release: 18
|
||||
Release: 20
|
||||
License: distributable
|
||||
Group: Applications/Archiving
|
||||
Source: ftp.uu.net:/pub/archiving/zip/src/zip23.tar.gz
|
||||
@ -9,6 +9,7 @@ Source1: ftp://ftp.freesoftware.com/pub/infozip/src/zcrypt29.tar.gz
|
||||
URL: http://www.info-zip.org/pub/infozip/Zip.html
|
||||
Patch0: zip23.patch
|
||||
Patch1: exec-shield.patch
|
||||
Patch2: zip23-umask.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
@ -24,6 +25,7 @@ program.
|
||||
%setup -q -a 1
|
||||
%patch0 -p1 -b .zip
|
||||
%patch1 -p1 -b .zip
|
||||
%patch2 -p1 -b .umask
|
||||
|
||||
%build
|
||||
make -f unix/Makefile prefix=/usr "CFLAGS=$RPM_OPT_FLAGS -I. -DUNIX" generic_gcc
|
||||
@ -55,6 +57,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man1/zip.1*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Mon Dec 22 2003 Lon Hohberger <lhh@redhat.com> 2.3-19
|
||||
- Make temp file have umask 0066 mode (#112516)
|
||||
|
||||
* Fri Oct 24 2003 Lon Hohberger <lhh@redhat.com> 2.3-18
|
||||
- Incorporate Arjan's exec-shield patch for i386
|
||||
|
||||
|
23
zip23-umask.patch
Normal file
23
zip23-umask.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -ur zip-2.3/zip.c zip-2.3-lhh/zip.c
|
||||
--- zip-2.3/zip.c 1999-11-16 15:08:10.000000000 -0500
|
||||
+++ zip-2.3-lhh/zip.c 2003-12-22 09:32:56.000000000 -0500
|
||||
@@ -849,6 +849,7 @@
|
||||
/* Add, update, freshen, or delete zip entries in a zip file. See the
|
||||
command help in help() above. */
|
||||
{
|
||||
+ mode_t old_umask; /* umask prior to temp file creation */
|
||||
int a; /* attributes of zip file */
|
||||
ulg c; /* start of central directory */
|
||||
int d; /* true if just adding to a zip file */
|
||||
@@ -1830,9 +1831,11 @@
|
||||
if ((tempzip = tempname(zipfile)) == NULL) {
|
||||
ZIPERR(ZE_MEM, "allocating temp filename");
|
||||
}
|
||||
+ old_umask = umask(0066);
|
||||
if ((tempzf = y = fopen(tempzip, FOPW_TMP)) == NULL) {
|
||||
ZIPERR(ZE_TEMP, tempzip);
|
||||
}
|
||||
+ umask(old_umask);
|
||||
}
|
||||
|
||||
#if (!defined(VMS) && !defined(CMS_MVS))
|
Loading…
Reference in New Issue
Block a user