added signalstate patch, fixes compilation with NetworkManaged-devel
headers installed. Resolves #537064 (F-12, devel)
This commit is contained in:
parent
a53b68b6a9
commit
f440e6a36f
26
ypbind-mt-1.20.4-signalstate.patch
Normal file
26
ypbind-mt-1.20.4-signalstate.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff -up ypbind-mt-1.20.4/src/ypbind_dbus_nm.c.signalstate ypbind-mt-1.20.4/src/ypbind_dbus_nm.c
|
||||
--- ypbind-mt-1.20.4/src/ypbind_dbus_nm.c.signalstate 2009-11-13 12:32:30.639389786 +0100
|
||||
+++ ypbind-mt-1.20.4/src/ypbind_dbus_nm.c 2009-11-13 12:34:30.429263750 +0100
|
||||
@@ -34,11 +34,12 @@
|
||||
|
||||
#ifdef HAVE_NETWORKMANAGER_NETWORKMANAGER_H
|
||||
#include <NetworkManager/NetworkManager.h>
|
||||
+#include <NetworkManager/NetworkManagerVPN.h>
|
||||
#else
|
||||
#define NM_DBUS_INTERFACE "org.freedesktop.NetworkManager"
|
||||
#define NM_DBUS_SERVICE "org.freedesktop.NetworkManager"
|
||||
#define NM_DBUS_PATH "/org/freedesktop/NetworkManager"
|
||||
-#define NM_DBUS_SIGNAL_STATE_CHANGE "StateChange"
|
||||
+#define NM_DBUS_VPN_SIGNAL_STATE_CHANGE "StateChange"
|
||||
|
||||
typedef enum NMState {
|
||||
NM_STATE_UNKNOWN = 0,
|
||||
@@ -138,7 +139,7 @@ dbus_filter (DBusConnection *connection,
|
||||
handled = DBUS_HANDLER_RESULT_HANDLED;
|
||||
}
|
||||
else if (dbus_message_is_signal (message, NM_DBUS_INTERFACE,
|
||||
- NM_DBUS_SIGNAL_STATE_CHANGE))
|
||||
+ NM_DBUS_VPN_SIGNAL_STATE_CHANGE))
|
||||
{
|
||||
NMState state = NM_STATE_UNKNOWN;
|
||||
|
10
ypbind.spec
10
ypbind.spec
@ -1,7 +1,7 @@
|
||||
Summary: The NIS daemon which binds NIS clients to an NIS domain
|
||||
Name: ypbind
|
||||
Version: 1.29.91
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Daemons
|
||||
Source0: ftp://ftp.us.kernel.org/pub/linux/utils/net/NIS/ypbind-mt-%{version}.tar.bz2
|
||||
@ -9,7 +9,10 @@ Url: http://www.linux-nis.org/nis/ypbind-mt/index.html
|
||||
Source1: ypbind.init
|
||||
Source2: nis.sh
|
||||
Patch1: ypbind-1.11-gettextdomain.patch
|
||||
# Sent to upstream. No response.
|
||||
Patch2: ypbind-mt-1.29.91-man-port.patch
|
||||
# Sent to upstream. Fixes bug #537064.
|
||||
Patch3: ypbind-mt-1.20.4-signalstate.patch
|
||||
|
||||
Requires(post): chkconfig
|
||||
Requires(preun): chkconfig
|
||||
@ -43,6 +46,7 @@ also need to install the ypserv package to a machine on your network.
|
||||
%setup -q -n ypbind-mt-%{version}
|
||||
%patch1 -p1 -b .gettextdomain
|
||||
%patch2 -p1 -b .man-port
|
||||
%patch3 -p1 -b .signalstate
|
||||
|
||||
%build
|
||||
%configure --sbindir=/sbin
|
||||
@ -87,6 +91,10 @@ fi
|
||||
%doc README NEWS
|
||||
|
||||
%changelog
|
||||
* Fri Nov 19 2009 Karel Klic <kklic@redhat.com> - 3:1.29.91-2
|
||||
- Added signalstate patch, which fixes compilation with
|
||||
NetworkManaged-devel headers installed. Resolves #537064.
|
||||
|
||||
* Mon Oct 26 2009 Karel Klic <kklic@redhat.com> - 3:1.29.91-1
|
||||
- Updated to 1.29.91 from upstream
|
||||
- Removed 1.19-port-leak patch because the upstream source code has
|
||||
|
Loading…
Reference in New Issue
Block a user