Merge Review
This commit is contained in:
parent
bf2b5cb671
commit
ebc52e069e
@ -1,11 +0,0 @@
|
|||||||
--- ypbind-mt-1.19/src/Makefile.am.orig 2004-02-13 16:17:12.000000000 -0500
|
|
||||||
+++ ypbind-mt-1.19/src/Makefile.am 2006-08-23 21:10:30.000000000 -0400
|
|
||||||
@@ -6,7 +6,7 @@
|
|
||||||
|
|
||||||
AUTOMAKE_OPTIONS = 1.4 gnits
|
|
||||||
|
|
||||||
-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s -m 555
|
|
||||||
+INSTALL_PROGRAM = @INSTALL_PROGRAM@ -m 555
|
|
||||||
|
|
||||||
AM_CFLAGS = -D_REENTRANT=1 @WARNFLAGS@ -DUSE_BROADCAST=@USE_BROADCAST@
|
|
||||||
LDADD = ../lib/libcompat.a @LIBINTL@ @SLP_LIBS@
|
|
55
ypbind.spec
55
ypbind.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The NIS daemon which binds NIS clients to an NIS domain.
|
Summary: The NIS daemon which binds NIS clients to an NIS domain
|
||||||
Name: ypbind
|
Name: ypbind
|
||||||
Version: 1.20.4
|
Version: 1.20.4
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source0: ftp://ftp.us.kernel.org/pub/linux/utils/net/NIS/ypbind-mt-%{PACKAGE_VERSION}.tar.bz2
|
Source0: ftp://ftp.us.kernel.org/pub/linux/utils/net/NIS/ypbind-mt-%{PACKAGE_VERSION}.tar.bz2
|
||||||
@ -11,11 +11,13 @@ Patch1: ypbind-1.11-broadcast.patch
|
|||||||
Patch2: ypbind-1.11-gettextdomain.patch
|
Patch2: ypbind-1.11-gettextdomain.patch
|
||||||
Patch3: ypbind-mt-1.19-port-leak.patch
|
Patch3: ypbind-mt-1.19-port-leak.patch
|
||||||
Patch4: ypbind-mt-1.19-log-binds.patch
|
Patch4: ypbind-mt-1.19-log-binds.patch
|
||||||
Patch5: ypbind-1.19-debuginfo.patch
|
Patch5: ypbind-mt-1.20.4-smartwrite.patch
|
||||||
Patch6: ypbind-mt-1.20.4-smartwrite.patch
|
|
||||||
|
|
||||||
Prereq: /sbin/chkconfig
|
Requires(post): chkconfig
|
||||||
Requires: rpcbind, yp-tools, bash >= 2.0
|
Requires(preun): chkconfig
|
||||||
|
# This is for /sbin/service
|
||||||
|
Requires(preun): initscripts
|
||||||
|
Requires: rpcbind, yp-tools
|
||||||
Epoch: 3
|
Epoch: 3
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -41,12 +43,11 @@ also need to install the ypserv package to a machine on your network.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n ypbind-mt-%{version}
|
%setup -q -n ypbind-mt-%{version}
|
||||||
%patch1 -p1
|
%patch1 -p1 -b .broadcast
|
||||||
%patch2 -p1
|
%patch2 -p1 -b .gettextdomain
|
||||||
%patch3 -p1
|
%patch3 -p1 -b .port-leak
|
||||||
%patch4 -p1
|
%patch4 -p1 -b .log-binds
|
||||||
#%patch5 -p1
|
%patch5 -p1 -b .smartwrite
|
||||||
%patch6 -p1 -b .smartwrite
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf
|
autoreconf
|
||||||
@ -55,11 +56,11 @@ make
|
|||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
%makeinstall sbindir=$RPM_BUILD_ROOT/sbin
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d $RPM_BUILD_ROOT/var/yp/binding
|
mkdir -p $RPM_BUILD_ROOT/%{_initrddir} $RPM_BUILD_ROOT/var/yp/binding
|
||||||
install -m 644 etc/yp.conf $RPM_BUILD_ROOT/etc/yp.conf
|
install -m 644 etc/yp.conf $RPM_BUILD_ROOT/etc/yp.conf
|
||||||
install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ypbind
|
install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/%{_initrddir}/ypbind
|
||||||
|
|
||||||
%{find_lang} %{name}
|
%{find_lang} %{name}
|
||||||
|
|
||||||
@ -70,29 +71,33 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
/sbin/chkconfig --add ypbind
|
/sbin/chkconfig --add ypbind
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
if [ "$1" = 0 ] ; then
|
if [ $1 = 0 ] ; then
|
||||||
/sbin/service ypbind stop > /dev/null 2>&1
|
/sbin/service ypbind stop >/dev/null 2>&1
|
||||||
/sbin/chkconfig --del ypbind
|
/sbin/chkconfig --del ypbind
|
||||||
fi
|
fi
|
||||||
exit 0
|
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
if [ "$1" -ge 1 ]; then
|
if [ "$1" -ge "1" ] ; then
|
||||||
/sbin/service ypbind condrestart > /dev/null 2>&1
|
/sbin/service ypbind condrestart >/dev/null 2>&1 || :
|
||||||
fi
|
fi
|
||||||
exit 0
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
/sbin/ypbind
|
/sbin/ypbind
|
||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
%config /etc/rc.d/init.d/*
|
%{_initrddir}/*
|
||||||
%config(noreplace) /etc/yp.conf
|
%config(noreplace) /etc/yp.conf
|
||||||
%dir /var/yp
|
|
||||||
%dir /var/yp/binding
|
%dir /var/yp/binding
|
||||||
%doc README NEWS
|
%doc README NEWS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 21 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.20.4-9
|
||||||
|
- Merge Review - remove dot from end of the summary, convert all tags
|
||||||
|
in %%changelog to utf-8, escape %% character in changelog, fix
|
||||||
|
requires and scriptlets, remove %%makeinstall, do not mark init
|
||||||
|
script file as config, remove unused patches
|
||||||
|
Resolves: #226663
|
||||||
|
|
||||||
* Tue Oct 21 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.20.4-8
|
* Tue Oct 21 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.20.4-8
|
||||||
- Rewrite binding files only when they are changed
|
- Rewrite binding files only when they are changed
|
||||||
Resolves: #454581
|
Resolves: #454581
|
||||||
@ -203,7 +208,7 @@ exit 0
|
|||||||
- rebuilt
|
- rebuilt
|
||||||
|
|
||||||
* Wed May 21 2003 Bill Nottingham <notting@redhat.com> 1.12-1.10
|
* Wed May 21 2003 Bill Nottingham <notting@redhat.com> 1.12-1.10
|
||||||
- make yp.conf %config(noreplace)
|
- make yp.conf %%config(noreplace)
|
||||||
|
|
||||||
* Thu Apr 24 2003 Steve Dickson <SteveD@RedHat.com>
|
* Thu Apr 24 2003 Steve Dickson <SteveD@RedHat.com>
|
||||||
- Updated to 1.12 from upstream.
|
- Updated to 1.12 from upstream.
|
||||||
@ -268,7 +273,7 @@ exit 0
|
|||||||
* Sat Mar 3 2001 Preston Brown <pbrown@redhat.com>
|
* Sat Mar 3 2001 Preston Brown <pbrown@redhat.com>
|
||||||
- much more sane ypbind init script for when networking is down.
|
- much more sane ypbind init script for when networking is down.
|
||||||
|
|
||||||
* Wed Feb 7 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
* Wed Feb 7 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||||
- fix "usage" string (use $0)
|
- fix "usage" string (use $0)
|
||||||
|
|
||||||
* Wed Jan 24 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
* Wed Jan 24 2001 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||||
|
Loading…
Reference in New Issue
Block a user