updated to latest upstream version ypbind-mt-1.20.4
This commit is contained in:
parent
713c992128
commit
b8fb454273
@ -1 +1,2 @@
|
|||||||
ypbind-mt-1.19.tar.bz2
|
ypbind-mt-1.19.tar.bz2
|
||||||
|
ypbind-mt-1.20.4.tar.bz2
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
4878b742d61590501230aa8baa6a4f53 ypbind-mt-1.19.tar.bz2
|
266d2fb625d5511c4c5cc54a03bea00a ypbind-mt-1.20.4.tar.bz2
|
||||||
|
@ -1,5 +1,5 @@
|
|||||||
--- ypbind-mt-1.19/src/serv_list.c.orig 2006-12-01 13:47:28.000000000 -0500
|
--- ypbind-mt-1.20.4/src/serv_list.c.orig 2007-05-02 11:27:10.505406000 -0400
|
||||||
+++ ypbind-mt-1.19/src/serv_list.c 2006-12-01 14:00:09.000000000 -0500
|
+++ ypbind-mt-1.20.4/src/serv_list.c 2007-05-02 11:28:27.659681000 -0400
|
||||||
@@ -50,6 +50,8 @@
|
@@ -50,6 +50,8 @@
|
||||||
#include "local.h"
|
#include "local.h"
|
||||||
#include "pthread_np.h"
|
#include "pthread_np.h"
|
||||||
@ -9,7 +9,7 @@
|
|||||||
#if (defined(__sun__) || defined(sun)) && defined(__svr4__)
|
#if (defined(__sun__) || defined(sun)) && defined(__svr4__)
|
||||||
typedef uint32_t u_int32_t;
|
typedef uint32_t u_int32_t;
|
||||||
#endif
|
#endif
|
||||||
@@ -80,6 +82,22 @@ struct binding
|
@@ -80,6 +82,22 @@
|
||||||
struct bound_server ypset;
|
struct bound_server ypset;
|
||||||
CLIENT *client_handle;
|
CLIENT *client_handle;
|
||||||
};
|
};
|
||||||
@ -32,7 +32,7 @@
|
|||||||
|
|
||||||
static struct binding *domainlist = NULL;
|
static struct binding *domainlist = NULL;
|
||||||
static int max_domains = 0;
|
static int max_domains = 0;
|
||||||
@@ -224,6 +242,12 @@ change_binding (const char *domain, ypbi
|
@@ -224,6 +242,12 @@
|
||||||
pthread_rdwr_rlock_np (&domainlock);
|
pthread_rdwr_rlock_np (&domainlock);
|
||||||
update_bindingfile (&domainlist[i]);
|
update_bindingfile (&domainlist[i]);
|
||||||
pthread_rdwr_runlock_np (&domainlock);
|
pthread_rdwr_runlock_np (&domainlock);
|
||||||
@ -45,7 +45,7 @@
|
|||||||
|
|
||||||
return;
|
return;
|
||||||
}
|
}
|
||||||
@@ -792,6 +816,10 @@ ping_all (struct binding *list)
|
@@ -797,6 +821,10 @@
|
||||||
list->server[i].port = s_in.sin_port;
|
list->server[i].port = s_in.sin_port;
|
||||||
if (s_in.sin_port == 0)
|
if (s_in.sin_port == 0)
|
||||||
{
|
{
|
||||||
@ -56,7 +56,7 @@
|
|||||||
if (debug_flag)
|
if (debug_flag)
|
||||||
log_msg (LOG_DEBUG, _("host '%s' doesn't answer."),
|
log_msg (LOG_DEBUG, _("host '%s' doesn't answer."),
|
||||||
list->server[i].host);
|
list->server[i].host);
|
||||||
@@ -996,13 +1024,21 @@ ping_all (struct binding *list)
|
@@ -1001,13 +1029,21 @@
|
||||||
void
|
void
|
||||||
do_binding (void)
|
do_binding (void)
|
||||||
{
|
{
|
||||||
@ -79,7 +79,7 @@
|
|||||||
}
|
}
|
||||||
pthread_mutex_unlock (&search_lock);
|
pthread_mutex_unlock (&search_lock);
|
||||||
}
|
}
|
||||||
@@ -1031,7 +1067,8 @@ test_bindings (void *param __attribute__
|
@@ -1038,7 +1074,8 @@
|
||||||
pthread_exit (&success);
|
pthread_exit (&success);
|
||||||
|
|
||||||
lastcheck += ping_interval;
|
lastcheck += ping_interval;
|
||||||
@ -88,8 +88,8 @@
|
|||||||
+ if (lastcheck >= 60) /* 900 = 15min. */
|
+ if (lastcheck >= 60) /* 900 = 15min. */
|
||||||
lastcheck = 0;
|
lastcheck = 0;
|
||||||
|
|
||||||
lastcheck = test_bindings_once (lastcheck, NULL);
|
#if USE_DBUS_NM
|
||||||
@@ -1081,6 +1118,7 @@ retry:
|
@@ -1091,6 +1128,7 @@
|
||||||
domainlist[i].active = -1;
|
domainlist[i].active = -1;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -97,7 +97,7 @@
|
|||||||
if (domainlist[i].active != -1)
|
if (domainlist[i].active != -1)
|
||||||
{
|
{
|
||||||
/* The binding is in use, check if it is still valid and
|
/* The binding is in use, check if it is still valid and
|
||||||
@@ -1097,6 +1135,10 @@ retry:
|
@@ -1107,6 +1145,10 @@
|
||||||
YPPROC_DOMAIN, (xdrproc_t) ypbind_xdr_domainname,
|
YPPROC_DOMAIN, (xdrproc_t) ypbind_xdr_domainname,
|
||||||
(caddr_t) &domain, (xdrproc_t) xdr_bool,
|
(caddr_t) &domain, (xdrproc_t) xdr_bool,
|
||||||
(caddr_t) &out, time_out);
|
(caddr_t) &out, time_out);
|
||||||
@ -108,7 +108,7 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* time to search a new fastest server, but only if the current
|
/* time to search a new fastest server, but only if the current
|
||||||
@@ -1186,6 +1228,12 @@ retry:
|
@@ -1196,6 +1238,12 @@
|
||||||
pthread_mutex_unlock (&search_lock);
|
pthread_mutex_unlock (&search_lock);
|
||||||
pthread_rdwr_wlock_np (&domainlock);
|
pthread_rdwr_wlock_np (&domainlock);
|
||||||
}
|
}
|
||||||
@ -121,24 +121,26 @@
|
|||||||
} /* end for () all domains */
|
} /* end for () all domains */
|
||||||
|
|
||||||
pthread_rdwr_wunlock_np (&domainlock);
|
pthread_rdwr_wunlock_np (&domainlock);
|
||||||
--- ypbind-mt-1.19/src/ypbind-mt.c.orig 2006-12-01 13:47:28.000000000 -0500
|
--- ypbind-mt-1.20.4/src/ypbind-mt.c.orig 2007-05-02 11:27:10.482429000 -0400
|
||||||
+++ ypbind-mt-1.19/src/ypbind-mt.c 2006-12-01 13:55:04.000000000 -0500
|
+++ ypbind-mt-1.20.4/src/ypbind-mt.c 2007-05-02 11:30:00.067633000 -0400
|
||||||
@@ -463,12 +463,13 @@ sig_handler (void *v_param __attribute_
|
@@ -466,6 +466,7 @@
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
+int verbose_flag;
|
+int verbose_flag;
|
||||||
|
|
||||||
static void
|
static void
|
||||||
usage (void)
|
usage (int ret)
|
||||||
{
|
@@ -478,7 +479,7 @@
|
||||||
fputs (_("Usage:\n"), stderr);
|
output = stdout;
|
||||||
- fputs (_("\typbind [-broadcast | -ypset | -ypsetme] [-p port] [-f configfile]\n\t [-no-ping] [-broken-server] [-local-only] [-i ping-interval] [-debug]\n"), stderr);
|
|
||||||
+ fputs (_("\typbind [-broadcast | -ypset | -ypsetme] [-p port] [-f configfile]\n\t [-no-ping] [-broken-server] [-local-only] [-i ping-interval] [-debug] [-verbose]\n"), stderr);
|
fputs (_("Usage:\n"), output);
|
||||||
fputs (_("\typbind -c [-f configfile]\n"), stderr);
|
- fputs (_("\typbind [-broadcast | -ypset | -ypsetme] [-p port] [-f configfile]\n\t [-no-ping] [-broken-server] [-local-only] [-i ping-interval] [-debug]\n"), output);
|
||||||
fputs (_("\typbind --version\n"), stderr);
|
+ fputs (_("\typbind [-broadcast | -ypset | -ypsetme] [-p port] [-f configfile]\n\t [-no-ping] [-broken-server] [-local-only] [-i ping-interval] [-debug] [-verbose]\n"), output);
|
||||||
exit (1);
|
#ifdef USE_DBUS_NM
|
||||||
@@ -505,6 +506,9 @@ main (int argc, char **argv)
|
fputs (_("\t [-no-dbus]\n"), output);
|
||||||
|
#endif
|
||||||
|
@@ -656,6 +657,9 @@
|
||||||
else if (strcmp ("-d", argv[i]) == 0 ||
|
else if (strcmp ("-d", argv[i]) == 0 ||
|
||||||
strcmp ("-debug", argv[i]) == 0)
|
strcmp ("-debug", argv[i]) == 0)
|
||||||
debug_flag = 1;
|
debug_flag = 1;
|
||||||
@ -148,26 +150,28 @@
|
|||||||
else if (strcmp ("-broken-server", argv[i]) == 0 ||
|
else if (strcmp ("-broken-server", argv[i]) == 0 ||
|
||||||
strcmp ("-broken_server", argv[i]) == 0)
|
strcmp ("-broken_server", argv[i]) == 0)
|
||||||
broken_server = 1;
|
broken_server = 1;
|
||||||
--- ypbind-mt-1.19/man/ypbind.8.in.orig 2006-12-01 13:47:44.000000000 -0500
|
--- ypbind-mt-1.20.4/man/ypbind.8.xml.orig 2006-10-04 11:26:24.000000000 -0400
|
||||||
+++ ypbind-mt-1.19/man/ypbind.8.in 2006-12-01 13:55:04.000000000 -0500
|
+++ ypbind-mt-1.20.4/man/ypbind.8.xml 2007-05-02 11:33:11.128479000 -0400
|
||||||
@@ -31,6 +31,8 @@ ypbind
|
@@ -41,6 +41,7 @@
|
||||||
] [
|
<command>ypbind</command>
|
||||||
.BR \-d | \-debug
|
<arg choice='opt'>-c </arg>
|
||||||
] [
|
<group choice='opt'><arg choice='plain'>-d </arg><arg choice='plain'>-debug </arg></group>
|
||||||
+.BR \-v | \-verbose
|
+ <arg choice='opt'>-verbose </arg>
|
||||||
+] [
|
<arg choice='opt'>-broadcast </arg>
|
||||||
.B \-broadcast
|
<arg choice='opt'>-broken-server </arg>
|
||||||
] [
|
<arg choice='opt'>-ypset </arg>
|
||||||
.B \-broken-server
|
@@ -208,6 +209,14 @@
|
||||||
@@ -208,6 +210,11 @@ in debug mode.
|
</listitem>
|
||||||
will not put itself into background, and error messages and debug
|
</varlistentry>
|
||||||
output are written to standard error.
|
<varlistentry>
|
||||||
.TP
|
+ <term><option>-verbose</option></term>
|
||||||
+.B "\-verbose"
|
+ <listitem>
|
||||||
+Causes
|
+<para>Causes
|
||||||
+.B ypbind
|
+<command>ypbind</command>
|
||||||
+to syslog(2) any and all changes in the server its bound to.
|
+to syslog(2) any and all changes in the server its bound to.</para>
|
||||||
+.TP
|
+ </listitem>
|
||||||
.B "\-broken-server"
|
+ </varlistentry>
|
||||||
lets
|
+ <varlistentry>
|
||||||
.B ypbind
|
<term><option>-broken-server</option></term>
|
||||||
|
<listitem>
|
||||||
|
<para>lets
|
||||||
|
16
ypbind.spec
16
ypbind.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The NIS daemon which binds NIS clients to an NIS domain.
|
Summary: The NIS daemon which binds NIS clients to an NIS domain.
|
||||||
Name: ypbind
|
Name: ypbind
|
||||||
Version: 1.19
|
Version: 1.20.4
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source0: ftp://ftp.us.kernel.org/pub/linux/utils/net/NIS/ypbind-mt-%{PACKAGE_VERSION}.tar.bz2
|
Source0: ftp://ftp.us.kernel.org/pub/linux/utils/net/NIS/ypbind-mt-%{PACKAGE_VERSION}.tar.bz2
|
||||||
@ -9,9 +9,9 @@ Url: http://www.linux-nis.org/nis/ypbind-mt/index.html
|
|||||||
Source1: ypbind.init
|
Source1: ypbind.init
|
||||||
Patch1: ypbind-1.11-broadcast.patch
|
Patch1: ypbind-1.11-broadcast.patch
|
||||||
Patch2: ypbind-1.11-gettextdomain.patch
|
Patch2: ypbind-1.11-gettextdomain.patch
|
||||||
Patch3: ypbind-1.19-debuginfo.patch
|
Patch3: ypbind-mt-1.19-port-leak.patch
|
||||||
Patch4: ypbind-mt-1.19-port-leak.patch
|
Patch4: ypbind-mt-1.19-log-binds.patch
|
||||||
Patch5: ypbind-mt-1.19-log-binds.patch
|
Patch5: ypbind-1.19-debuginfo.patch
|
||||||
|
|
||||||
Prereq: /sbin/chkconfig
|
Prereq: /sbin/chkconfig
|
||||||
Requires: rpcbind, yp-tools, bash >= 2.0
|
Requires: rpcbind, yp-tools, bash >= 2.0
|
||||||
@ -19,6 +19,7 @@ Epoch: 3
|
|||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
BuildRequires: autoconf,automake
|
BuildRequires: autoconf,automake
|
||||||
|
BuildRequires: dbus-glib-devel, docbook-style-xsl
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Network Information Service (NIS) is a system that provides
|
The Network Information Service (NIS) is a system that provides
|
||||||
@ -43,7 +44,7 @@ also need to install the ypserv package to a machine on your network.
|
|||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch4 -p1
|
%patch4 -p1
|
||||||
%patch5 -p1
|
#%patch5 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf
|
autoreconf
|
||||||
@ -90,6 +91,9 @@ exit 0
|
|||||||
%doc README NEWS
|
%doc README NEWS
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 3 2007 Steve Dickson <steved@redhat.com> - 3:1.19.1-1
|
||||||
|
- updated to latest upstream version ypbind-mt-1.20.4
|
||||||
|
|
||||||
* Tue Apr 17 2007 Steve Dickson <steved@redhat.com> - 3:1.19-9
|
* Tue Apr 17 2007 Steve Dickson <steved@redhat.com> - 3:1.19-9
|
||||||
- Fixed typo in init script (bz 233459)
|
- Fixed typo in init script (bz 233459)
|
||||||
- Changed init script to look in /etc/yp.conf for the
|
- Changed init script to look in /etc/yp.conf for the
|
||||||
|
Loading…
Reference in New Issue
Block a user