New release 1.31
This commit is contained in:
parent
f84f698bea
commit
acd718da7e
@ -1 +1 @@
|
||||
ypbind-mt-1.29.91.tar.bz2
|
||||
ypbind-mt-1.31.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
ab196dbb9474481e1e879f3d8cc94e30 ypbind-mt-1.29.91.tar.bz2
|
||||
99383456e3a02cdc0863ecb24b8399e0 ypbind-mt-1.31.tar.bz2
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff -up ypbind-mt-1.20.4/src/ypbind_dbus_nm.c.signalstate ypbind-mt-1.20.4/src/ypbind_dbus_nm.c
|
||||
--- ypbind-mt-1.20.4/src/ypbind_dbus_nm.c.signalstate 2009-11-13 12:32:30.639389786 +0100
|
||||
+++ ypbind-mt-1.20.4/src/ypbind_dbus_nm.c 2009-11-13 12:34:30.429263750 +0100
|
||||
@@ -34,11 +34,12 @@
|
||||
|
||||
#ifdef HAVE_NETWORKMANAGER_NETWORKMANAGER_H
|
||||
#include <NetworkManager/NetworkManager.h>
|
||||
+#include <NetworkManager/NetworkManagerVPN.h>
|
||||
#else
|
||||
#define NM_DBUS_INTERFACE "org.freedesktop.NetworkManager"
|
||||
#define NM_DBUS_SERVICE "org.freedesktop.NetworkManager"
|
||||
#define NM_DBUS_PATH "/org/freedesktop/NetworkManager"
|
||||
-#define NM_DBUS_SIGNAL_STATE_CHANGE "StateChange"
|
||||
+#define NM_DBUS_VPN_SIGNAL_STATE_CHANGE "StateChange"
|
||||
|
||||
typedef enum NMState {
|
||||
NM_STATE_UNKNOWN = 0,
|
||||
@@ -138,7 +139,7 @@ dbus_filter (DBusConnection *connection,
|
||||
handled = DBUS_HANDLER_RESULT_HANDLED;
|
||||
}
|
||||
else if (dbus_message_is_signal (message, NM_DBUS_INTERFACE,
|
||||
- NM_DBUS_SIGNAL_STATE_CHANGE))
|
||||
+ NM_DBUS_VPN_SIGNAL_STATE_CHANGE))
|
||||
{
|
||||
NMState state = NM_STATE_UNKNOWN;
|
||||
|
@ -1,27 +0,0 @@
|
||||
diff -up ypbind-mt-1.29.91/man/ypbind.8.xml.man-port ypbind-mt-1.29.91/man/ypbind.8.xml
|
||||
--- ypbind-mt-1.29.91/man/ypbind.8.xml.man-port 2009-06-15 16:29:18.000000000 +0200
|
||||
+++ ypbind-mt-1.29.91/man/ypbind.8.xml 2009-10-26 17:55:32.000000000 +0100
|
||||
@@ -47,6 +47,7 @@
|
||||
<arg choice='opt'>-ypset </arg>
|
||||
<arg choice='opt'>-ypsetme </arg>
|
||||
<arg choice='opt'>-no-ping </arg>
|
||||
+ <arg choice='opt'>-p <replaceable>port</replaceable></arg>
|
||||
<arg choice='opt'>-f <replaceable>configfile</replaceable></arg>
|
||||
<arg choice='opt'>-local-only </arg>
|
||||
<arg choice='opt'>-ping-interval <replaceable>ping-interval</replaceable></arg>
|
||||
@@ -238,6 +239,15 @@ from keeping the connection unnecessaril
|
||||
</listitem>
|
||||
</varlistentry>
|
||||
<varlistentry>
|
||||
+ <term><option>-p</option> port</term>
|
||||
+ <listitem>
|
||||
+<para><command>ypbind</command>
|
||||
+will bind itself to this port. This makes it possible to have a router
|
||||
+filtering packets to the NIS ports, so that access to this service from
|
||||
+hosts on the Internet can be restricted.</para>
|
||||
+ </listitem>
|
||||
+ </varlistentry>
|
||||
+ <varlistentry>
|
||||
<term><option>-f</option> configfile</term>
|
||||
<listitem>
|
||||
<para><command>ypbind</command>
|
24
ypbind.spec
24
ypbind.spec
@ -1,7 +1,7 @@
|
||||
Summary: The NIS daemon which binds NIS clients to an NIS domain
|
||||
Name: ypbind
|
||||
Version: 1.29.91
|
||||
Release: 2%{?dist}
|
||||
Version: 1.31
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Daemons
|
||||
Source0: ftp://ftp.us.kernel.org/pub/linux/utils/net/NIS/ypbind-mt-%{version}.tar.bz2
|
||||
@ -9,13 +9,6 @@ Url: http://www.linux-nis.org/nis/ypbind-mt/index.html
|
||||
Source1: ypbind.init
|
||||
Source2: nis.sh
|
||||
Patch1: ypbind-1.11-gettextdomain.patch
|
||||
# Response from upstream: the -p option does not work in all situations
|
||||
# correctly and shouldn't be really used.
|
||||
# It is missing from the man page on purpose.
|
||||
Patch2: ypbind-mt-1.29.91-man-port.patch
|
||||
# Response from upstream: the patch will be a part of next release.
|
||||
# Fixes bug #537064.
|
||||
Patch3: ypbind-mt-1.20.4-signalstate.patch
|
||||
|
||||
Requires(post): chkconfig
|
||||
Requires(preun): chkconfig
|
||||
@ -48,11 +41,9 @@ also need to install the ypserv package to a machine on your network.
|
||||
%prep
|
||||
%setup -q -n ypbind-mt-%{version}
|
||||
%patch1 -p1 -b .gettextdomain
|
||||
%patch2 -p1 -b .man-port
|
||||
%patch3 -p1 -b .signalstate
|
||||
|
||||
%build
|
||||
%configure --sbindir=/sbin
|
||||
%configure --sbindir=/sbin --enable-dbus-nm
|
||||
make
|
||||
|
||||
%install
|
||||
@ -94,6 +85,15 @@ fi
|
||||
%doc README NEWS
|
||||
|
||||
%changelog
|
||||
* Mon Jan 4 2010 Karel Klic <kklic@redhat.com> - 3:1.31-1
|
||||
- Updated to version 1.31 from upstream
|
||||
- Removed signalstate patch because it was merged by upstream
|
||||
- Removed man-port patch, because it was rejected by
|
||||
the upstream. Option '-p' does not work in all cases, it
|
||||
is not supported, intentionally not included in
|
||||
the documentation, and it is also removed from the usage
|
||||
string in this version
|
||||
|
||||
* Fri Nov 19 2009 Karel Klic <kklic@redhat.com> - 3:1.29.91-2
|
||||
- Added signalstate patch, which fixes compilation with
|
||||
NetworkManaged-devel headers installed. Resolves #537064.
|
||||
|
Loading…
Reference in New Issue
Block a user