- Update patch for RH bug #437328.
This commit is contained in:
parent
d6be31bd81
commit
ed5ba6af32
@ -1,6 +1,40 @@
|
||||
diff -up yelp-2.22.0/configure.in.beagle-search yelp-2.22.0/configure.in
|
||||
--- yelp-2.22.0/configure.in.beagle-search 2008-03-31 10:20:10.000000000 -0400
|
||||
+++ yelp-2.22.0/configure.in 2008-03-31 10:20:10.000000000 -0400
|
||||
@@ -133,7 +133,12 @@ dnl ******
|
||||
dnl beagle
|
||||
dnl ******
|
||||
|
||||
-BEAGLE_MODULES="libbeagle-0.0 >= 0.2.4"
|
||||
+BEAGLE_MODULES=
|
||||
+if $PKG_CONFIG --exists libbeagle-1.0; then
|
||||
+ BEAGLE_MODULES="libbeagle-1.0 >= 0.3.0"
|
||||
+else
|
||||
+ BEAGLE_MODULES="libbeagle-0.0 >= 0.2.4"
|
||||
+fi
|
||||
|
||||
AC_ARG_WITH([search],
|
||||
[AC_HELP_STRING([--with-search=basic|beagle|auto],
|
||||
diff -up yelp-2.22.0/configure.beagle-search yelp-2.22.0/configure
|
||||
--- yelp-2.22.0/configure.beagle-search 2008-03-31 10:20:41.000000000 -0400
|
||||
+++ yelp-2.22.0/configure 2008-03-31 10:22:02.000000000 -0400
|
||||
@@ -26663,7 +26663,12 @@ fi
|
||||
|
||||
|
||||
|
||||
-BEAGLE_MODULES="libbeagle-0.0 >= 0.2.4"
|
||||
+BEAGLE_MODULES=
|
||||
+if $PKG_CONFIG --exists libbeagle-1.0; then
|
||||
+ BEAGLE_MODULES="libbeagle-1.0 >= 0.3.0"
|
||||
+else
|
||||
+ BEAGLE_MODULES="libbeagle-0.0 >= 0.2.4"
|
||||
+fi
|
||||
|
||||
|
||||
# Check whether --with-search was given.
|
||||
diff -up yelp-2.22.0/src/yelp-search-parser.c.beagle-search yelp-2.22.0/src/yelp-search-parser.c
|
||||
--- yelp-2.22.0/src/yelp-search-parser.c.beagle-search 2008-03-09 15:00:42.000000000 -0400
|
||||
+++ yelp-2.22.0/src/yelp-search-parser.c 2008-03-13 14:16:15.000000000 -0400
|
||||
+++ yelp-2.22.0/src/yelp-search-parser.c 2008-03-31 10:20:10.000000000 -0400
|
||||
@@ -314,7 +314,8 @@ check_finished (YelpSearchParser *parser
|
||||
g_free (check);
|
||||
xmlNewTextChild (parser->root, NULL, BAD_CAST "online1", BAD_CAST split[1]);
|
||||
|
@ -20,7 +20,7 @@
|
||||
Summary: A system documentation reader from the Gnome project
|
||||
Name: yelp
|
||||
Version: 2.22.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Source: http://ftp.gnome.org/pub/GNOME/sources/yelp/2.21/%{name}-%{version}.tar.bz2
|
||||
URL: http://live.gnome.org/Yelp
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=319096
|
||||
@ -81,7 +81,7 @@ BuildRequires: rarian-devel >= %{rarian_version}
|
||||
|
||||
|
||||
%if %{WITH_MONO}
|
||||
BuildRequires: libbeagle-devel
|
||||
BuildRequires: libbeagle-devel
|
||||
%endif
|
||||
|
||||
%description
|
||||
@ -163,6 +163,9 @@ update-desktop-database &> /dev/null ||:
|
||||
%{_datadir}/yelp
|
||||
|
||||
%changelog
|
||||
* Mon Mar 31 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3
|
||||
- Update patch for RH bug #437328.
|
||||
|
||||
* Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
|
||||
- Add patch for RH bug #437328 (searching with Beagle broken).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user