2.21.1
This commit is contained in:
parent
21acfb0688
commit
63e49ecf0d
@ -1 +1 @@
|
|||||||
yelp-2.20.0.tar.bz2
|
yelp-2.21.1.tar.bz2
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
diff -up yelp-2.20.0/src/yelp-window.c.rarian-crash yelp-2.20.0/src/yelp-window.c
|
|
||||||
--- yelp-2.20.0/src/yelp-window.c.rarian-crash 2007-11-04 22:50:04.000000000 -0500
|
|
||||||
+++ yelp-2.20.0/src/yelp-window.c 2007-11-04 22:51:25.000000000 -0500
|
|
||||||
@@ -1584,9 +1584,9 @@ window_do_load_html (YelpWindow *wind
|
|
||||||
goto done;
|
|
||||||
}
|
|
||||||
|
|
||||||
- base_uri = g_filename_to_uri (real_uri, NULL, NULL);
|
|
||||||
+ base_uri = g_filename_to_uri (uri, NULL, NULL);
|
|
||||||
if (frag_id) {
|
|
||||||
- real_uri = g_strconcat (base_uri, "#", frag_id);
|
|
||||||
+ real_uri = g_strconcat (base_uri, "#", frag_id, NULL);
|
|
||||||
g_free (base_uri);
|
|
||||||
} else {
|
|
||||||
real_uri = base_uri;
|
|
@ -1,17 +0,0 @@
|
|||||||
diff -up yelp-2.20.0/src/yelp-search-parser.c.search-crash yelp-2.20.0/src/yelp-search-parser.c
|
|
||||||
--- yelp-2.20.0/src/yelp-search-parser.c.search-crash 2007-09-17 16:49:09.000000000 -0400
|
|
||||||
+++ yelp-2.20.0/src/yelp-search-parser.c 2007-11-05 18:13:09.000000000 -0500
|
|
||||||
@@ -1074,8 +1074,11 @@ slow_search_process (RrnReg *reg, Search
|
|
||||||
|
|
||||||
ptr = g_strrstr (container->base_filename, "/");
|
|
||||||
|
|
||||||
- path = g_strndup (container->base_filename,
|
|
||||||
- ptr - container->base_filename);
|
|
||||||
+ if (ptr)
|
|
||||||
+ path = g_strndup (container->base_filename,
|
|
||||||
+ ptr - container->base_filename);
|
|
||||||
+ else
|
|
||||||
+ path = g_strdup (container->base_filename);
|
|
||||||
|
|
||||||
/* BEGIN HTML special block */
|
|
||||||
if (reg->type && (g_str_equal (reg->type, "text/html") ||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
8902618c343093b1c64ee6d647ec41ed yelp-2.20.0.tar.bz2
|
94cc5f45792ba5e11a338ce30442c35a yelp-2.21.1.tar.bz2
|
||||||
|
15
yelp.spec
15
yelp.spec
@ -19,18 +19,14 @@
|
|||||||
|
|
||||||
Summary: A system documentation reader from the Gnome project
|
Summary: A system documentation reader from the Gnome project
|
||||||
Name: yelp
|
Name: yelp
|
||||||
Version: 2.20.0
|
Version: 2.21.1
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
Source: http://ftp.gnome.org/pub/GNOME/sources/yelp/2.20/%{name}-%{version}.tar.bz2
|
Source: http://ftp.gnome.org/pub/GNOME/sources/yelp/2.21/%{name}-%{version}.tar.bz2
|
||||||
URL: http://live.gnome.org/Yelp
|
URL: http://live.gnome.org/Yelp
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=319096
|
# http://bugzilla.gnome.org/show_bug.cgi?id=319096
|
||||||
Patch1: yelp-2.15.5-fedora-docs.patch
|
Patch1: yelp-2.15.5-fedora-docs.patch
|
||||||
Patch2: yelp-2.13.2-add-mime-handling.patch
|
Patch2: yelp-2.13.2-add-mime-handling.patch
|
||||||
Patch3: yelp-2.15.91-use-pango.patch
|
Patch3: yelp-2.15.91-use-pango.patch
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=493594
|
|
||||||
Patch4: rarian-crash.patch
|
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=493751
|
|
||||||
Patch5: search-crash.patch
|
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=497559
|
# http://bugzilla.gnome.org/show_bug.cgi?id=497559
|
||||||
Patch6: hp.patch
|
Patch6: hp.patch
|
||||||
# http://bugzilla.gnome.org/show_bug.cgi?id=499744
|
# http://bugzilla.gnome.org/show_bug.cgi?id=499744
|
||||||
@ -94,8 +90,6 @@ one central tool.
|
|||||||
%patch1 -p1 -b .fedora-docs
|
%patch1 -p1 -b .fedora-docs
|
||||||
%patch2 -p1 -b .add-mime-handling
|
%patch2 -p1 -b .add-mime-handling
|
||||||
%patch3 -p1 -b .use-pango
|
%patch3 -p1 -b .use-pango
|
||||||
%patch4 -p1 -b .rarian-crash
|
|
||||||
%patch5 -p1 -b .search-crash
|
|
||||||
%patch6 -p1 -b .hp
|
%patch6 -p1 -b .hp
|
||||||
%patch7 -p1 -b .xl
|
%patch7 -p1 -b .xl
|
||||||
%patch8 -p1 -b .xl2
|
%patch8 -p1 -b .xl2
|
||||||
@ -163,6 +157,9 @@ update-desktop-database &> /dev/null ||:
|
|||||||
%{_datadir}/yelp
|
%{_datadir}/yelp
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 3 2007 Matthias Clasen <mclasen@redhat.com> - 2.21.1-1
|
||||||
|
- Update to 2.21.1
|
||||||
|
|
||||||
* Mon Dec 3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-9
|
* Mon Dec 3 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-9
|
||||||
- Rebuild against xulrunner again
|
- Rebuild against xulrunner again
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user