Update to 3.13.3
This commit is contained in:
parent
d9901348b6
commit
39eac6f397
@ -1,62 +0,0 @@
|
||||
From b76206bbdeb710853f585942377badff0a4c1df9 Mon Sep 17 00:00:00 2001
|
||||
From: Matthias Clasen <mclasen@redhat.com>
|
||||
Date: Thu, 8 Nov 2012 21:43:31 -0500
|
||||
Subject: [PATCH] Don't steal focus, optionally
|
||||
|
||||
It is somewhat rude to steal focus like this, and it actively
|
||||
interferes with some use cases for launching yelp in the background.
|
||||
Add a commandline option --dont-steal-focus, to make those
|
||||
use cases work.
|
||||
---
|
||||
src/yelp-application.c | 20 ++++++++++++--------
|
||||
1 file changed, 12 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/src/yelp-application.c b/src/yelp-application.c
|
||||
index 057cafd..2d004c2 100644
|
||||
--- a/src/yelp-application.c
|
||||
+++ b/src/yelp-application.c
|
||||
@@ -43,6 +43,7 @@
|
||||
#define DEFAULT_URI "help:gnome-help"
|
||||
|
||||
static gboolean editor_mode = FALSE;
|
||||
+static gboolean dont_steal_focus = FALSE;
|
||||
|
||||
enum {
|
||||
READ_LATER_CHANGED,
|
||||
@@ -63,6 +64,7 @@ option_version_cb (const gchar *option_name,
|
||||
|
||||
static const GOptionEntry entries[] = {
|
||||
{"editor-mode", 0, 0, G_OPTION_ARG_NONE, &editor_mode, N_("Turn on editor mode"), NULL},
|
||||
+ {"dont-steal-focus", 0, 0, G_OPTION_ARG_NONE, &dont_steal_focus, N_("Don't steal focus"), NULL},
|
||||
{ "version", 0, G_OPTION_FLAG_NO_ARG | G_OPTION_FLAG_HIDDEN, G_OPTION_ARG_CALLBACK, option_version_cb, NULL, NULL },
|
||||
{ NULL }
|
||||
};
|
||||
@@ -472,15 +474,17 @@ application_uri_resolved (YelpUri *uri,
|
||||
if (gdk_window)
|
||||
gdk_x11_window_move_to_current_desktop (gdk_window);
|
||||
|
||||
- /* Ensure we actually present the window when invoked from the command
|
||||
- * line. This is somewhat evil, but the minor evil of Yelp stealing
|
||||
- * focus (after you requested it) is outweighed for me by the major
|
||||
- * evil of no help window appearing when you click Help.
|
||||
- */
|
||||
- if (data->timestamp == 0)
|
||||
- data->timestamp = gdk_x11_get_server_time (gtk_widget_get_window (GTK_WIDGET (window)));
|
||||
+ if (!dont_steal_focus) {
|
||||
+ /* Ensure we actually present the window when invoked from the command
|
||||
+ * line. This is somewhat evil, but the minor evil of Yelp stealing
|
||||
+ * focus (after you requested it) is outweighed for me by the major
|
||||
+ * evil of no help window appearing when you click Help.
|
||||
+ */
|
||||
+ if (data->timestamp == 0)
|
||||
+ data->timestamp = gdk_x11_get_server_time (gtk_widget_get_window (GTK_WIDGET (window)));
|
||||
|
||||
- gtk_window_present_with_time (GTK_WINDOW (window), data->timestamp);
|
||||
+ gtk_window_present_with_time (GTK_WINDOW (window), data->timestamp);
|
||||
+ }
|
||||
|
||||
g_object_unref (uri);
|
||||
g_free (data);
|
||||
--
|
||||
1.7.12.1
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
02f0383b02960766ea46059b9a02cf85 yelp-3.12.0.tar.xz
|
||||
a49b10c1a9e78c88ccb1f7e306935812 yelp-3.13.3.tar.xz
|
||||
|
12
yelp.spec
12
yelp.spec
@ -3,13 +3,11 @@
|
||||
Summary: Help browser for the GNOME desktop
|
||||
Name: yelp
|
||||
Epoch: 1
|
||||
Version: 3.12.0
|
||||
Release: 2%{?dist}
|
||||
Version: 3.13.3
|
||||
Release: 1%{?dist}
|
||||
#VCS: git:git://git.gnome.org/yelp
|
||||
Source: http://download.gnome.org/sources/yelp/3.12/%{name}-%{version}.tar.xz
|
||||
Source: http://download.gnome.org/sources/yelp/3.13/%{name}-%{version}.tar.xz
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=687957
|
||||
Patch0: 0001-Don-t-steal-focus-optionally.patch
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=687960
|
||||
Patch1: 0001-Center-new-windows.patch
|
||||
|
||||
@ -63,7 +61,6 @@ the libraries in the yelp-libs package.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
@ -123,6 +120,9 @@ gtk-update-icon-cache %{_datadir}icons/hicolor &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 24 2014 Richard Hughes <rhughes@redhat.com> - 1:3.13.3-1
|
||||
- Update to 3.13.3
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.12.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user