Drop unused patches

This commit is contained in:
Christopher Aillon 2011-05-24 07:08:26 -07:00
parent 37349a8227
commit 32385fd0c1
9 changed files with 0 additions and 1636 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,47 +0,0 @@
--- yelp-2.20.0/src/yelp-man-parser.c 2007-09-17 16:49:09.000000000 -0400
+++ hacked/src/yelp-man-parser.c 2007-11-16 20:00:34.000000000 -0500
@@ -501,7 +501,12 @@
static void
macro_hanging_paragraph_handler (YelpManParser *parser, gchar *macro, GSList *args)
{
- parser_stack_pop_node (parser, "IP");
+ xmlNodePtr tmpNode;
+
+ tmpNode = parser_stack_pop_node (parser, "HP");
+
+ if (tmpNode != NULL)
+ parser->ins = tmpNode->parent;
parser->ins = parser_append_node (parser, macro);
@@ -510,6 +515,8 @@
parser_append_given_text (parser, args->data);
parser->ins = parser->ins->parent;
}
+
+ parser_stack_push_node (parser, parser->ins);
}
/* BSD mandoc macros
--- yelp-2.20.0/stylesheets/man2html.xsl 2007-09-17 16:49:10.000000000 -0400
+++ hacked/stylesheets/man2html.xsl 2007-11-16 22:19:34.000000000 -0500
@@ -85,6 +85,8 @@
span[class~="Section"] { margin-left: 0.4em; }
dd { padding-bottom: 10px; }
+
+ p[class~="HP"] { text-indent: -2em; margin-left: 2em; }
</xsl:text>
</xsl:template>
@@ -204,6 +206,10 @@
<p><xsl:apply-templates/></p>
</xsl:template>
+<xsl:template match="HP">
+ <p class="HP"><xsl:apply-templates/></p>
+</xsl:template>
+
<xsl:template match="ROW">
<tr><xsl:apply-templates/></tr>
</xsl:template>

View File

@ -1,13 +0,0 @@
diff -up yelp-2.29.5/src/Makefile.am.libs yelp-2.29.5/src/Makefile.am
--- yelp-2.29.5/src/Makefile.am.libs 2010-03-10 23:50:02.021505526 -0500
+++ yelp-2.29.5/src/Makefile.am 2010-03-10 23:50:16.258506223 -0500
@@ -93,7 +93,8 @@ yelp_LDADD = \
$(X_LIBS) \
$(MOZILLA_COMPONENT_LIBS) \
$(MOZILLA_EXTRA_LIBS) \
- $(MOZILLA_GLUE_LIBS)
+ $(MOZILLA_GLUE_LIBS) \
+ -ldl
yelp_LDFLAGS = $(AM_LDFLAGS)

View File

@ -1,12 +0,0 @@
diff -up yelp-2.25.1/configure.in.libxul yelp-2.25.1/configure.in
--- yelp-2.25.1/configure.in.libxul 2009-03-02 01:13:20.000000000 -0500
+++ yelp-2.25.1/configure.in 2009-03-02 08:03:44.000000000 -0500
@@ -251,7 +251,7 @@ if test "$MOZILLA" = "libxul-embedding"
PKG_CHECK_MODULES([MOZILLA_COMPONENT],[$MOZILLA $gecko_cv_extra_pkg_dependencies])
MOZILLA_COMPONENT_CFLAGS="$MOZILLA_COMPONENT_CFLAGS `$PKG_CONFIG --cflags ${gecko_cv_gecko}` `$PKG_CONFIG --define-variable=includetype=unstable --cflags ${gecko_cv_gecko}`"
else
- PKG_CHECK_MODULES([MOZILLA_COMPONENT],[${gecko_cv_gecko}-xpcom >= $gecko_min_version $gecko_cv_extra_pkg_dependencies])
+ PKG_CHECK_MODULES([MOZILLA_COMPONENT],[${gecko_cv_gecko} >= $gecko_min_version $gecko_cv_extra_pkg_dependencies])
fi
# Set flags

View File

@ -1,7 +0,0 @@
--- yelp-2.13.2/yelp.desktop.in.in.add-mime-handling 2005-12-15 19:16:20.000000000 -0500
+++ yelp-2.13.2/yelp.desktop.in.in 2005-12-15 19:18:18.000000000 -0500
@@ -12,3 +12,4 @@
X-GNOME-Bugzilla-Product=Yelp
X-GNOME-Bugzilla-Component=general
X-GNOME-Bugzilla-Version=@VERSION@
+MimeType=application/docbook+xml

View File

@ -1,21 +0,0 @@
--- yelp-2.15.91/src/yelp-main.c.use-pango 2006-08-29 12:18:35.000000000 -0400
+++ yelp-2.15.91/src/yelp-main.c 2006-08-29 12:19:07.000000000 -0400
@@ -403,18 +403,6 @@
}
if (private || !main_is_running ()) {
- const gchar *env;
-
- /* workaround for bug #329461 */
- env = g_getenv ("MOZ_ENABLE_PANGO");
-
- if (env == NULL ||
- *env == '\0' ||
- g_str_equal(env, "0"))
- {
- g_setenv ("MOZ_DISABLE_PANGO", "1", TRUE);
- }
-
if (session_started) {
main_restore_session ();
} else {

View File

@ -1,16 +0,0 @@
--- yelp-2.18.1/src/yelp-utils.c.posix-man 2007-04-18 12:51:28.000000000 -0400
+++ yelp-2.18.1/src/yelp-utils.c 2007-04-18 12:51:32.000000000 -0400
@@ -807,8 +807,11 @@
if ((cur = strchr (path, ')')))
man_num = g_strndup (path, cur - path);
if (man_num[0]) {
- man_dir = g_new (gchar, 5);
- g_snprintf (man_dir, 5, "man%c", man_num[0]);
+ man_dir = g_new (gchar, 6);
+ if (man_num[1] == 'p')
+ g_snprintf (man_dir, 6, "man%cp", man_num[0]);
+ else
+ g_snprintf (man_dir, 5, "man%c", man_num[0]);
}
} else {
man_name = g_strdup (path);

View File

@ -1,12 +0,0 @@
diff -up yelp-2.31.6/src/yelp-application.c.keyfile yelp-2.31.6/src/yelp-application.c
--- yelp-2.31.6/src/yelp-application.c.keyfile 2010-06-30 00:33:20.746211407 -0400
+++ yelp-2.31.6/src/yelp-application.c 2010-06-30 00:34:19.608212315 -0400
@@ -224,7 +224,7 @@ application_setup (YelpApplication *app)
gchar *keyfile = g_build_filename (g_get_user_config_dir (),
"yelp", "yelp.cfg",
NULL);
- priv->backend = g_keyfile_settings_backend_new (keyfile);
+ priv->backend = g_keyfile_settings_backend_new (keyfile, "/org/gnome/yelp", NULL);
priv->gsettings = g_settings_new_with_backend ("org.gnome.yelp",
priv->backend);
g_free (keyfile);

View File

@ -1,22 +0,0 @@
diff -up yelp-2.27.4/src/yelp-main.c.use-pango yelp-2.27.4/src/yelp-main.c
--- yelp-2.27.4/src/yelp-main.c.use-pango 2009-08-06 20:18:11.000000000 -0400
+++ yelp-2.27.4/src/yelp-main.c 2009-08-24 23:20:45.955969896 -0400
@@ -412,18 +412,6 @@ main (int argc, char **argv)
#endif /* WITH_SMCLIENT */
if (private || !main_is_running ()) {
- const gchar *env;
-
- /* workaround for bug #329461 */
- env = g_getenv ("MOZ_ENABLE_PANGO");
-
- if (env == NULL ||
- *env == '\0' ||
- g_str_equal(env, "0"))
- {
- g_setenv ("MOZ_DISABLE_PANGO", "1", TRUE);
- }
-
if (session_started) {
main_restore_session ();
} else {