- updated xulrunner patch, rebuild against xulrunner

This commit is contained in:
Martin Stransky 2008-02-28 15:05:21 +00:00
parent fb20623a3d
commit 294cce2715
2 changed files with 57 additions and 8 deletions

View File

@ -1,8 +1,45 @@
diff -up yelp-2.21.2/configure.libxul yelp-2.21.2/configure
--- yelp-2.21.2/configure.libxul 2008-01-08 16:46:27.000000000 -0500
+++ yelp-2.21.2/configure 2008-01-08 16:47:38.000000000 -0500
@@ -27017,10 +27017,10 @@ seamonkey) gecko_cv_gecko_flavour=mozill
xulrunner) gecko_cv_gecko_flavour=toolkit ;;
diff -up yelp-2.21.90/src/Makefile.in.libxul yelp-2.21.90/src/Makefile.in
--- yelp-2.21.90/src/Makefile.in.libxul 2008-01-28 22:59:48.000000000 +0100
+++ yelp-2.21.90/src/Makefile.in 2008-02-28 18:26:05.000000000 +0100
@@ -353,6 +353,7 @@ mozilla_include_subdirs = \
yelp_CPPFLAGS = \
-I$(top_srcdir) \
-I$(top_builddir)/src \
+ $(MOZILLA_COMPONENT_CFLAGS) \
$(addprefix -I$(MOZILLA_INCLUDE_ROOT)/,$(mozilla_include_subdirs)) \
$(YELP_DEFINES) \
$(AM_CPPFLAGS)
diff -up yelp-2.21.90/configure.libxul yelp-2.21.90/configure
--- yelp-2.21.90/configure.libxul 2008-01-28 22:59:38.000000000 +0100
+++ yelp-2.21.90/configure 2008-02-28 18:26:05.000000000 +0100
@@ -1597,7 +1597,7 @@ Optional Packages:
--with-x use the X Window System
--with-search=basic|beagle|auto
turn on search support [default=auto]
- --with-gecko[=mozilla|firefox|seamonkey|xulrunner]
+ --with-gecko[=mozilla|firefox|seamonkey|libxul]
Which gecko engine to use (autodetected by default)
@@ -26977,10 +26977,10 @@ fi
gecko_cv_gecko=$with_gecko
# Autodetect gecko
-_geckos="xulrunner firefox mozilla-firefox seamonkey mozilla"
+_geckos="libxul firefox mozilla-firefox seamonkey mozilla"
if test -z "$gecko_cv_gecko"; then
for lizard in $_geckos; do
- if $PKG_CONFIG --exists $lizard-xpcom; then
+ if $PKG_CONFIG --exists $lizard; then
gecko_cv_gecko=$lizard
break;
fi
@@ -27014,13 +27014,13 @@ case "$gecko_cv_gecko" in
mozilla) gecko_cv_gecko_flavour=mozilla ;;
seamonkey) gecko_cv_gecko_flavour=mozilla ;;
*firefox) gecko_cv_gecko_flavour=toolkit ;;
-xulrunner) gecko_cv_gecko_flavour=toolkit ;;
+libxul*) gecko_cv_gecko_flavour=toolkit ;;
esac
-_GECKO_INCLUDE_ROOT="`$PKG_CONFIG --variable=includedir ${gecko_cv_gecko}-xpcom`"
@ -16,6 +53,15 @@ diff -up yelp-2.21.2/configure.libxul yelp-2.21.2/configure
fi # if gecko_cv_have_gecko
@@ -27566,7 +27566,7 @@ MOZILLA_GLUE_LIBS="$gecko_cv_glue_libs"
case "$MOZILLA" in
-xulrunner) gecko_min_version=1.8 ;;
+libxul*) gecko_min_version=1.8 ;;
*firefox) gecko_min_version=1.5 ;;
*) { { echo "$as_me:$LINENO: error: $gecko_cv_gecko is not supported" >&5
echo "$as_me: error: $gecko_cv_gecko is not supported" >&2;}
@@ -27583,12 +27583,12 @@ if test -n "$PKG_CONFIG"; then
pkg_cv_MOZILLA_COMPONENT_CFLAGS="$MOZILLA_COMPONENT_CFLAGS"
else
@ -28,7 +74,7 @@ diff -up yelp-2.21.2/configure.libxul yelp-2.21.2/configure
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; then
- pkg_cv_MOZILLA_COMPONENT_CFLAGS=`$PKG_CONFIG --cflags "${gecko_cv_gecko}-xpcom >= $gecko_min_version $gecko_cv_extra_pkg_dependencies" 2>/dev/null`
+ pkg_cv_MOZILLA_COMPONENT_CFLAGS=`$PKG_CONFIG --cflags "libxul >= $gecko_min_version $gecko_cv_extra_pkg_dependencies" 2>/dev/null`
+ pkg_cv_MOZILLA_COMPONENT_CFLAGS=`$PKG_CONFIG --cflags libxul libxul-unstable 2>/dev/null`
else
pkg_failed=yes
fi

View File

@ -20,7 +20,7 @@
Summary: A system documentation reader from the Gnome project
Name: yelp
Version: 2.21.90
Release: 3%{?dist}
Release: 4%{?dist}
Source: http://ftp.gnome.org/pub/GNOME/sources/yelp/2.21/%{name}-%{version}.tar.bz2
URL: http://live.gnome.org/Yelp
# http://bugzilla.gnome.org/show_bug.cgi?id=319096
@ -100,7 +100,7 @@ one central tool.
%build
%configure \
--enable-search \
--with-mozilla=xulrunner\
--with-mozilla=libxul \
--enable-man \
--enable-info \
--disable-schemas-install
@ -159,6 +159,9 @@ update-desktop-database &> /dev/null ||:
%{_datadir}/yelp
%changelog
* Thu Feb 28 2008 Martin Stransky <stransky@redhat.com> - 2.21.90-4
- updated xulrunner patch, rebuild against xulrunner
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.21.90-3
- Autorebuild for GCC 4.3